The pfSense Store

Author Topic: ACME / Let's Encrypt - ""Registration key is already in use" and malformed  (Read 272 times)

0 Members and 1 Guest are viewing this topic.

Offline riahc3

  • Full Member
  • ***
  • Posts: 137
  • Karma: +3/-4
    • View Profile
Im getting two errors when trying to make the cert.

First ""Registration key is already in use" and then   "

type": "urn:acme:error:malformed",
  "detail": "Provided agreement URL [https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf] does not match current agreement URL [https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf]",
  "status": 400

As well.

Is the package broken?

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21488
  • Karma: +1456/-26
    • View Profile
Re: ACME / Let's Encrypt - ""Registration key is already in use" and malformed
« Reply #1 on: December 28, 2017, 03:15:24 pm »
That has been fixed for weeks. Update your ACME package, and if you don't see an update for the ACME package, update your firewall to the latest version and then it should pick up the update along the way.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline riahc3

  • Full Member
  • ***
  • Posts: 137
  • Karma: +3/-4
    • View Profile
Im seeing version 0.1.16 No updates for it.

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2283
  • Karma: +173/-9
    • View Profile
Im seeing version 0.1.16
That's old.
"ACME" is package that has very regularly updates - checkout this forum https://forum.pfsense.org/index.php?board=15.0
See image for the latest version I have today - using of course, the latest pfSense version.

No updates for it.
https://github.com/pfsense/FreeBSD-ports/commits/devel/security/pfSense-pkg-acme ....
Your pfSense doesn't locate packages anymore ? Updates ? What is your pfSense version ?

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21488
  • Karma: +1456/-26
    • View Profile
Im seeing version 0.1.16 No updates for it.

Update pfSense then, because if you don't see 0.1.30 then you are not on a current version of pfSense.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!