pfSense Gold Subscription

Author Topic: pfSense - Cannot connect to Netflix and Hulu on Andriod devices / Smart TVs  (Read 366 times)

0 Members and 1 Guest are viewing this topic.

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Happy Holidays everyone, any help is super appreciated.

I'm brand new to pfSense (installed last night), but comfortable in this area.

This one has me stumped for the last few hours--  only Netflix and Hulu can no longer connect over specific devices.

iPhone 7 & iPad Pro - working great
Windows PC - working great
Macbook Air - working great
Android Tablet / Roku Smart TVs - Netflix "NW-2-5" error when connecting ; Hulu - previews load, when trying to watch a stream I get "something is wrong with your connection"

Firewall logs at the time of connection show nothing from these device IPs.

I've spent ~30 minutes searching for this same error

Anyone heard of this before?

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Shoot happens with Amazon Video on Android / Smart TVs too.

I'm tempted to hardwire the TVs into ISP routers / skipping the pfSense firewall.

Found another other thread-- but dude didn't remember his fix.
https://forum.pfsense.org/index.php?topic=141791.0

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
And it gets worse.

Amazon Echo and Echo Dot no longer connect / even when going through factory reset.

Crap-- what could be going on?

Offline chpalmer

  • Hero Member
  • *****
  • Posts: 1787
  • Karma: +93/-3
    • View Profile
    • Home of Cablenut
P.S. statements made by me are not necessarily condoned by the management of this fine organization.  http://badmodems.com

Offline bcruze

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +1/-0
    • View Profile
firewall > rules > lan

add a static entry for each of the devices.   

edit the gateway of EACH statically created device and change it to gateway/ WAN interface.

this works for both PIA and nordvpn

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
firewall > rules > lan

add a static entry for each of the devices.   

edit the gateway of EACH statically created device and change it to gateway/ WAN interface.

this works for both PIA and nordvpn

thanks, but it unfortunately didn't make a difference

Network: 192.168.100.20/32  (IP address of a Smart TV)
Gateway: 192.168.2.1 (Gateway of WAN2)
Interface: <Interface is correct>

I'm using dual-WANs through a gateway group. 

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
I'm also not using a VPN.

It's just pfSense 2.4.2 basic configuration w/ a gateway group setup for Dual WANs.

I'm going to erase and install 2.3.5

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
pfSense 2.3.5, out of the box, didn't configure anything but 1 WAN and LAN through the initial install prompts.

Same situation- Netflix, Hulu, Amazon Video all fail to load on the Smart TVs.

Zero issues with Apple and MSFT products.

This is really frustrating

Offline Rai80

  • Newbie
  • *
  • Posts: 10
  • Karma: +1/-0
    • View Profile
IPV6 in play?

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
IPV6 in play?

Got it disabled / set to "None" on the WAN / LAN interfaces

Temporarily setup a Floating Firewall rule to Deny any IPv6 Traffic - source anywhere, destination anywhere-- but didn't make a difference.

Poor Amazon Echo won't connect either :/

Offline molykule

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-0
    • View Profile
Re: pfSense - Cannot connect to Netflix and Hulu on Andriod devices / Smart TVs
« Reply #10 on: December 29, 2017, 07:04:22 pm »
Hi,

Heres what i have done. Please make an alias with all the static assigned IP's of media devices. Create a floating rule for that alias and ope the ports for it. I think i have 80 and 443 and then all the ephemeral ports. You can google the range for ephemeral ports.
Please see the attached screen shot of my floating rule for media devices. Also if you have squid, by pass the rule for those ip's.

Please let me know if you are still stuck,
thanks,
molykule

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: pfSense - Cannot connect to Netflix and Hulu on Andriod devices / Smart TVs
« Reply #11 on: December 29, 2017, 08:39:39 pm »
Hi,

Heres what i have done. Please make an alias with all the static assigned IP's of media devices. Create a floating rule for that alias and ope the ports for it. I think i have 80 and 443 and then all the ephemeral ports. You can google the range for ephemeral ports.
Please see the attached screen shot of my floating rule for media devices. Also if you have squid, by pass the rule for those ip's.

Please let me know if you are still stuck,
thanks,
molykule

I copied your floating firewall rule starting w/ 1 Smart TV IP -- added Alias for ports 80, 443, and 49152:65535, however the issue still persists.

Another weird thing I noticed, the "sign in" button on pfchangs.com doesn't trigger the pop-up; happens on all computers.  Works when I switch to Wifi off ISP modem. 

For what it's worth, I installed and did the basic config of OpenSense-- same issues there too.

Here's my full setup if this helps...

WAN 1 -> Time Warner Coax -> Netgear Modem -> Linksys Velop Router -> PCIe Dual Nic Port 1 (WAN1 in)
WAN 2 -> ATT Uverse Copper -> ATT Modem/Router Combo -> PCIe Dual Nic Port 2 (WAN2 in)
LAN out -> Netgear Gigabit Switch -> Wired Devices / Wifi Controller in Bridged modem (DHCP on wifi controller turned off)

Ubuntu 16 Desktop Parent Host
1x Onboard NIC (LAN in)
1x PCIe NIC (LAN out)
1x PCEe Dual Nic ( WAN1 in, WAN2 in)

Virtual Box- VM Hosting pFSense 2.4.2
Bridged Adapters for WAN1 in (em0) WAN2 in (em1) LAN1 out (em2) - > Promiscuous Mode - Deny All on all adapters

WAN1 em0: 192.168.2.x (assigned by DHCP of Linksys Router)
WAN2 em1: 192.168.1.x (assigned by DHCP of ATT Modem/Router Combo)
LAN em2: 192.168.100.1 (gateway for local network devices / issuing DHCP)

DNS: I disable internal DNS server from pfSense.  I have LAN DHCP server set to use a custom DNS IP for devices-- a Raspberry Pi thats running PiHole

Offline mrkool

  • Newbie
  • *
  • Posts: 17
  • Karma: +1/-0
    • View Profile
Re: pfSense - Cannot connect to Netflix and Hulu on Andriod devices / Smart TVs
« Reply #12 on: December 30, 2017, 01:36:04 pm »
I ran into lots of issues because of the following

1. Pfsense loves intel Nicís (not your issue just throwing it out there)
2. Clear the blacklisted ip addresses
3. (do u have snort enabled?) if yes what rules sources Are you using?

Offline CCNewb

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: pfSense - Cannot connect to Netflix and Hulu on Andriod devices / Smart TVs
« Reply #13 on: December 30, 2017, 09:13:21 pm »
I ran into lots of issues because of the following

1. Pfsense loves intel Nicís (not your issue just throwing it out there)
2. Clear the blacklisted ip addresses
3. (do u have snort enabled?) if yes what rules sources Are you using?

Nothing blacklisted.  All NICs are physically Intel except 1, but they're all Intel emulated within Virtualbox.

For now, I have the TVs connected to the Linksys Velop Wifi (different than my regular wifi controller) / bypassing pfSense.  On the CODELQ traffic shaper for that WAN, I reduced the speed 12mbits leaving room for the TVs if my main network is saturating the circuits. 

Not sure what snort is, unless it's enabled and installed by default, I don't have it.

It's frustrating to the point where I'd pay someone $50 to fix it.  Any takers :)?