pfSense English Support > CARP/VIPs

VIP Proxy ARP conflict problem

(1/1)

daraardalan:
Hello, This is my first post ever in pfSense community, I apologize in advance for any grammar or spelling errors I might have and thank anyone trying to help solve my problem  :)

I run pfSense in a datacenter environment to handle parts of my WAN traffic.
I have a /29 public IP subnet and I have assigned one of the IPs on a WAN interface in my pfSesne, I have also added a few of the next available IPs from my subnet as Virtual IPs in Porxy ARP mode in pfSense. NAT and everything is working fine and I can use all the IPs as I wish.
The problem is, I want to remove one of the Virtual IPs and assign it directly to a Windows Server virutal machine in the same WAN . When I remove the NAT rules associated with the Virtual IP and also remove it from Firewall -> Virtual IP page and set it up on the Windows box I get a "Windows has detected an IP address conflict error" and my VM does not aquire the IP address. It feels like pfSense is still somehow using the IP even after I have removed it from the Virtual IP page.
Here are the specs:
pfSense WAN and the Windows box are both ESXI 6 VMs in my WAN port group.
x.x.x.121 is my ISP's Gateway
x.x.x.122 is set on pfSense WAN
x.x.x.123 is the Virtual IP that works fine in pfSense for NAT and other stuff, but once removed, cannot be set on the Windows VM.

Rebooting the windows machine does not solve the problem. It still gets a 169.254.x.x APIPA address and does not accept the Public IP directly set onto it.


EDIT 1:
I read somewhere that I might have to "Clear the ARP table of the LAN switch" which my service provider operates. Can it be a problem on their end and the cause behind this problem?

EDIT 2:
Turned out it was a misconfiguration in Windows Server, this resolved the issue:
http://lyngtinh.blogspot.de/2011/12/how-to-disable-autoconfiguration-ipv4.html

not connected to pfSense at all... woops

Navigation

[0] Message Index

Go to full version