pfSense Gold Subscription

Author Topic: pc engines alix 6f2 / MC7710 issue / 2.3.5-RELEASE-p1 (i386)  (Read 193 times)

0 Members and 1 Guest are viewing this topic.

Offline pfsense_user_123

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
    • View Profile
pc engines alix 6f2 / MC7710 issue / 2.3.5-RELEASE-p1 (i386)
« on: December 29, 2017, 04:14:41 pm »
Hello,
how to make this modem to work ?.
MC7710 is on list => https://doc.pfsense.org/index.php/Known_Working_3G-4G_Modems
It's confirmed on this forum success working on APU2 devices with PPP.

Board:   Alix 6f2, BIOS  v0.99m (Ericsson 2XGNJ - F5521GW works on this board like a charm)
System: 2.3.5-RELEASE-p1 (i386)
LTE Modem: Sierra Wireless MC7710 (generic with DIP Mode)  / Firmware: SWI9200X_03.05.19.04ap r5475 carmd-en-10527 2012/09/17 17:57:14

PPP is unable to connect on any of /dev/cuaU0.X port
CHAT: The modem is not responding to "AT" at ModemCmd: label.

Code: [Select]
Dec 29 20:58:40 ppp [opt1_link0] Link: reconnection attempt 1500 in 1 seconds
Dec 29 20:58:42 ppp [opt1_link0] Link: reconnection attempt 1500
Dec 29 20:58:56 ppp [opt1_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
Dec 29 20:58:56 ppp [opt1_link0] MODEM: chat script failed
Dec 29 20:58:56 ppp [opt1_link0] Link: DOWN event
Dec 29 20:58:56 ppp [opt1_link0] LCP: Down event
Dec 29 20:58:56 ppp [opt1_link0] Link: reconnection attempt 1501 in 3 seconds
Dec 29 20:58:59 ppp [opt1_link0] Link: reconnection attempt 1501
Dec 29 20:59:12 ppp [opt1_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
Dec 29 20:59:12 ppp [opt1_link0] MODEM: chat script failed
Dec 29 20:59:12 ppp [opt1_link0] Link: DOWN event
Dec 29 20:59:12 ppp [opt1_link0] LCP: Down event
Dec 29 20:59:12 ppp [opt1_link0] Link: reconnection attempt 1502 in 1 seconds
Dec 29 20:59:13 ppp [opt1_link0] Link: reconnection attempt 1502
Dec 29 20:59:28 ppp [opt1_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
Dec 29 20:59:28 ppp [opt1_link0] MODEM: chat script failed
Dec 29 20:59:28 ppp [opt1_link0] Link: DOWN event
Dec 29 20:59:28 ppp [opt1_link0] LCP: Down event
Dec 29 20:59:28 ppp [opt1_link0] Link: reconnection attempt 1503 in 2 seconds
Dec 29 20:59:30 ppp [opt1_link0] Link: reconnection attempt 1503
Dec 29 20:59:44 ppp [opt1_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
Dec 29 20:59:44 ppp [opt1_link0] MODEM: chat script failed
Dec 29 20:59:44 ppp [opt1_link0] Link: DOWN event
Dec 29 20:59:44 ppp [opt1_link0] LCP: Down event
Dec 29 20:59:44 ppp [opt1_link0] Link: reconnection attempt 1504 in 1 seconds
Dec 29 20:59:45 ppp [opt1_link0] Link: reconnection attempt 1504
Dec 29 21:00:01 ppp [opt1_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
Dec 29 21:00:01 ppp [opt1_link0] MODEM: chat script failed
Dec 29 21:00:01 ppp [opt1_link0] Link: DOWN event
Dec 29 21:00:01 ppp [opt1_link0] LCP: Down event
Dec 29 21:00:01 ppp [opt1_link0] Link: reconnection attempt 1505 in 4 seconds
Dec 29 21:00:05 ppp [opt1_link0] Link: reconnection attempt 1505
Dec 29 21:00:18 ppp [opt1_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
Dec 29 21:00:18 ppp [opt1_link0] MODEM: chat script failed
Dec 29 21:00:18 ppp [opt1_link0] Link: DOWN event
Dec 29 21:00:18 ppp [opt1_link0] LCP: Down event
Dec 29 21:00:18 ppp [opt1_link0] Link: reconnection attempt 1506 in 4 seconds
Dec 29 21:00:22 ppp [opt1_link0] Link: reconnection attempt 1506
Dec 29 21:00:35 ppp [opt1_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
Dec 29 21:00:35 ppp [opt1_link0] MODEM: chat script failed
Dec 29 21:00:35 ppp [opt1_link0] Link: DOWN event
Dec 29 21:00:35 ppp [opt1_link0] LCP: Down event
Dec 29 21:00:35 ppp [opt1_link0] Link: reconnection attempt 1507 in 4 seconds
Dec 29 21:00:39 ppp [opt1_link0] Link: reconnection attempt 1507
Dec 29 21:00:52 ppp [opt1_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
Dec 29 21:00:52 ppp [opt1_link0] MODEM: chat script failed
Dec 29 21:00:52 ppp [opt1_link0] Link: DOWN event
Dec 29 21:00:52 ppp [opt1_link0] LCP: Down event
Dec 29 21:00:52 ppp [opt1_link0] Link: reconnection attempt 1508 in 2 seconds
Dec 29 21:00:54 ppp [opt1_link0] Link: reconnection attempt 1508

I can see serial ports:
Code: [Select]
[2.3.5-RELEASE][admin@beastie.localdomain]/root: ls -l /dev/cu*
crw-rw----  1 uucp  dialer  0x67 Dec 29 20:14 /dev/cuaU0.0
crw-rw----  1 uucp  dialer  0x68 Dec 29 14:07 /dev/cuaU0.0.init
crw-rw----  1 uucp  dialer  0x69 Dec 29 14:07 /dev/cuaU0.0.lock
crw-rw----  1 uucp  dialer  0x6d Dec 29 15:46 /dev/cuaU0.1
crw-rw----  1 uucp  dialer  0x6e Dec 29 14:07 /dev/cuaU0.1.init
crw-rw----  1 uucp  dialer  0x6f Dec 29 14:07 /dev/cuaU0.1.lock
crw-rw----  1 uucp  dialer  0x73 Dec 29 14:07 /dev/cuaU0.2
crw-rw----  1 uucp  dialer  0x74 Dec 29 14:07 /dev/cuaU0.2.init
crw-rw----  1 uucp  dialer  0x75 Dec 29 14:07 /dev/cuaU0.2.lock
crw-rw----  1 uucp  dialer  0x79 Dec 29 14:48 /dev/cuaU0.3
crw-rw----  1 uucp  dialer  0x7a Dec 29 14:07 /dev/cuaU0.3.init
crw-rw----  1 uucp  dialer  0x7b Dec 29 14:07 /dev/cuaU0.3.lock
crw-rw----  1 uucp  dialer  0x7f Dec 29 14:48 /dev/cuaU0.4
crw-rw----  1 uucp  dialer  0x80 Dec 29 14:07 /dev/cuaU0.4.init
crw-rw----  1 uucp  dialer  0x81 Dec 29 14:07 /dev/cuaU0.4.lock
crw-rw----  1 uucp  dialer  0x85 Dec 29 14:07 /dev/cuaU0.5
crw-rw----  1 uucp  dialer  0x86 Dec 29 14:07 /dev/cuaU0.5.init
crw-rw----  1 uucp  dialer  0x87 Dec 29 14:07 /dev/cuaU0.5.lock
crw-rw----  1 uucp  dialer  0x29 Dec 29 14:07 /dev/cuau0
crw-rw----  1 uucp  dialer  0x2a Dec 29 14:07 /dev/cuau0.init
crw-rw----  1 uucp  dialer  0x2b Dec 29 14:07 /dev/cuau0.lock
crw-rw----  1 uucp  dialer  0x2f Dec 29 14:51 /dev/cuau1
crw-rw----  1 uucp  dialer  0x30 Dec 29 14:07 /dev/cuau1.init
crw-rw----  1 uucp  dialer  0x31 Dec 29 14:07 /dev/cuau1.lock
[2.3.5-RELEASE][admin@beastie.localdomain]/root:

DMESG:
Code: [Select]
[2.3.5-RELEASE][admin@beastie.localdomain]/root: dmesg
Copyright (c) 1992-2016 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 10.3-RELEASE-p22 #0 352658d6e(RELENG_2_3): Tue Oct 24 05:16:13 CDT 2017
    root@ce23-i386-builder:/builder/pfsense-235/tmp/obj/builder/pfsense-235/tmp/FreeBSD-src/sys/pfSense_wrap i386
FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512
CPU: Geode(TM) Integrated Processor by AMD PCS (498.06-MHz 586-class CPU)
  Origin="AuthenticAMD"  Id=0x5a2  Family=0x5  Model=0xa  Stepping=2
  Features=0x88a93d<FPU,DE,PSE,TSC,MSR,CX8,SEP,PGE,CMOV,CLFLUSH,MMX>
  AMD Features=0xc0400000<MMX+,3DNow!+,3DNow!>
real memory  = 268435456 (256 MB)
avail memory = 226562048 (216 MB)
pnpbios: Bad PnP BIOS data checksum
random: <Software, Yarrow> initialized
ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (ipw_ibss_fw, 0xc08151d0, 0) error 1
ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (ipw_monitor_fw, 0xc0815280, 0) error 1
iwi_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
iwi_bss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (iwi_bss_fw, 0xc083cc70, 0) error 1
iwi_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
iwi_ibss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (iwi_ibss_fw, 0xc083cd20, 0) error 1
iwi_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
iwi_monitor: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (iwi_monitor_fw, 0xc083cdd0, 0) error 1
wlan: mac acl policy registered
ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (ipw_bss_fw, 0xc0815120, 0) error 1
K6-family MTRR support enabled (2 registers)
kbd0 at kbdmux0
ACPI BIOS Error (bug): A valid RSDP was not found (20150515/tbxfroot-258)
ACPI: Table initialisation failed: AE_NOT_FOUND
ACPI: Try disabling either ACPI or apic support.
cryptosoft0: <software crypto> on motherboard
padlock0: No ACE support.
pcib0 pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
Geode LX: PC Engines ALIX.6 v0.99m tinyBIOS V1.4a (C)1997-2007
pci0: <encrypt/decrypt, entertainment crypto> at device 1.2 (no driver attached)
vr0: <VIA VT6105M Rhine III 10/100BaseTX> port 0x1000-0x10ff mem 0xe0000000-0xe00000ff irq 10 at device 9.0 on pci0
vr0: Quirks: 0x2
vr0: Revision: 0x96
miibus0: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0
ukphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto, auto-flow
vr0: Ethernet address: 00:0d:b9:2f:b0:30
vr1: <VIA VT6105M Rhine III 10/100BaseTX> port 0x1400-0x14ff mem 0xe0040000-0xe00400ff irq 11 at device 10.0 on pci0
vr1: Quirks: 0x2
vr1: Revision: 0x96
miibus1: <MII bus> on vr1
ukphy1: <Generic IEEE 802.3u media interface> PHY 1 on miibus1
ukphy1:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto, auto-flow
vr1: Ethernet address: 00:0d:b9:2f:b0:31
isab0: <PCI-ISA bridge> port 0x6000-0x6007,0x6100-0x61ff,0x6200-0x623f,0x9d00-0x9d7f,0x9c00-0x9c3f at device 15.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <AMD CS5536 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xff00-0xff0f at device 15.2 on pci0
ata0: <ATA channel> at channel 0 on atapci0
ata1: <ATA channel> at channel 1 on atapci0
ohci0: <OHCI (generic) USB controller> mem 0xefffe000-0xefffefff irq 12 at device 15.4 on pci0
usbus0 on ohci0
ehci0: <AMD CS5536 (Geode) USB 2.0 controller> mem 0xefffd000-0xefffdfff irq 12 at device 15.5 on pci0
usbus1: EHCI version 1.0
usbus1 on ehci0
cpu0 on motherboard
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xe0000-0xea7ff pnpid ORM0000 on isa0
atrtc0: <AT realtime clock> at port 0x70 irq 8 on isa0
Event timer "RTC" frequency 32768 Hz quality 0
attimer0: <AT timer> at port 0x40 on isa0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
ppc0: parallel port not found.
uart0: <16550 or compatible> at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
uart0: console (115200,n,8,1)
uart1: <16550 or compatible> at port 0x2f8-0x2ff irq 3 on isa0
Timecounters tick every 1.000 msec
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 480Mbps High Speed USB v2.0
ugen0.1: <AMD> at usbus0
uhub0: <AMD OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <AMD> at usbus1
uhub1: <AMD EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
ada0 at ata0 bus 0 scbus0 target 0 lun 0
ada0: <ATP COMPACT FLASH 20140121> ATA device
ada0: Serial Number 99007150915130200371
ada0: 66.700MB/s transfers (UDMA4, PIO 512bytes)
ada0: 3831MB (7847280 512 byte sectors)
ada0: Previously was known as ad0
random: unblocking device.
Timecounter "TSC" frequency 498061515 Hz quality 800
Root mount waiting for: usbus1 usbus0
uhub0: 4 ports with 4 removable, self powered
Root mount waiting for: usbus1
uhub1: 4 ports with 4 removable, self powered
Root mount waiting for: usbus1
ugen1.2: <Sierra Wireless, Incorporated> at usbus1
u3g0: <Sierra Wireless, Incorporated MC7710, class 0/0, rev 2.00/0.06, addr 2> on usbus1
u3g0: Found 6 ports.
Trying to mount root from ufs:/dev/ufs/pfsense1 [ro,sync,noatime]...
vr1: link state changed to DOWN
vr1: link state changed to UP
vr0: link state changed to DOWN
ng0: changing name to 'ppp0'
vr0: link state changed to UP
tun1: changing name to 'ovpnc1'
ovpnc1: link state changed to UP
pflog0: promiscuous mode enabled
ng0: changing name to 'ppp0'
[2.3.5-RELEASE][admin@beastie.localdomain]/root:

DEVICE:
Code: [Select]
[2.3.5-RELEASE][admin@beastie.localdomain]/root: usbconfig
ugen0.1: <OHCI root HUB AMD> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen1.1: <EHCI root HUB AMD> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)

ugen1.2: <MC7710 Sierra Wireless, Incorporated> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (0mA)
  bLength = 0x0012
  bDescriptorType = 0x0001
  bcdUSB = 0x0200
  bDeviceClass = 0x0000  <Probed by interface class>
  bDeviceSubClass = 0x0000
  bDeviceProtocol = 0x0000
  bMaxPacketSize0 = 0x0040
  idVendor = 0x1199
  idProduct = 0x68a3
  bcdDevice = 0x0006
  iManufacturer = 0x0003  <Sierra Wireless, Incorporated>
  iProduct = 0x0002  <MC7710>
  iSerialNumber = 0x0004  <358178042993362>
  bNumConfigurations = 0x0001


Some AT stuff: (unfortunately this is done on my old laptop with Windows with Putty, via AT serial port, once again unfortunately without SIM slot)
What is wort attention that on ALIX i cannot send any AT command to none of 6 port I have from dmesg)
cu -l /dev/cuaU0.1 to cu -l /dev/cuaU0.5 - just HANG after connection, with prompt CONNECTED


Code: [Select]
at
OK
AT!ENTERCND="A710"
OK
AT!PCINFO?
State: 0 (LPM)
LPM force flags - W_DISABLE:1, User:1, Temp:0, Volt:0, Auth:0
W_DISABLE: 1
Poweroff mode: 0
LPM Persistent: 0


OK
AT!PCFCCAUTH?
NV setting: 0
Auth enabled: 0
Lock state: 0


OK
AT!UDINFO?
VID: 0x1199
PID: 0x68A3
Interface: DIP
Manufacturer: Sierra Wireless, Incorporated
Product: MC7710


OK
AT!UDPID=?
68A3
68AA
68A2
68B1
68A9

OK
AT!UDUSBCOMP?
!UDUSBCOMP: 3

OK
AT!UDUSBCOMP=?
0  - HIP  DM    NMEA  AT    MDM1  MDM2  MDM3  MS  SUPPORTED
1  - HIP  DM    NMEA  AT    MDM1  MS              NOT SUPPORTED
2  - HIP  DM    NMEA  AT    NIC1  MS              SUPPORTED
3  - HIP  DM    NMEA  AT    MDM1  NIC1  MS        SUPPORTED
4  - HIP  DM    NMEA  AT    NIC1  NIC2  NIC3  MS  SUPPORTED
5  - HIP  DM    NMEA  AT    ECM1  MS              SUPPORTED
6  - DM   NMEA  AT    QMI                         NOT SUPPORTED
7  - DM   NMEA  AT    RMNET1 RMNET2 RMNET3        NOT SUPPORTED
8  - DM   NMEA  AT    MBIM                        NOT SUPPORTED
9  - MBIM                                         NOT SUPPORTED
10 - NMEA MBIM                                    NOT SUPPORTED
11 - DM   MBIM                                    NOT SUPPORTED
12 - DM   NMEA  MBIM                              NOT SUPPORTED
13 - Config1: comp6    Config2: comp8             NOT SUPPORTED
14 - Config1: comp6    Config2: comp9             NOT SUPPORTED
15 - Config1: comp6    Config2: comp10            NOT SUPPORTED
16 - Config1: comp6    Config2: comp11            NOT SUPPORTED
17 - Config1: comp6    Config2: comp12            NOT SUPPORTED
18 - Config1: comp7    Config2: comp8             NOT SUPPORTED
19 - Config1: comp7    Config2: comp9             NOT SUPPORTED
20 - Config1: comp7    Config2: comp10            NOT SUPPORTED
21 - Config1: comp7    Config2: comp11            NOT SUPPORTED
22 - Config1: comp7    Config2: comp12            NOT SUPPORTED

« Last Edit: December 29, 2017, 04:37:37 pm by pfsense_user_123 »

Offline johnkeates

  • Hero Member
  • *****
  • Posts: 749
  • Karma: +57/-1
    • View Profile
Re: pc engines alix 6f2 / MC7710 issue / 2.3.5-RELEASE-p1 (i386)
« Reply #1 on: December 29, 2017, 04:51:42 pm »
Are you using the correct serial speed/modes?

Offline pfsense_user_123

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
    • View Profile
Re: pc engines alix 6f2 / MC7710 issue / 2.3.5-RELEASE-p1 (i386)
« Reply #2 on: December 29, 2017, 05:04:13 pm »
Not sure, what value is correct for this MC7710 with PFSense,

Basically the default value 9600 for cu on this Alix Board works fine with Ericsson 2XGNJ

I can also connect to this MC7710 AT serial port on Windows with 9600.


Offline pfsense_user_123

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
    • View Profile
Re: pc engines alix 6f2 / MC7710 issue / 2.3.5-RELEASE-p1 (i386)
« Reply #3 on: January 02, 2018, 07:04:42 am »
Back with update after Christmas.
1) MPD is talking with ppp on 115200 by default
2) Problem with AT on serial is result of "somehow locked serial bus", (I have no idea why it occurs on this ALIX 6f2) - but the only way to back it to live is take down power from MC7710 module and power up it again.

usbconfig -d 1.2 power_off
usbconfig -d 1.2 power_on

Or You can try "blind AT command"
AT!RESET

The best way is turn off (unplug power cord) whole device.
In my case modem for ppp presents on /dev/cuaU0.3
Code: [Select]
[opt1_link0] MODEM: Fail to open serial port /dev/cuaU0.3 on speed 115200
Jan 2 12:54:22 ppp [opt1_link0] Link: DOWN event
Jan 2 12:54:22 ppp [opt1_link0] LCP: Down event
Jan 2 12:54:22 ppp [opt1_link0] Link: reconnection attempt 11 in 3 seconds
Jan 2 12:54:25 ppp [opt1_link0] Link: reconnection attempt 11
Jan 2 12:54:25 ppp [opt1_link0] CHAT: Detected Hayes compatible modem.
Jan 2 12:54:28 ppp [opt1_link0] CHAT: The modem is not responding to "AT&F&C1&D2E0S0=0M1" at ModemCmd: label.
Jan 2 12:54:28 ppp [opt1_link0] MODEM: chat script failed
Jan 2 12:54:28 ppp [opt1_link0] Link: DOWN event
Jan 2 12:54:28 ppp [opt1_link0] LCP: Down event
Jan 2 12:54:28 ppp [opt1_link0] Link: reconnection attempt 12 in 2 seconds
Jan 2 12:54:30 ppp [opt1_link0] Link: reconnection attempt 12
Jan 2 12:54:31 ppp [opt1_link0] CHAT: Detected Hayes compatible modem.
Jan 2 12:54:31 ppp [opt1_link0] CHAT: Dialing server at *99#...
Jan 2 12:54:31 ppp [opt1_link0] CHAT: ATDT*99#
Jan 2 12:54:31 ppp [opt1_link0] CHAT: Connected at 100000000.
Jan 2 12:54:31 ppp [opt1_link0] MODEM: chat script succeeded
Jan 2 12:54:31 ppp [opt1_link0] Link: UP event
Jan 2 12:54:31 ppp [opt1_link0] LCP: Up event
Jan 2 12:54:31 ppp [opt1_link0] LCP: state change Starting --> Req-Sent
Jan 2 12:54:31 ppp [opt1_link0] LCP: SendConfigReq #3
Jan 2 12:54:31 ppp [opt1_link0] ACFCOMP
Jan 2 12:54:31 ppp [opt1_link0] PROTOCOMP
Jan 2 12:54:31 ppp [opt1_link0] ACCMAP 0x000a0000
Jan 2 12:54:31 ppp [opt1_link0] MRU 1500
Jan 2 12:54:31 ppp [opt1_link0] MAGICNUM 0x863c1dc0
Jan 2 12:54:31 ppp [opt1_link0] LCP: rec'd Configure Request #6 (Req-Sent)
Jan 2 12:54:31 ppp [opt1_link0] ACCMAP 0x00000000
Jan 2 12:54:31 ppp [opt1_link0] AUTHPROTO CHAP MD5
Jan 2 12:54:31 ppp [opt1_link0] MAGICNUM 0x14e36fb8
Jan 2 12:54:31 ppp [opt1_link0] PROTOCOMP
Jan 2 12:54:31 ppp [opt1_link0] ACFCOMP
Jan 2 12:54:31 ppp [opt1_link0] LCP: SendConfigAck #6
Jan 2 12:54:31 ppp [opt1_link0] ACCMAP 0x00000000
Jan 2 12:54:31 ppp [opt1_link0] AUTHPROTO CHAP MD5
Jan 2 12:54:31 ppp [opt1_link0] MAGICNUM 0x14e36fb8
Jan 2 12:54:31 ppp [opt1_link0] PROTOCOMP
Jan 2 12:54:31 ppp [opt1_link0] ACFCOMP
Jan 2 12:54:31 ppp [opt1_link0] LCP: state change Req-Sent --> Ack-Sent
Jan 2 12:54:31 ppp [opt1_link0] LCP: rec'd Configure Ack #3 (Ack-Sent)
Jan 2 12:54:31 ppp [opt1_link0] ACFCOMP
Jan 2 12:54:31 ppp [opt1_link0] PROTOCOMP
Jan 2 12:54:31 ppp [opt1_link0] ACCMAP 0x000a0000
Jan 2 12:54:31 ppp [opt1_link0] MRU 1500
Jan 2 12:54:31 ppp [opt1_link0] MAGICNUM 0x863c1dc0
Jan 2 12:54:31 ppp [opt1_link0] LCP: state change Ack-Sent --> Opened
Jan 2 12:54:31 ppp [opt1_link0] LCP: auth: peer wants CHAP, I want nothing
Jan 2 12:54:31 ppp [opt1_link0] LCP: LayerUp
Jan 2 12:54:31 ppp [opt1_link0] LCP: rec'd Discard Request #7 (Opened)
Jan 2 12:54:31 ppp [opt1_link0] CHAP: rec'd CHALLENGE #1 len: 35
Jan 2 12:54:31 ppp [opt1_link0] Name: "UMTS_CHAP_SRVR"
Jan 2 12:54:31 ppp [opt1_link0] CHAP: Using authname "user"
Jan 2 12:54:31 ppp [opt1_link0] CHAP: sending RESPONSE #1 len: 25
Jan 2 12:54:31 ppp [opt1_link0] CHAP: rec'd SUCCESS #1 len: 4
Jan 2 12:54:31 ppp [opt1_link0] LCP: authorization successful
Jan 2 12:54:31 ppp [opt1_link0] Link: Matched action 'bundle "opt1" ""'
Jan 2 12:54:31 ppp [opt1_link0] Link: Join bundle "opt1"
Jan 2 12:54:31 ppp [opt1] Bundle: Status update: up 1 link, total bandwidth 100000000 bps
Jan 2 12:54:31 ppp [opt1] IPCP: Open event
Jan 2 12:54:31 ppp [opt1] IPCP: state change Initial --> Starting
Jan 2 12:54:31 ppp [opt1] IPCP: LayerStart
Jan 2 12:54:31 ppp [opt1] IPV6CP: Open event
Jan 2 12:54:31 ppp [opt1] IPV6CP: state change Initial --> Starting
Jan 2 12:54:31 ppp [opt1] IPV6CP: LayerStart
Jan 2 12:54:31 ppp [opt1] IPCP: Up event
Jan 2 12:54:31 ppp [opt1] IPCP: state change Starting --> Req-Sent
Jan 2 12:54:31 ppp [opt1] IPCP: SendConfigReq #9
Jan 2 12:54:31 ppp [opt1] IPADDR 0.0.0.0
Jan 2 12:54:31 ppp [opt1] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
Jan 2 12:54:31 ppp [opt1] PRIDNS 0.0.0.0
Jan 2 12:54:31 ppp [opt1] SECDNS 0.0.0.0
Jan 2 12:54:31 ppp [opt1] IPV6CP: Up event
Jan 2 12:54:31 ppp [opt1] IPV6CP: state change Starting --> Req-Sent
Jan 2 12:54:31 ppp [opt1] IPV6CP: SendConfigReq #21
Jan 2 12:54:31 ppp [opt1] IPCP: rec'd Configure Request #2 (Req-Sent)
Jan 2 12:54:31 ppp [opt1] IPCP: SendConfigAck #2
Jan 2 12:54:31 ppp [opt1] IPCP: state change Req-Sent --> Ack-Sent
Jan 2 12:54:31 ppp [opt1] IPCP: rec'd Configure Reject #9 (Ack-Sent)
Jan 2 12:54:31 ppp [opt1] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
Jan 2 12:54:31 ppp [opt1] IPCP: SendConfigReq #10
Jan 2 12:54:31 ppp [opt1] IPADDR 0.0.0.0
Jan 2 12:54:31 ppp [opt1] PRIDNS 0.0.0.0
Jan 2 12:54:31 ppp [opt1] SECDNS 0.0.0.0
Jan 2 12:54:31 ppp [opt1] IPCP: rec'd Configure Nak #10 (Ack-Sent)
Jan 2 12:54:31 ppp [opt1] IPADDR IP_REMOVED
Jan 2 12:54:31 ppp [opt1] CHANGE is OK
Jan 2 12:54:31 ppp [opt1] PRIDNS IP_REMOVED
Jan 2 12:54:31 ppp [opt1] SECDNS IP_REMOVED
Jan 2 12:54:31 ppp [opt1] IPCP: SendConfigReq #11
Jan 2 12:54:31 ppp [opt1] IPADDR IP_REMOVED
Jan 2 12:54:31 ppp [opt1] PRIDNS IP_REMOVED
Jan 2 12:54:31 ppp [opt1] SECDNS IP_REMOVED
Jan 2 12:54:31 ppp [opt1] IPCP: rec'd Configure Ack #11 (Ack-Sent)
Jan 2 12:54:31 ppp [opt1] IPADDR IP_REMOVED
Jan 2 12:54:31 ppp [opt1] PRIDNS IP_REMOVED
Jan 2 12:54:31 ppp [opt1] SECDNS IP_REMOVED
Jan 2 12:54:31 ppp [opt1] IPCP: state change Ack-Sent --> Opened
Jan 2 12:54:31 ppp [opt1] IPCP: LayerUp
Jan 2 12:54:31 ppp [opt1] IP_REMOVED -> GW_IP_REMOVED
Jan 2 12:54:32 ppp [opt1] IFACE: Up event
Jan 2 12:54:32 ppp [opt1] IFACE: Rename interface ng0 to ppp0
Jan 2 12:54:33 ppp [opt1] IPV6CP: SendConfigReq #22
Jan 2 12:54:35 ppp [opt1] IPV6CP: SendConfigReq #23
Jan 2 12:54:37 ppp [opt1] IPV6CP: SendConfigReq #24
Jan 2 12:54:39 ppp [opt1] IPV6CP: SendConfigReq #25
Jan 2 12:54:41 ppp [opt1] IPV6CP: SendConfigReq #26
Jan 2 12:54:43 ppp [opt1] IPV6CP: SendConfigReq #27
Jan 2 12:54:45 ppp [opt1] IPV6CP: SendConfigReq #28
Jan 2 12:54:47 ppp [opt1] IPV6CP: SendConfigReq #29
Jan 2 12:54:49 ppp [opt1] IPV6CP: SendConfigReq #30
Jan 2 12:54:51 ppp [opt1] IPV6CP: parameter negotiation failed
Jan 2 12:54:51 ppp [opt1] IPV6CP: state change Req-Sent --> Stopped
Jan 2 12:54:51 ppp [opt1] IPV6CP: LayerFinish

« Last Edit: January 02, 2018, 07:09:51 am by pfsense_user_123 »

Offline pfsense_user_123

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
    • View Profile
Re: pc engines alix 6f2 / MC7710 issue / 2.3.5-RELEASE-p1 (i386)
« Reply #4 on: January 02, 2018, 07:47:30 am »
Now it looks good.
FYI it is good to check, bands used by Your Provider.

For example:
T-Mobile drops you down to worse band on traffic idle.

For me the best is B3 and B20 (so I stick to it)
B7 sucks (so I exclude it from AT!BAND)

AT!GSTATUS?
!GSTATUS:
Current Time:  20815            Temperature: 40
Bootup Time:   20762            Mode:        ONLINE
System mode:   LTE               PS state:    Attached
LTE band:      B3                      LTE bw:      15 MHz
LTE Rx chan:   1798               LTE Tx chan: 19798
EMM state:     Registered     Normal Service
EMM connection:RRC Idle

RSSI (dBm):    -52            Tx Power:    0
RSRP (dBm):    -79           TAC:         xxx
RSRQ (dB):     -12             Cell ID:     xxx
SINR (dB):     20.8

BTW
I assume that module for usie (ethernet device) is not compiled into NanoBSD kernel ?, am I right ?
How does it look like on full Pfsense install ?

Lack of qmi on FreeBSD makes me unhappy :-(
« Last Edit: January 02, 2018, 03:35:23 pm by pfsense_user_123 »