pfSense Gold Subscription

Author Topic: Can't Access LAN Interface from WAN Side  (Read 152 times)

0 Members and 1 Guest are viewing this topic.

Offline tmack8080

  • Newbie
  • *
  • Posts: 3
  • Karma: +1/-0
    • View Profile
Can't Access LAN Interface from WAN Side
« on: December 30, 2017, 03:27:03 pm »
Hey guys,

Hate asking this as its been asked over and over again but I'm not seeing a solution in any existing forum posts. Also reading "Mastering pfSense" - David Zientara, but not finding my answer there either.

I can ping the WAN interface from 192.168.1.9
I cannot ping, or access the Web Admin GUI, from 192.168.1.9
I can access the internet from 172.16.0.30
I can access the Web Admin GUI from 172.16.0.30

Diagram attached.

Thanks
« Last Edit: December 30, 2017, 03:59:08 pm by tmack8080 »

Offline chpalmer

  • Hero Member
  • *****
  • Posts: 1786
  • Karma: +93/-3
    • View Profile
    • Home of Cablenut
Re: Can't Access LAN Interface from WAN Side
« Reply #1 on: December 30, 2017, 04:14:37 pm »
You need to port forward from the WAN side to the LAN side. 

Your behind NAT.  Remember??  ;D

Try your WAN GUI at 192.168.1.200

P.S. statements made by me are not necessarily condoned by the management of this fine organization.  http://badmodems.com

Offline tmack8080

  • Newbie
  • *
  • Posts: 3
  • Karma: +1/-0
    • View Profile
Re: Can't Access LAN Interface from WAN Side
« Reply #2 on: December 31, 2017, 12:07:17 pm »
Thanks for the response.

OK, here's the rub ... this was working as diagrammed previously without any port forwards. In fact I can't spell port forward; haven't gotten that far in the book yet.
Previously I was able to access the Web Admin GUI from 192.168.1.9 on 172.16.0.1 (LAN interface) and I was also able to ping anything on 172.16.0.0. The only configuration changes I made were to add the "Pass any protocol, from any source and any destination" rule on the WAN interface and disable "Block private networks and loopback addresses".

This only became a problem after an IP conflict. I accidently gave my FreeNAS server an already used IP on 172.16.0.0. I've since shutdown all physical devices, reset pfSense to factory defaults and reconfigured.

I'm able to access the Web Admin GUI on the WAN interface from 192.168.1.9 and 172.16.0.30. I can access the Web Admin GUI on the LAN port only from 172.16.0.30. I was under the impression, from reading, that once a LAN interface is created the Web Admin GUI is only supposed to be available from the LAN interface, for security purposes. Is that not correct? Obviously I can access it on the WAN interface even though I have a LAN interface configured.

Thanks again.

Offline Derelict

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9597
  • Karma: +1089/-309
    • View Profile
Re: Can't Access LAN Interface from WAN Side
« Reply #3 on: December 31, 2017, 03:02:53 pm »
You have also created an asymmetric routing scenario.

https://forum.pfsense.org/index.php?topic=142090.msg775011#msg775011
Las Vegas, Nevada, USA
Use this diagram to describe your issue.
The pfSense Book is now available for just $24.70!
Do Not PM For Help! NO_WAN_EGRESSTM