pfSense English Support > Firewalling

TFTP not working across LAN segments (UDP no cksum issue?)

(1/1)

klubar:
A have 2 LANs on my network (separate) interfaces:

LAN:  192.168.10.0/24
PHONESYS: 192.168.1.0/24

Issue: TFPT requests from LAN to PHONESYS are not working.

Diagnostics:
Doing a packet capture I can see the request from 192.168.10.182 to 192.168.1.31 port 69 on both the computer (.182 using Wireshark) and on the PFSense on the LAN interface (using Diagnostic->Packet Capture).

A packet capture on the PHONESYS interface shows

The TFTP request
12:38:59.488859 00:08:a2:09:d9:f3 > 00:e0:07:02:ed:47, ethertype IPv4 (0x0800), length 66: (tos 0x0, ttl 127, id 22020, offset 0, flags [none], proto UDP (17), length 52)
    192.168.1.1.8847 > 192.168.1.31.69: [udp sum ok]  24 RRQ "nasystem/who_is" octet


 12:38:59.490535 00:e0:07:02:ed:47 > 00:08:a2:09:d9:f3, ethertype IPv4 (0x0800), length 149: (tos 0x0, ttl 99, id 4823, offset 0, flags [none], proto UDP (17), length 135)
    192.168.1.31.4134 > 192.168.1.1.8847: [no cksum] UDP, length 107


Yet this response never makes it back to the LAN interface.

Any ideas or suggestions? (Is it an issue with the no checksum?)

If it's any help, it's an Avaya IP Office on the PHONESYS interface.

Thanks


Firewall rules: Allow * FROM and TO LAN/PHONESYS

JKnott:

--- Quote ---Any ideas or suggestions? (Is it an issue with the no checksum?)

--- End quote ---

UDP checksum is optional on IPv4 (mandatory on IPv6).  What does Wireshark show for it?  If it's all zeros, then a UDP checksum is not used for that packet.

Navigation

[0] Message Index

Go to full version