Netgate SG-1000 microFirewall

Author Topic: Possible to supersede prefix lifetime with dhcp6c?  (Read 141 times)

0 Members and 1 Guest are viewing this topic.

Offline jtl

  • Jr. Member
  • **
  • Posts: 44
  • Karma: +0/-0
    • View Profile
Possible to supersede prefix lifetime with dhcp6c?
« on: January 12, 2018, 05:55:27 pm »
I have a TELUS FTTH connection. I then terminate the Ethernet handoff from the ONT into my own switch as untagged VLAN 666, of which two other ports are untagged VLAN 666, one going to the Actiontec crappy router for IPTV boxes and another going to my pfSense router.

Problem is, it appears sometimes Telus does maintenance or something at night with the DHCP server at least once a month in my experience, which causes the IP source guard/Dynamic ACL binding at their edge switch to stop routing the IP address given to my pfSense router. Sometimes the connection comes back after 10 minutes or so (happened once when I was away from home) but it often doesn't come back until the DHCP lease is renewed which can take up to 2 hours (lease time is 4 hours). dpinger shows 100% loss for both the IPv4 and IPv6 interface.

If I manually release and renew the DHCP lease under Status->Interfaces the connection comes back instantly.

Similar to the issue in this forum thread, but last time it happened on December 25th 2017 at 21:29 PST I still had the same IPv4 and v6 IP upon renewal: https://www.dslreports.com/forum/r29680126-Possible-DHCP-Problem-on-Fiber

An idea I had to fix this problem is set the DHCP renewal time to a short value regardless of what the server sets. It's possible to do this for IPv4 with dhclient by adding
Code: [Select]
supersede dhcp-lease-time 1800; to the options. But I want to synchronize the DHCP renewal life time with both DHCP and DHCP6 to ensure a seamless and reliable connection as I host servers from home (And no, upgrading to a business connection wouldn't help as they still use DHCP, just registering the MAC address of your router in some clunky web UI)

I tried setting a manual prefix lifetime in a custom DHCP6 config file, but it just seems to be overridden by the sent server value.

Code: [Select]
id-assoc pd 0 {
prefix ::/56 1800 1800;
prefix-interface vtnet1 {

I tried looking for the source of dhcp6c on pfSense github so I can get at hacking it, but either I'm blind or it's not there.

Thanks
pfSense 2.4.2 - virtualized with PCIe passthrough on whitebox - 150/150 FTTP