Netgate Store

Author Topic: every 10th packet to localhost has high latency on SG-2440  (Read 146 times)

0 Members and 1 Guest are viewing this topic.

Offline Cybertoy

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
every 10th packet to localhost has high latency on SG-2440
« on: January 16, 2018, 07:15:24 am »
Hi,

I have been debugging latency problems on my network and ended up narrowing it down to the SG-2440 running community version of pfsense. When I login to the machine and issue a ping localhost command I get:

Code: [Select]
root: ping localhost
PING localhost (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.093 ms
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.048 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.052 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.055 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.046 ms
64 bytes from 127.0.0.1: icmp_seq=5 ttl=64 time=0.059 ms
64 bytes from 127.0.0.1: icmp_seq=6 ttl=64 time=0.061 ms
64 bytes from 127.0.0.1: icmp_seq=7 ttl=64 time=140.970 ms
64 bytes from 127.0.0.1: icmp_seq=8 ttl=64 time=0.061 ms
64 bytes from 127.0.0.1: icmp_seq=9 ttl=64 time=0.068 ms
64 bytes from 127.0.0.1: icmp_seq=10 ttl=64 time=0.068 ms
64 bytes from 127.0.0.1: icmp_seq=11 ttl=64 time=0.040 ms
64 bytes from 127.0.0.1: icmp_seq=12 ttl=64 time=0.057 ms
64 bytes from 127.0.0.1: icmp_seq=13 ttl=64 time=0.057 ms
64 bytes from 127.0.0.1: icmp_seq=14 ttl=64 time=0.063 ms
64 bytes from 127.0.0.1: icmp_seq=15 ttl=64 time=0.060 ms
64 bytes from 127.0.0.1: icmp_seq=16 ttl=64 time=0.066 ms
64 bytes from 127.0.0.1: icmp_seq=17 ttl=64 time=146.021 ms
64 bytes from 127.0.0.1: icmp_seq=18 ttl=64 time=0.056 ms
64 bytes from 127.0.0.1: icmp_seq=19 ttl=64 time=0.046 ms
64 bytes from 127.0.0.1: icmp_seq=20 ttl=64 time=0.052 ms
64 bytes from 127.0.0.1: icmp_seq=21 ttl=64 time=0.058 ms

so every 10th or so packet has >100ms ping time. This also for packets going through the firewall or hitting the firewall from a remote host.

Any leads what I should look for here?

best,
Cybertoy

Offline Cybertoy

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: every 10th packet to localhost has high latency on SG-2440
« Reply #1 on: January 16, 2018, 07:30:32 am »
HA! Sorry to bug you all. I spent some more time in this forum and discovered the Netgate Coreboot Upgrade package. I applied an update and that seems to have done the job. Ping times are find now. VoIP sounds good, too!

regards,
Cybertoy