Netgate SG-1000 microFirewall

Author Topic: pfSense Limiters: works on websites / speedtest, but doesnt work on file DL  (Read 246 times)

0 Members and 1 Guest are viewing this topic.

Offline test4321

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Hey guys, I have installed Limiters on my box.

The limits work on Speedtest and just general browsing.



BUT, when testing file download the limits go over:



What am I doing wrong with my setup? I have also reset the states when I tested the new config.

Here is my configuration:

Limiters:





LAN Rule













Thanks!


PS: I tried running the Wizard, but it bricked my box and I had to completely restart from beginning. This box is already in production so I wouldnt want to do something drastic.



« Last Edit: January 16, 2018, 04:55:00 pm by test4321 »

Offline tman222

  • Jr. Member
  • **
  • Posts: 76
  • Karma: +11/-0
    • View Profile
One question that comes to mind right away: Are you using a proxy setup by chance (e.g. Squid)?

Offline test4321

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
One question that comes to mind right away: Are you using a proxy setup by chance (e.g. Squid)?

Yes I am - is there an issue with this? How can I use both?

UPDATE: looking into this article now:

https://guglio.xyz/pfsense-2-3-limiters-and-squid-bugfix/

Offline tman222

  • Jr. Member
  • **
  • Posts: 76
  • Karma: +11/-0
    • View Profile
One question that comes to mind right away: Are you using a proxy setup by chance (e.g. Squid)?

Yes I am - is there an issue with this? How can I use both?

UPDATE: looking into this article now:

https://guglio.xyz/pfsense-2-3-limiters-and-squid-bugfix/

The reason I asked is because when using the squid proxy the configuration has to be altered somewhat (I have run into this same problem as well actually).  Otherwise, you are just using the limiter to limit bandwidth between local machine and the proxy, but not between the proxy and the machine online you are downloading from.  Unfortunately, I'm actually not quite how to make those modifications - was the article you found helpful, i.e. did you get it working?