Netgate SG-1000 microFirewall

Author Topic: Watchdog timeout on queue 0 problem with ESXi VM  (Read 114 times)

0 Members and 1 Guest are viewing this topic.

Offline MrRocco

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Watchdog timeout on queue 0 problem with ESXi VM
« on: January 17, 2018, 12:10:58 pm »
Hi folks,

I see this has been posted before but no clear resolution. I will explain my setup and see if there are new ideas.

Running ESXi 6.5.0
MKQ77 Intel mobo with Intel i5 3470S CPU
Intel 82579LM, and 2x 82574L NICs (none marked for PCI passthrough)

Running latest pfSense 2.4 as a guest FreeBSD 64b VM
1GB RAM allocated
1 vCPU
NICs to pfSense are ne1000 / VMX3

Woke up this morning to no Internet access and started checking. Found the console of pfSense dumping the title message out. Checked the logs and for no apparent reason it just started spewing:

Code: [Select]
Jan 17 03:00:00 pfSense-pjneder php: [pfBlockerNG] Starting cron process.
Jan 17 03:00:00 pfSense-pjneder check_reload_status: Syncing firewall
Jan 17 03:00:00 pfSense-pjneder php: [pfBlockerNG] No changes to Firewall rules, skipping Filter Reload
Jan 17 03:48:42 pfSense-pjneder kernel: vmx1: watchdog timeout on queue 0
Jan 17 03:49:48 pfSense-pjneder kernel: vmx1: watchdog timeout on queue 0
Jan 17 03:50:26 pfSense-pjneder kernel: vmx1: watchdog timeout on queue 0
Jan 17 03:51:32 pfSense-pjneder kernel: vmx1: watchdog timeout on queue 0
Jan 17 03:51:48 pfSense-pjneder kernel: vmx1: watchdog timeout on queue 0
Jan 17 03:52:17 pfSense-pjneder kernel: vmx1: watchdog timeout on queue 0
Jan 17 03:52:43 pfSense-pjneder kernel: vmx1: watchdog timeout on queue 0
Jan 17 03:53:20 pfSense-pjneder kernel: vmx1: watchdog timeout on queue 0

Unfortunately it took a full power cycle of my server to get it back. vmx1 is my LAN port but I use a 3rd NIC as management into the ESXi server. With a simple reboot of pfSense the WAN port was working but the LAN/vmx1 was still dead.

I'm somewhat handy with this setup but there are those on this forum that know way more depth on ESXi and pfSense. Curious if anyone has thoughts or ideas of where I could look for the root cause.

Thanks!


Offline KOM

  • Hero Member
  • *****
  • Posts: 5609
  • Karma: +688/-23
    • View Profile
Re: Watchdog timeout on queue 0 problem with ESXi VM
« Reply #1 on: January 17, 2018, 12:18:50 pm »
I've been using pfSense on ESXi (Dell Powervault NX3000) for years without issue.  Currently running 6.5.0.7526125.  VM is 2 vCPU, 2GB vRAM, 3 E1000 NICs.  I had problems in the past with the vmx NICs.  E1000 has been rock-solid for me.

Offline MrRocco

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: Watchdog timeout on queue 0 problem with ESXi VM
« Reply #2 on: January 17, 2018, 12:22:40 pm »
OK, that is good to know. I seem to recall reading that performance (or something) was better with vmx. However I will switch if that's what it takes for reliability.