Netgate SG-1000 microFirewall

Author Topic: Ntopng not starting  (Read 314 times)

0 Members and 1 Guest are viewing this topic.

Offline jjstecchino

  • Full Member
  • ***
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Ntopng not starting
« on: January 19, 2018, 06:51:54 pm »
Just updated from 2.4.2 to 2.4.3-DEVELOPMENT (amd64) built on Fri Jan 19 13:16:41 CST 2018 and ntopng is not starting.
Redis is running
If i go to a shell and try "/usr/local/etc/rc.d/ntopng.sh start " ntopng doesnt start
ntopng without parameters starts fine.
System log shows: pid 75313 (ntopng), uid 0: exited on signal 11 (core dumped)

Offline jjstecchino

  • Full Member
  • ***
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Re: Ntopng not starting
« Reply #1 on: January 19, 2018, 07:09:28 pm »
it seems to bomb with the -H option.
removing -H from the options in ntopng.sh it starts just fine.

Offline Firemedic46

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Ntopng not starting
« Reply #2 on: January 20, 2018, 10:48:20 am »
Had the same problem 2.4.3-DEVELOPMENT (amd64) built on Fri Jan 19 13:16:41 CST 2018, removing -H from the options in ntopng.sh Also fixed it for me! I am sure it's not the proper fix, but it is working.

Offline jjstecchino

  • Full Member
  • ***
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Re: Ntopng not starting
« Reply #3 on: January 27, 2018, 07:01:35 pm »
Can't find on ntopng user guide what -H does

Offline jjstecchino

  • Full Member
  • ***
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Re: Ntopng not starting
« Reply #4 on: February 04, 2018, 06:49:24 am »
I could not find -H option anywhere in NtopNG manual.
I then looked into ntopng source code (startup options are in prefs.cpp) and -H does not seem to be a valid option.
Having said that ntopng should just log an "Unknown option -H: Ignored" and continue , however ntopng in pfsense exits with a "Segmentation Fault".

Wonder if this could be fixed in pfsense, just removing -H option in the source. It is annoying to have to edit ntopng.sh after every update.

Offline jjstecchino

  • Full Member
  • ***
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Re: Ntopng not starting
« Reply #5 on: February 04, 2018, 08:13:22 am »
I found it! -H is disable alerts on an old version of ntopng but doesnt seem to be supported anymore on the recent version 3.2.

/usr/local/etc.rc.d/ntopng.sh is an autogenerated file based on the configuration options chosen on the web interface (ntopng settings), so for the time being until the web interface is updated to reflect the new version 3.2 settings, just uncheck "Disables all alerts generated by ntopng, such as flooding notifications." under general options as this setting seems to be irelevant and crashes ntopng. With this ntopng seems to be working flawlessly.

Offline grandrivers

  • Sr. Member
  • ****
  • Posts: 573
  • Karma: +13/-2
    • View Profile
Re: Ntopng not starting
« Reply #6 on: February 04, 2018, 02:17:39 pm »
pfsense 2.4 super micro A1SRM-2558F
C2558 8gig ECC  60gig SSD
tripple Wan dual pppoe

Offline jjstecchino

  • Full Member
  • ***
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Re: Ntopng not starting
« Reply #7 on: February 04, 2018, 03:14:11 pm »
Thanks, I wish I saw that. I hope the web configuration will get fixed soon though