Netgate Store

Author Topic: Load Balancing through Multi-VPN WAN  (Read 360 times)

0 Members and 1 Guest are viewing this topic.

Offline Otaku

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Load Balancing through Multi-VPN WAN
« on: January 21, 2018, 01:39:53 pm »
Hello!  ;D

I have created 3 VPN connections through NordVPN and all are working well on their own. I created a gateway group of the VPN interfaces and it appears that the gateway group is up and running correctly. However, the traffic isn't load balanced between the 3 VPN interfaces. If I shut down an interface in the group the fail over works correctly, but the traffic is just routed primarily through the next available interface. I am hoping to round-robin through the interfaces.

What am I missing here?

I did enable System>Advanced>Miscellaneous>Load Balancing "Use Sticky Connections"


Any help would be great. I'll attach some screenshots of my configuration. I'm not sure how to embed the pictures. This is my first post.

Offline Otaku

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Load Balancing through Multi-VPN WAN
« Reply #1 on: January 28, 2018, 01:52:05 pm »
Perhaps I'm asking the wrong question? Basically, I'm trying to do this to make it so all network traffic cannot be tracked back to a single WAN IP. Is there a different configuration with VPN interfaces that'd make it work?

Thanks for your time.

Offline q54e3w

  • Full Member
  • ***
  • Posts: 164
  • Karma: +16/-1
    • View Profile
Re: Load Balancing through Multi-VPN WAN
« Reply #2 on: January 29, 2018, 01:03:57 am »
Disable sticky connections.

You may have issues with web sites that maintain connection info as they see you hitting from hitting addresses and throw errors etc. Selective routing can help with that.

Offline Otaku

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Load Balancing through Multi-VPN WAN
« Reply #3 on: January 29, 2018, 09:31:10 pm »
Initial signs are that unselecting the sticky connections did the trick. Thanks! I'm still learning. I thought the sticky connections enabled the load balancing too... didn't realize it'd still work without it on.