Netgate Store

Author Topic: An interesting situation with NAT  (Read 153 times)

0 Members and 1 Guest are viewing this topic.

Offline chieftech

  • Jr. Member
  • **
  • Posts: 29
  • Karma: +2/-0
    • View Profile
An interesting situation with NAT
« on: January 22, 2018, 02:13:46 am »
Hi to all, Have some interesting experience. This topic about NAT with some prehistory

2.4.2-RELEASE-p1 (amd64)
built on Tue Dec 12 13:45:26 CST 2017
FreeBSD 11.1-RELEASE-p6

System have 3 WAN connections. Settings on the screenshots.

Initially, my task was to find out how i can exclude the gateway from the rule "Gateway Swiching".

In my case, was created interface for Openvpn connection, for flexible configuration of traffic and static routes.
Of course this interface have own gateway which is displayed along with all.

Once, for some reason the monitoring ip go offline, and Pfsense switched the defaul gateway to gateway of interface for VPN. This broke my entire routing. Besides, Pfsense does this even then Alarm latency on WANs.

I create the topic with a question how i can exclude gateway frome rule "Gateway switching" - there I was advised to turn off this setting in System settings, which I did...

Problems started when WAN that was set default goes down - NAT on another WANs was not working any more.
In general, the problem sounds like this:
In pfsense 2.4.2_p1 NAT does not work without default gateway.
Besides, not working Squid and ddns ip cheking(Do not send an IP to ddns service), and packages check naturally too.

I assumed that this problem is specific only on my system, but:
In 2.3.3 release - does not work too.
In 2.2.6 Release - all work fine, except for packages check but its naturally...

In conclusion, I would very much like to:

1. How to exclude the gateway I need, from the rule "gateway switching"? It would be nice to have such a parameter in the gateway settings.
2. What's wrong with NAT?