Netgate SG-1000 microFirewall

Author Topic: Dont update to latest snap  (Read 393 times)

0 Members and 1 Guest are viewing this topic.

Offline maverick_slo

  • Hero Member
  • *****
  • Posts: 829
  • Karma: +40/-3
    • View Profile
Dont update to latest snap
« on: January 25, 2018, 10:57:22 am »
... itvrendered my system useless.
Unexpected ] in interfaces.inc line i dont know😁

Offline mais_um

  • Full Member
  • ***
  • Posts: 249
  • Karma: +4/-0
    • View Profile
Re: Dont update to latest snap
« Reply #1 on: January 25, 2018, 11:31:28 am »
Happens to me! Lucky me only update the backup one!
pfSense:
ASRock -> Wolfdale1333-D667 (2GB TeamElite Ram)
Marvell 88SA8040 Sata to CF(Sandisk 4GB) Controller
NIC's: RTL8100E (Internal ) and Intel® PRO/1000 PT Dual (Intel 82571GB)

Offline maverick_slo

  • Hero Member
  • *****
  • Posts: 829
  • Karma: +40/-3
    • View Profile
Re: Dont update to latest snap
« Reply #2 on: January 25, 2018, 12:17:38 pm »

Offline TechyTech

  • Newbie
  • *
  • Posts: 20
  • Karma: +6/-0
  • It's the little bits that are the biggest problems
    • View Profile
Re: Dont update to latest snap
« Reply #3 on: January 25, 2018, 12:34:55 pm »
Bleh.  Had to go to shell and edit /etc/inc/interfaces.inc file manually.

LIne 2514:

Code: [Select]
!isset($config['interfaces'][$iface]]['enable'])) {
Should be:

Code: [Select]
!isset($config['interfaces'][$iface]['enable'])) {
Save file and reboot.  All is back up.


Offline maverick_slo

  • Hero Member
  • *****
  • Posts: 829
  • Karma: +40/-3
    • View Profile
Re: Dont update to latest snap
« Reply #4 on: January 25, 2018, 02:02:14 pm »
Fixed :)