Netgate SG-1000 microFirewall

Author Topic: Request denied by pfSense proxy: 403 Forbidden  (Read 225 times)

0 Members and 1 Guest are viewing this topic.

Offline njuguna

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Request denied by pfSense proxy: 403 Forbidden
« on: January 26, 2018, 07:14:02 am »
Hi All,

I am running pfsense 2.4.2.

I have installed squid proxy server and filter configured it to transparent proxy. Have not configured any Target Categories. When the users browse the internet some pages are giving the error

Request denied by pfSense proxy: 403 Forbidden
Reason:
Client address: 192.168.100.206
Client name: 192.168.100.206
Client group: default
Target group: none
URL: http://www.shallalist.de/

any assistance to resolve the error will be highly appreciated

Online KOM

  • Hero Member
  • *****
  • Posts: 5594
  • Karma: +688/-23
    • View Profile
Re: Request denied by pfSense proxy: 403 Forbidden
« Reply #1 on: January 26, 2018, 08:35:29 am »
IIRC the default squidguard config is to block all until you edit the Target Rules of the Common ACL.

Offline njuguna

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Request denied by pfSense proxy: 403 Forbidden
« Reply #2 on: January 27, 2018, 01:15:25 am »
IIRC the default squidguard config is to block all until you edit the Target Rules of the Common ACL.

How do you go about that, am new to pfsense

Online KOM

  • Hero Member
  • *****
  • Posts: 5594
  • Karma: +688/-23
    • View Profile
Re: Request denied by pfSense proxy: 403 Forbidden
« Reply #3 on: January 29, 2018, 09:04:53 am »
Services - Squidguard Proxy Filter - Common ACL

Under General Options - Target Rules, click the + sign the white circle to expand the Target Rules List.

Go down to the very bottom and change Default access [all] = Deny to Allow.

Offline njuguna

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Request denied by pfSense proxy: 403 Forbidden
« Reply #4 on: February 01, 2018, 05:42:14 am »
I tried your solution but still getting the same error

Online KOM

  • Hero Member
  • *****
  • Posts: 5594
  • Karma: +688/-23
    • View Profile
Re: Request denied by pfSense proxy: 403 Forbidden
« Reply #5 on: February 01, 2018, 07:59:57 am »
When you make any changes to squidguard, you need to remember to go back to the General settings page and click the Apply button or nothing you did will take effect.