Netgate SG-1000 microFirewall

Author Topic: Chrome for Business and SQUID Proxy - Secure Connection?  (Read 85 times)

0 Members and 1 Guest are viewing this topic.

Offline epionier

  • Jr. Member
  • **
  • Posts: 68
  • Karma: +1/-0
    • View Profile
Chrome for Business and SQUID Proxy - Secure Connection?
« on: January 26, 2018, 11:00:07 am »

I use pfsense on the local network running SQUID on with local authentification.

I downloaded Chrome for Business that allows me to configure settings via (ADM / GPO).

Unfortunately I am unable to get Chrome working with SQUID properly with a secure connection.

I want that Chrome connects to the squid server with a secure connection (TLS) no matter if the destination website ist HTTPS or HTTP.

What I have done:

1) I used GPO for manual proxy connection and entered because https://10.21.301.1:3128 is not working
(Which should be possible according to:
In chrome it asks then for proxy authentification. This is working but this is a unsecure connection because in the authentification it says and not https.//......
How do I switch to TLS connection?
After importing the local certificate of SQUID I am able to connect to HTTPS sites. But is the connection to the local SQUID server then secure with TLS?

2) By the way, does anyone know a possibility that Chrome does not ask for proxy authentification on startup? I get the prompt every time I open Chrome no matter if the credentials are saved or not.

I know this a certain question for Chrome but it depends on SQUID, too.
Maybe someone can help me out.