Netgate SG-1000 microFirewall

Author Topic: Squidguard blocking Netflix on ROKU client  (Read 178 times)

0 Members and 1 Guest are viewing this topic.

Offline etaggart

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Squidguard blocking Netflix on ROKU client
« on: January 29, 2018, 09:20:48 pm »
I'm having trouble with Squidguard blocking Netflix from Roku clients.   I've whitelisted netflix.com and nflxvideo.net but it's still getting blocked?   Blocked message in log is below:

29.01.2018 22:10:19   192.168.1.51/roku.taggarthome.com   http://23.246.6.210/?o=AQFcbeCGEjLIyGQFesK3rUjJvp_c-gwUBCQIhY_FnNLJMsMNjgKWibgzPRtxj2iA5p9UKnsS84xHqIOrr7yfFYUtv8NSCLe03UfX3n3G7eMBKwqnnL_uQXRXBzbc-ODez48eVCwsoNaMrxlZUxM_A-FkbVFY6rlDtEWW9IlUSVu3NWhvL2CXzJJams3Hki7fygDVcKw&v=3&e=1517325017&t=h0anJZHDX_hho-dreD4WlTZM0GA#ebr=0+29443&s=1   Request(default/in-addr/-) - GET REDIRECT

Stumped... 

Thanks for any help pointing me in the right direction.

Offline user12345

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Squidguard blocking Netflix on ROKU client
« Reply #1 on: January 30, 2018, 08:35:33 pm »
Where did you whitelist and how?  I had the same problem but had to do a very specific set of steps to get past it. 

Offline etaggart

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Squidguard blocking Netflix on ROKU client
« Reply #2 on: February 07, 2018, 09:31:43 pm »
I have a whitelist defined in squidguard, but I suspect the ROKU netflix client is not using he netflix dns names, but IP addresses.   How did you get past it?

Offline etaggart

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Squidguard blocking Netflix on ROKU client
« Reply #3 on: February 07, 2018, 10:04:04 pm »
That's what it was.  The Roku netflix client wasn't using the domain name, but IP addresses for the Netflix servers.   I guess I should have realized that in the log.  Even though I had the option "Do not allow IP-Addresses in URL" unchecked, I was looked at the squidguard config at /usr/local/etc/SquidGuard/SquidGuard.conf and saw that it had !in-addr which was blocking anything that had an IP address in the URL.   Seems to be working fine now after I removed that.