Netgate SG-1000 microFirewall

Author Topic: DNS Forwarder not working on reboot  (Read 145 times)

0 Members and 1 Guest are viewing this topic.

Offline rquigley

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
DNS Forwarder not working on reboot
« on: February 05, 2018, 05:36:20 pm »
Hi All,

I'm currently using the DNS Forwarder as a means of serving internal DNS for services I run on my network.

For some reason, I'm noticing that any time I restart or boot cold my instance, the internal DNS doesn't resolve. I'm able to fix this by simply saving the existing configuration in the GUI and Apply Changes which gets it up and running again.

I'm just wanting to know whether this is an issue for all or just myself?

I'm running PfSense 2.4.2-RELEASE-P1.

Any assistance would be appreciated. Many thanks!

Offline fcapizzo

  • Jr. Member
  • **
  • Posts: 50
  • Karma: +0/-0
    • View Profile
Re: DNS Forwarder not working on reboot
« Reply #1 on: February 19, 2018, 01:53:30 am »
I reported this (https://forum.pfsense.org/index.php?topic=132179.msg727024) back in 2017, but no one replied.  This still happens to me now.

The most annoying instance of this happening is I update pfSense by connecting internal DNS entry for my pfSense router.  The last part of the update reboots the router and waits for it to be reachable afterwards.  Unfortunately, because DNS Forwarder does not work correctly on reboot, it looks as if the update fails.  At that time I need to connect to the router via IP, and then restart DNS Forwarder.

I wish this was fixed, because this is really the only issue I have with pfSense.

Offline marvosa

  • Hero Member
  • *****
  • Posts: 776
  • Karma: +42/-0
    • View Profile
Re: DNS Forwarder not working on reboot
« Reply #2 on: February 19, 2018, 01:11:41 pm »
Several upgrades ago, I had a similar issue with the forwarder... where it would not resolve anything after an upgrade.    I never tried re-saving the config, but what did work for me was specifically selecting my LAN interfaces on Services -> DNS Forwarder instead of leaving it on "All".

We may have two totally separate issues, but it's worth a shot.