Netgate SG-1000 microFirewall

Author Topic: Squid ssl filtering not working  (Read 144 times)

0 Members and 1 Guest are viewing this topic.

Offline Bytec0de

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Squid ssl filtering not working
« on: February 06, 2018, 07:00:06 am »
HI,
      I have enabled https filtering in squid and have created a CA for it..also I am using "Splice All" as SSL/MITM Mode. It runs great on chrome but I get "SSL_ERROR_RX_RECORD_TOO_LONG" error on firefox on some websites...  I do not want to add certificate manually on browser/system.  Is there any solution for this problem?

Thanks in advance
« Last Edit: February 07, 2018, 01:52:56 am by Bytec0de »

Offline slim2016

  • Jr. Member
  • **
  • Posts: 36
  • Karma: +1/-0
    • View Profile
Re: Squid ssl filtering not working
« Reply #1 on: February 07, 2018, 07:18:24 am »
Have you installed squidguard? can you show us a screenshot of the squid settings?

Offline Bytec0de

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Squid ssl filtering not working
« Reply #2 on: February 08, 2018, 06:08:39 am »
Thanks for the reply.. Yes I have installed squidguard... Please look for the screenshot of squid settings below.