pfSense English Support > General Questions

(solved) Nessus vulnerability false positives

(1/8) > >>

MaxBishop:
I am running version 2.4.2-RELEASE-p1 (amd64)

A Nessus scan shows several false positives identified as: pfSense < 2.1.1 Multiple Vulnerabilities

It reports my installed version as: unknown..0

My question is: is the current version of pfSense hiding its version?

johnpoz:
How exactly are you scanning - from public wan side or lan side?  do you have ports open on the wan?  What exactly are you scanning with, what version of Nessue/Tenable?

MaxBishop:
Hi,

I'm scanning from the LAN side with:
Nessus  7.0.1 (#108) LINUX
Updated: February 7 at 12:15 PM
Plugin set: 201802071215

The scan identifies 4 Critical, 5 High, and 9 Medium level vulnerabilities.

--- Code: ---
CRITICAL 10.0 106488 pfSense < 2.1.1 Multiple Vulnerabilities (SA-14_02 - SA-14_03)
CRITICAL 10.0 106490 pfSense SA-14_08 / pfSense SA-14_09 / pfSense SA-14_10 / pfSense SA-14_11 / SA-14-12 SA-14-12 : Multiple Vulnerabilities
CRITICAL 10.0 106491 pfSense < 2.1.5 Multiple Vulnerabilities (SA-14_15 - SA-14_17)
CRITICAL 0.0 106499 pfSense SA-16_01 / SA-16-02 : Multiple Vulnerabilities
HIGH 9.0 106501 pfSense < 2.3.1-p1 Multiple Vulnerabilities (SA-16_05)
HIGH 9.0 106502 pfSense < 2.3.1-p5 Multiple Vulnerabilities (SA-16_07 - SA-16_08)
HIGH 9.0 106503 pfSense < 2.3.3 Multiple Vulnerabilities (SA-17_01 - SA-17_03)
HIGH 7.8 106489 pfSense < 2.1.3 Remote Denial of Service Vulnerability (SA-14_05)
HIGH 7.5 106498 pfSense SA-15_10 / SA-15-11 : Multiple Vulnerabilities
MEDIUM 6.8 106493 pfSense < 2.2.1 Multiple Vulnerabilities (SA-15_02 - SA-15_04)
MEDIUM 4.3 106492 pfSense < 2.2 Multiple Vulnerabilities (SA-15_01)
MEDIUM 4.3 106494 pfSense < 2.2.2 Multiple Vulnerabilities (SA-15_05)
MEDIUM 4.3 106495 pfSense < 2.2.3 Multiple Vulnerabilities (SA-15_07)
MEDIUM 4.3 106496 pfSense < 2.2.4 Multiple Vulnerabilities (SA-15_07)
MEDIUM 4.3 106497 pfSense < 2.2.5 Multiple Vulnerabilities (SA-15_08)
MEDIUM 4.3 106500 pfSense SA-16_03 / SA-16-04 : Multiple Vulnerabilities
MEDIUM 4.3 106504 pfSense < 2.3.4 DHCP Lease Display XSS (SA-17_04)
MEDIUM 4.3 106505 pfSense < 2.3.4-p1 Multiple Vulnerabilities (SA-17_05 - SA-17_06)

--- End code ---

I can provide a more detailed report, but again, all of these are based on the reported pfSense version number (unknown..0).

johnpoz:
Well clearly something is not right if your running 2.4.2p1 and all those issues are related to running pfense below looks like 2.3.4p1

I will have to fire up nessus and do a scan, just haven't played with it in a bit - will fire up that VM...

MaxBishop:
Hi,
Thanks,
Let me know if you need any other information.
Meanwhile, I'll check it out in my VM prototype network too.

Navigation

[0] Message Index

[#] Next page

Go to full version