Netgate Store

Author Topic: Can't install with ZFS 2.4.2  (Read 822 times)

0 Members and 1 Guest are viewing this topic.

Offline NotAnAlias

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +1/-2
    • View Profile
Can't install with ZFS 2.4.2
« on: February 09, 2018, 01:00:20 am »
Hello,

I am using the amd64 2.4.2 pfsense version.

Specs:
Motherboard: GA-B150M-D3H
Memory: 2x2gb ddr3 1066
Flash drive: Sandisk ultra usb 3.0 for installation
SSD: Silicon Power 60GB SSD S60 MLC
CPU: G4400

When I try to install with ZFS, I select stripe option and select the 60gb Silicon Power SSD.
It errors saying:

Code: [Select]
ahcich1: Timeout on slot 0 port 0
ahcich1:  is 00000000 cs 00000000 ss 00000001 rs 00000001 tfd 40 serr 00000000 cmd 0000c017
ada8:ahcich1:0:0:0): SEND_FPDMA_QUEUED DATA SET MANAGEMENT. ACB: 64 02 00 00 00 40 00 00 00 00 00

It gets stuck here, a picture may be more helpful(large):
https://i.imgur.com/o2vMXZp.jpg

Any ideas why this may be happening? UFS seemed to install just fine. However I do not trust UFS, it corrupts very easily. It is worth noting, this same system had issues with a nanobsd install as well on 2.3.x. It took a very very long time to boot up. Others with the same configuration have the same issue. https://www.reddit.com/r/PFSENSE/comments/49qc4x/its_very_slow_on_my_skylake_g4400/

I have tried different SATA cables and different ports. The SSD works fine connected via a USB adapter to a different computer, it checks out with crystaldiskmark and crystaldiskinfo.
« Last Edit: February 09, 2018, 01:05:24 am by NotAnAlias »

Offline NotAnAlias

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +1/-2
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #1 on: February 19, 2018, 01:37:27 am »
This appears to be a FreeBSD issue, I tried installing 11.1 and I have the same problem. I'll try and look around there.

Offline revengineer

  • Jr. Member
  • **
  • Posts: 98
  • Karma: +6/-0
    • View Profile

Offline Iceman24

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +2/-0
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #3 on: March 04, 2018, 10:15:28 pm »
Anyone with solution to this? I've been unable to install latest stable on ZFS.

Offline Iceman24

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +2/-0
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #4 on: March 04, 2018, 10:54:29 pm »
I did get it to install with NVMe SSD. I'm not using an expensive SSD for this though, but if I used an M.2 SATA SSD, would that also work? It's SATA, but M.2, so maybe it gets around this. Can anyone confirm this for me? I'd need to order one ASAP.

Offline Iceman24

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +2/-0
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #5 on: March 05, 2018, 10:11:09 am »
Another update on this. I tried a Seagate 2.5" HDD and it worked fine with ZFS, so it doesn't even affect all SATA drives. Good to know. Hopefully different SSD that I order will work.

Offline Gertjan

  • Hero Member
  • *****
  • Posts: 2696
  • Karma: +218/-9
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #6 on: March 05, 2018, 10:16:10 am »
... UFS seemed to install just fine. However I do not trust UFS, it corrupts very easily. It is worth noting, ....
Running pfSense on an old Dell Dimension 5150, which is a retired desktop PC, 7 years ago ... with a hard disk that last already 10 years running UFS ....
Never saw something that looked like a disk corruption.


Btw : I have an UPS ...  ;)

Offline NotAnAlias

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +1/-2
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #7 on: March 12, 2018, 06:39:48 pm »
Does this help: https://forums.freebsd.org/threads/cam-errors-freebsd-11-1.61796/post-356879?

Been a while since I tried this since i just went back to pfsense 2.3.5 on another machine for the timebeing.

I tried a very similar command at bootup and it did not help unfortunately. I also tried two different SSDs and they both have the same issue.
I tried registering at the FreeBSD forums to ask there, but an admin never approved my account when I tried to register.
« Last Edit: March 12, 2018, 06:42:57 pm by NotAnAlias »

Offline Iceman24

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +2/-0
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #8 on: March 12, 2018, 06:43:14 pm »
To follow up, a different SSD did work. Seems like just an issue on certain drives.

Offline NotAnAlias

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +1/-2
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #9 on: March 13, 2018, 04:06:21 pm »
To follow up, a different SSD did work. Seems like just an issue on certain drives.
What SSD worked for you?

Offline Iceman24

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +2/-0
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #10 on: March 13, 2018, 05:43:06 pm »
To follow up, a different SSD did work. Seems like just an issue on certain drives.
What SSD worked for you?
Silicon Power 120GB M55 M.2 2280 SSD With R/W Up To 550MB/s (SLC Cache for Speed Boost) SATA III Internal Solid State Drive for Ultrabooks and Tablets (SP120GBSS3M55M28)
https://www.amazon.com/gp/product/B074ZF28GP

Offline NotAnAlias

  • Jr. Member
  • **
  • Posts: 39
  • Karma: +1/-2
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #11 on: March 28, 2018, 08:51:48 am »
Just an update, instead of buying a new ssd I did something naughty.

I went ahead and just used a sata to usb 3.0 adapter and ZFS works fine. I just have it plugged outside the case for now, but I went ahead and ordered a 20pin to type A adapter so I can put the SSD in the pc.


Offline SammyWoo

  • Full Member
  • ***
  • Posts: 209
  • Karma: +9/-4
    • View Profile
Re: Can't install with ZFS 2.4.2
« Reply #12 on: March 28, 2018, 02:12:44 pm »
Well thank you for this thread so am not the only dummy who can't do this simple thing :) Got error on my Sandisk SSD ask well, and I gave up, not gonna buy another SSD, UFS and my UPS already does the job anyway, just thought if it's free, throw that in there right, but if it makes me jump through hoops, meh.