Netgate SG-1000 microFirewall

Author Topic: Undocumented protocol change in pfsync ?  (Read 86 times)

0 Members and 1 Guest are viewing this topic.

Offline UnknownNR1

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
  • Systemadministrator
    • View Profile
Undocumented protocol change in pfsync ?
« on: February 22, 2018, 09:07:16 am »
Yesterday I tried to update a cluster of two devices from 2.3.4 to 2.4.2.
After the slave installs the new version, pfsync no longer works. So when the addresses swung, I lost a bunch of connections.

I took a closer look at the problem and found that definitely no states were exchanged. After the master had the new version everything worked again without problems.

Was the protocol changed again for pfsync? I could not find anything in the documentation or release notes.

Sorry for possible bad English

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 21619
  • Karma: +1486/-26
    • View Profile
Re: Undocumented protocol change in pfsync ?
« Reply #1 on: February 23, 2018, 07:32:01 am »
Any time there is an upgrade, especially across operating system versions, there is always a possibility that will happen. It doesn't always affect everyone, but you can never rely on pfsync working during a significant OS update.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!