pfSense English Support > Traffic Shaping

Traffic not being sorted into queue


Hi Guys,

I am new and have been trying to figure out traffic shaping for 2 days now and just can't seem to get all my traffic going to one IP address to go through a separate queue to everything else

All I want is for all traffic going to to be lower priority

I have done the traffic shaper wizard at least 20 times with different things set up

I have tried every combination of rule I can think of being floating, WAN or LAN as pass or match and interface as LAN or WAN in those rules

I have the default allow LAN to any rule still set up which seems to be getting pretty much all the traffic which I'm not sure is the issue which you can see here

If I put the default allow all LAN rule into the queue the traffic will go through the queue but obviously I want to have 2 queues working not just 1 as that would be pointless

I've also tried to do it just by port 6881 as well since that is where most of the traffic should be going to and that doesn't seem to work

I ran Wireshark on my computer at and it shows the traffic coming in to port 6881 just fine

This is what the queue looks like at the moment too

I am running version 2.4.2p1

Is there a bug at the moment which doesn't allow for match rules to sort into the correct queues?

Any help would be awesome


If this traffic is coming in from the WAN, none of the actual traffic will have Destination addresses of  It's going to have a destination of your WAN IP, and it is then being NAT'ed to the internal host.

You have to match on the WAN side and do it based on inbound / destination port.  The shaper wizard should do this automatically, there's a rule for bittorrent that sets it to lower priority...

Thanks bradenmcg

I have already ran the wizard and I know the rule you're talking about but that rule doesn't do anything for me. In fact any floating rule that I create and assign to the qPnP queue will not be matched by the rule except for a few packets as you can see in the first pic.

The only way I have had this kinda work is if I create a LAN rule that passes the traffic to the SOURCE of Not destination but source which I thought was backwards until I tried it and now traffic going from the internet to goes into the queue but it isn't perfect and I'm sure there are other issues that will pop up from it being a pass rule and not match and also the fact it is in LAN rules may affect LAN traffic


[0] Message Index

Go to full version