pfSense English Support > 2.4 Development Snapshots

[solved] clients connecting to OpenVPN server not getting server's IP address



First off I am able to connect and get access to resources on local network and I did not have this issue before upgrading to development snapshots.

I might have messed up the setup when I setup openvpn as a client too with manual outbound NAT, but that only affects one out of 3 VLAN network. And the VLAN network I am accessing via openvpn server remains untouched by me.

So the issue I am having is that I am able to connect and get access to all my local resources but when I do whatismyip in google, I don't get my home IP, instead I get the regular non-VPN IP that I am connecting from. (IP does not change)

I have no idea how I am able to access all my local resources but don't get the local ip address.

In order to get the server's IP, you need to tunnel all traffic, per this option:

Force all client-generated IPv4 traffic through the tunnel.
Force all client-generated IPv6 traffic through the tunnel.

I see that those options are unchecked in your config.

It works now thanks!


[0] Message Index

Go to full version