Netgate SG-1000 microFirewall

Author Topic: Unbound Error: Address already in use...when using Cloudflare config  (Read 176 times)

0 Members and 1 Guest are viewing this topic.

Offline gsmornot

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +2/-0
    • View Profile
Searching did not find much for this error, any ideas? Quad9 does not have this issue, it is (for me) only when I use Cloudflare in my DNSResolver config.

Apr 16 14:15:19   unbound   57988:1   error: outgoing tcp: connect: Address already in use for 2606:4700:4700::1001
Apr 16 13:51:29   unbound   57988:1   error: outgoing tcp: connect: Address already in use for 1.1.1.1
Apr 16 11:23:57   unbound   57988:0   error: outgoing tcp: connect: Address already in use for 2606:4700:4700::1111
Apr 16 11:18:07   unbound   57988:0   error: outgoing tcp: connect: Address already in use for 1.1.1.1
Apr 16 10:49:35   unbound   57988:1   error: outgoing tcp: connect: Address already in use for 2606:4700:4700::1001
Apr 16 07:59:54   unbound   57988:0   error: outgoing tcp: connect: Address already in use for 1.1.1.1

The config I am using at the moment:
server:
include: /var/unbound/pfb_dnsbl.*conf
forward-zone:
name: "."
forward-ssl-upstream: yes
forward-addr: 1.1.1.1@853
forward-addr: 1.0.0.1@853
forward-addr: 2606:4700:4700::1111@853
forward-addr: 2606:4700:4700::1001@853

Offline NeoDude

  • Jr. Member
  • **
  • Posts: 40
  • Karma: +3/-0
    • View Profile
    • Chris Lawrence Photography
Re: Unbound Error: Address already in use...when using Cloudflare config
« Reply #1 on: April 17, 2018, 09:49:50 am »
Did you uncheck forwarder in Resolver Settings?
Home Server "Gandalf":  unRAID Pro 6 | MB:  ASUS Z9PE-D8 WS | CPU:  Dual Xeon E5-2670 | RAM:  64GB Crucial PC-1600 ECC

Offline CiscoX

  • Jr. Member
  • **
  • Posts: 30
  • Karma: +2/-0
    • View Profile
Re: Unbound Error: Address already in use...when using Cloudflare config
« Reply #2 on: April 17, 2018, 03:56:26 pm »
Hi,

I have the same in my log.
Intel i5-7400
8GB DDR4 2133Mhz
Samsung SSD 120

Offline gsmornot

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +2/-0
    • View Profile
Re: Unbound Error: Address already in use...when using Cloudflare config
« Reply #3 on: April 17, 2018, 08:13:45 pm »
Did you uncheck forwarder in Resolver Settings?
Yes. I have not used the forward option.
« Last Edit: April 17, 2018, 09:57:47 pm by gsmornot »

Offline gsmornot

  • Jr. Member
  • **
  • Posts: 61
  • Karma: +2/-0
    • View Profile
Re: Unbound Error: Address already in use...when using Cloudflare config
« Reply #4 on: April 18, 2018, 06:23:56 am »
Iím getting this now too:

Apr 18 06:13:35   unbound   56170:1   error: SSL_handshake syscall: Connection reset by peer
Apr 18 06:12:44   unbound   56170:1   error: SSL_handshake syscall: Connection reset by peer
Apr 18 06:12:23   unbound   56170:1   error: SSL_read syscall: Connection reset by peer

Offline cybrnook

  • Newbie
  • *
  • Posts: 17
  • Karma: +3/-0
    • View Profile
Re: Unbound Error: Address already in use...when using Cloudflare config
« Reply #5 on: April 18, 2018, 06:30:52 pm »
Also seeing this!

Apr 13 08:56:26    unbound    77728:4    error: outgoing tcp: connect: Address already in use for 1.1.1.1
Apr 13 08:56:33    unbound    77728:3    error: outgoing tcp: connect: Address already in use for 1.0.0.1
Apr 14 10:21:28    unbound    77728:3    error: outgoing tcp: connect: Address already in use for 1.0.0.1
Apr 15 13:16:32    unbound    77728:2    error: outgoing tcp: connect: Address already in use for 1.1.1.1
Apr 15 19:39:52    unbound    77728:2    error: outgoing tcp: connect: Address already in use for 1.1.1.1
Apr 15 22:26:56    unbound    77728:4    error: outgoing tcp: connect: Address already in use for 1.1.1.1
Apr 16 19:31:21    unbound    77728:2    error: SSL_read syscall: Connection reset by peer
Apr 16 20:39:28    unbound    77728:5    error: outgoing tcp: connect: Address already in use for 1.0.0.1
Apr 17 21:25:30    unbound    77728:7    error: outgoing tcp: connect: Address already in use for 1.1.1.1
Apr 17 22:23:10    unbound    77728:5    error: outgoing tcp: connect: Address already in use for 1.0.0.1
Apr 17 22:29:41    unbound    77728:3    error: outgoing tcp: connect: Address already in use for 1.1.1.1