The pfSense Store

Author Topic: latest snapsot wireless bridged as well as static not working  (Read 26783 times)

0 Members and 1 Guest are viewing this topic.

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
  • Karma: +0/-0
    • View Profile
latest snapsot, wireless gone down, doesnt work in bridged as well as static mode, not giving out ip address at all inspite of dhcp server configured properly.

its just that in both static as well as bridged mode it doesnt give out ip addresses so i think its an issue with DHCL
« Last Edit: April 09, 2009, 12:34:22 am by xbipin »

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #1 on: April 12, 2009, 12:29:43 am »
no1 to confirm wireless bridge on embedded on alix not functioning, basically works but dhcp having issues so doesnt give ip address at all and on manually configuring it also doesnt communicate

Offline Sloth

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #2 on: April 18, 2009, 02:36:32 am »
I can confirm that Wireless bridging is Borked on My Alix box running builds 0416-2048 and 0417-2146. Devices are associating successfully, but no traffic is being passed to LAN (Wifi bridged -> LAN). Have rolled back to 0328-0054, retaining same config, which works just fine.

Hardware:
Alix 2c3 BIOS 0.99h
Atheros 5212 based miniPCI card (Wistron CM9)

Offline timd

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
    • it support london
Re: latest snapsot wireless bridged as well as static not working
« Reply #3 on: April 19, 2009, 06:02:29 am »
Had same problem however a reboot has fixed it and so far its still up. (at home so dont mind testing)

Along with all that at least my massive wireless in / out errors are gone so hopefully this can be fixed while retaining these drivers.

Along with that it appears the ammount of inturupt on the processor is down when pushing my 50meg virgin line to the limit which is nice.

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5262
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #4 on: April 19, 2009, 06:36:31 am »
I'm running 1.2.3-RC1 built on Mon Apr 13 16:35:28 EDT 2009 and I'm not having any trouble with LAN bridged with wireless. DHCP hands out IP addresses to laptops linked over wireless.

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #5 on: April 19, 2009, 09:12:19 am »
i just installed 1.2.3-RC1 built on Mon Apr 13 17:15:57 EDT 2009 and it doesnt work, rebooted also but still the same, in bridged mode doesnt give ip and also id ip defined manually still doesnt provide internet access. if put in standard wireless mode without lan bridge, then still doesnt give out ip using dhcp, only works if ip defined manually in client.

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5262
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #6 on: April 19, 2009, 04:02:17 pm »
Do you have firewall rules allowing DHCP traffic on your wireless interface? There are a number of posts giving suitable rules.




Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #7 on: April 19, 2009, 11:34:58 pm »
with the following 2 rules it was working in older releases so i dont think thats the issue as the firewall doesnt block any such packets also

Offline Sloth

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #8 on: April 20, 2009, 02:05:04 am »
Wallybob: I also have an 'allow all' rule for the WiFi Interface (as noted in My post above this is a working config that is only borked by the most recent builds)

timd et al: what WiFi hardware are you running, and what flavour of pfSense - full or emebedded?

btw  Since the recent important WiFi code update, and aside from the current issue, the performance and reliablility of WiFi connections has been excellent: My stand-alone Wireless AP is now gathering dust...

Reagards

Jason.
« Last Edit: April 20, 2009, 02:08:07 am by Sloth »

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5262
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #9 on: April 20, 2009, 03:57:23 am »
I am running full version, atheros wireless NIC.

sloth and xbipin: have you looked in the DHCP server log for signs that the DHCP server received a request from the wireless NIC? (See Status -> System logs and click on the DHCP tab. Note though that for received DHCP requests on a wireless NIC bridged with a wired NIC the log reports wired NIC rather than the wireless NIC.) Is there isny error reports in the DHCP log?

Is there any report in the Firewall log that suggests the firewall is blocking DHCP?

Does a tcpdump on the wireless interface show received DHCP packets?



Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #10 on: April 20, 2009, 04:11:26 am »
the dhcp log doesnt show anything and the tcpdump gave the results present in the txt file
there is nothing in the system log or firewall log that suggests that something is blocking it

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5262
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #11 on: April 20, 2009, 04:36:42 am »
So tcpdump on the wireless interface shows incoming DHCP packets but the DHCP server doesn't log generating a response to them.

I suspect the firewall is blocking them (check your DHCP enabling rules are active on the wireless NIC) or the DHCP server is rejecting them ad not reporting them. (Do you have DHCP restricted to handing out addresses ONLY to known MAC addresses and the source address in the tcpdump trace is not in the "known MAC address" list? )

Offline wallabybob

  • Hero Member
  • *****
  • Posts: 5262
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #12 on: April 20, 2009, 04:41:50 am »
Please also look for blocked DHCP requests in /var/log/filter.log (That where I found them logged when I reported a DHCP problem in August 2008.)

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #13 on: April 20, 2009, 05:08:00 am »
the wireless is bridged to LAN and DHCP server is enabled on LAN and give ip to known MAC is unticked which is by default so its supposed to give out ips and in the log i replaced the mac address of my wireless client to 00:23:6c:xx:xx:xx so in it the last 3 portions i have purposely changed

Offline xbipin

  • Hero Member
  • *****
  • Posts: 1220
  • Karma: +0/-0
    • View Profile
Re: latest snapsot wireless bridged as well as static not working
« Reply #14 on: April 20, 2009, 05:16:56 am »
my filter log seems like this, its not blocking anything