The pfSense Store

Author Topic: automaticamente a portal cautivo http://192.168.1.1:8000  (Read 56920 times)

0 Members and 2 Guests are viewing this topic.

Offline hmeperu

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
automaticamente a portal cautivo http://192.168.1.1:8000
« on: September 22, 2009, 11:25:07 am »
 :-\
Buenas a todos gracias por toda la ayuda que estoy consiguiendo aqui, bueno el problema que tengo es que cuando reiniciio mi server por alguna falla como corte de luz, los clientes
que ya habian navegado anteriormente se quedan sin navegar ya que tienen que volver a escribir en el browser http://192.168.1.1:8000 osea no sale automatico, se supone que anteriormente ya se logearon, pense que no tenian que volver hacer eso, y bueno el problema es que no sale automatico tienen que hacer siempre eso los clientes..cuando cargan
algo o ponen una pagina www.google.com no carga y bueno tengo que llamarle y decirle que entren a la pagina de arriba y escriban todo eso..entienden?? bueno y eso un fastidio..
lo mejor seria que salga automaticamente para poner username o password...o aun mejor que ya no pida...mi pregunta es ??? si se va la luz los clientes tienen que identificarse otra vez con el servidor??????????....o en todo caso como se hace para que sea automaticamente si es que hay algun cambio en el server para que siempre aparesca eso por primera vez siempre y cuando no haya internet??

Offline sanchezluys

  • Sr. Member
  • ****
  • Posts: 548
  • Karma: +0/-0
    • View Profile
    • http://www.adrianamoda.lgg.com.ve
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #1 on: September 22, 2009, 01:05:19 pm »
 :) hola..

ya se ha hablado en varias ocasiones de este tema, cuando modificaste el archivo .html de entrada del captive portal borraste parte del codigo necesario para que se active de manera autoamtica la pagina de entrada, o tienes algun error en dicho html. verificalo o colocalo aca para que lo revisemos entre todos.
** Soporte Via Correo en Venezuela **
*- diseño y puesta en marcha del portal cautivo, eliminacion de p2p, control de acceso de usuarios, instalacion y configuracion basica del pfsense, OpenVpn -* Equipos con S.O. PC-BSD, OpenBSD, Linux, Win y OpenSolaris sobre x86
www.lgg.com.ve  www.adrianamoda.lgg.com.ve

Offline hmeperu

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #2 on: September 22, 2009, 02:43:53 pm »
HOla a todos miren este es mi codigo: la verdad lo copie de un lugar




<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

<title>Bienvenido a Internet - Casa</title>

</head>
<body>

<h1>INTERNET HOME 2009</h1>

<p>Ingrese en las casillas en blanco su username y password que se le proporciono a su email, luego haga click en boton LOGIN para iniciar el Internet.Si aun no tiene esos datos llame al 777777 para que aperturen su cuenta.</p>

<p>si aun tienes problemas para accesar al servicio es posible debido a que tu cuenta fue bloqueada
debido a algun retraso de pago.</p>

<p>Los depositos se realizan en el BANCO DE SCOTIABANK</p>

<h2>Identificate</h2>

<form method="post" action="$PORTAL_ACTION$">

   <fieldset>

   <legend>Datos de Cuenta</legend>

   <p>
      <label for="Username">Username:</label>
      <input type="text" id="auth_user" name="auth_user" size="25"/> ()
   </p>

   <p>
      <label for="Password">Password:</label>
      <input type="Password" id="auth_pass" name="auth_pass" size="25"/> ()
   </p>

   <input name="redirurl" type="hidden" value="$PORTAL_REDIRURL$">

   </fieldset>

   <p><input name="accept" type="submit" value="Login"></p>

</form>

</body>


tambie npor ahi escuche que hay que configurar DHCP Server??

Offline sanchezluys

  • Sr. Member
  • ****
  • Posts: 548
  • Karma: +0/-0
    • View Profile
    • http://www.adrianamoda.lgg.com.ve
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #3 on: September 22, 2009, 05:19:40 pm »
 :) hola...

tal como te comente el codigo tiene detalles.

Code: [Select]
(*)  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
(*)  <html lang="en">
(ok) <head>
(*)  <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
(ok) <title>Bienvenido a Internet - Casa</title>
(ok)  </head>
(ok)  <body>
(ok)  <h1>INTERNET HOME 2009</h1>
(ok)  <p>Ingrese en las casillas en blanco su username y password que se le proporciono a su email, luego haga click en boton LOGIN para iniciar el Internet.Si aun no tiene esos datos llame al 777777 para que aperturen su cuenta.</p>

(ok)  <p>si aun tienes problemas para accesar al servicio es posible debido a que tu cuenta fue bloqueada
debido a algun retraso de pago.</p>

(ok)  <p>Los depositos se realizan en el BANCO DE SCOTIABANK</p>

(ok)  <h2>Identificate</h2>

(x1)  <form method="post" action="$PORTAL_ACTION$">

(ok)   <fieldset>

(ok)   <legend>Datos de Cuenta</legend>

(ok)   <p>
(ok)      <label for="Username">Username:</label>
(x2)     <input type="text" id="auth_user" name="auth_user" size="25"/> ()
(ok)   </p>

(ok)   <p>
(ok)      <label for="Password">Password:</label>
(x3)      <input type="Password" id="auth_pass" name="auth_pass" size="25"/> ()
(ok)   </p>

(x4)   <input name="redirurl" type="hidden" value="$PORTAL_REDIRURL$">

(ok)   </fieldset>

(ok)   <p><input name="accept" type="submit" value="Login"></p>

(ok) </form>

(ok) </body>

donde:
(*) es codigo que considero que no es necesario
(ok) codigo que considero que esta bien
(x..) codigo que considero que esta mal.

para x1:
  tienes:         <form method="post" action="$PORTAL_ACTION$">  
  deberia ser:  <form method="post" action="http://192.168.1.1:8000/">

para x2:
  tienes:         <input type="text" id="auth_user" name="auth_user" size="25"/> ()
  deberia ser:   <input name="auth_user" size="25" type="text">

para x3:         
  tienes:         <input type="Password" id="auth_pass" name="auth_pass" size="25"/>
  deberia ser:   <input name="auth_pass" size="25" type="password">

para x4:
  tienes:        <input name="redirurl" type="hidden" value="$PORTAL_REDIRURL$">
  deberia ser: <input name="redirurl" value="http://www.google.co.ve" type="hidden">

lo mas grave es x1 y x4 a mi juicio... esperemos comentarios de otros foristas
« Last Edit: September 22, 2009, 05:44:37 pm by sanchezluys »
** Soporte Via Correo en Venezuela **
*- diseño y puesta en marcha del portal cautivo, eliminacion de p2p, control de acceso de usuarios, instalacion y configuracion basica del pfsense, OpenVpn -* Equipos con S.O. PC-BSD, OpenBSD, Linux, Win y OpenSolaris sobre x86
www.lgg.com.ve  www.adrianamoda.lgg.com.ve

Offline hmeperu

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #4 on: September 25, 2009, 06:31:12 pm »
hola amigo mira y este es el codigo html cuando el id y el password no son correctos mira


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

<title>Datos erroneos - Verifique</title>

</head>
<body>

<h1>INTERNET HOME 2009</h1>

<p>Tienes que ingresar correctamente tu cuenta de internet, tu username y password
para que puedas hacer uso del servicio de Internet.</p>

<p>Si al ingresar tu cuenta tienes problemas,envia un email al correo que te proporciono tu
username y password, de inmediato se contactaran para la brindarte una nueva cuenta.</p>

<h2>INICIO</h2>

<form method="post" action="$PORTAL_ACTION$">

   <fieldset>

   <legend>Datos de Cuenta</legend>

   <p>
      <label for="Username">Username:</label>
      <input type="text" id="auth_user" name="auth_user" size="25"/> ()
   </p>

   <p>
      <label for="Password">Password:</label>
      <input type="Password" id="auth_pass" name="auth_pass" size="25"/> ()
   </p>

   <input name="redirurl" type="hidden" value="$PORTAL_REDIRURL$">

   </fieldset>

   <p><input name="accept" type="submit" value="Login"></p>

</form>

</body>

Offline sanchezluys

  • Sr. Member
  • ****
  • Posts: 548
  • Karma: +0/-0
    • View Profile
    • http://www.adrianamoda.lgg.com.ve
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #5 on: September 26, 2009, 02:32:26 pm »
toma un tiempo y lee un poquito...

aca puedes empezar.

http://www.programacion.com/html/tutorial/curso/
** Soporte Via Correo en Venezuela **
*- diseño y puesta en marcha del portal cautivo, eliminacion de p2p, control de acceso de usuarios, instalacion y configuracion basica del pfsense, OpenVpn -* Equipos con S.O. PC-BSD, OpenBSD, Linux, Win y OpenSolaris sobre x86
www.lgg.com.ve  www.adrianamoda.lgg.com.ve

Offline hmeperu

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #6 on: September 28, 2009, 07:46:51 pm »
Hola...amigo probe tu codigo y no funciona igual tengo que poner el bendito   http://192.168.1.1:8000  y despues los clientes tienen que poner
su username y password...mis ips todas son fijas..en services ----porta cautivo----Disable concurrent logins estaesta con check probe sin check y con check esta opcion mas Disable MAC filtering y se comporta igual tengo que agregar siempre a http://192.168.1.1:8000  y no es automatico ya que si hago click en www.google.com no carga nada!!!, no se porqui
pasa eso..alguien podria ayudarme porfavor???...no manejo nada de DHCP, todos mis clientes ya estan con 192.168.1.x y cambiarlos seruia un problema..graciuas...de antemano
a todos..



Offline sanchezluys

  • Sr. Member
  • ****
  • Posts: 548
  • Karma: +0/-0
    • View Profile
    • http://www.adrianamoda.lgg.com.ve
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #7 on: September 29, 2009, 06:45:24 am »
http://forum.pfsense.org/index.php/topic,19351.0.html

ya revisaste lo expuesto en ese post??

o cambia <form method="post" action="http://192.168.1.1:8000/">

por: <form method="post" action="http://192.168.1.1:8000/index.php">
« Last Edit: September 29, 2009, 08:54:27 am by sanchezluys »
** Soporte Via Correo en Venezuela **
*- diseño y puesta en marcha del portal cautivo, eliminacion de p2p, control de acceso de usuarios, instalacion y configuracion basica del pfsense, OpenVpn -* Equipos con S.O. PC-BSD, OpenBSD, Linux, Win y OpenSolaris sobre x86
www.lgg.com.ve  www.adrianamoda.lgg.com.ve

Offline pzanitti

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #8 on: September 29, 2009, 12:28:23 pm »
http://forum.pfsense.org/index.php/topic,19351.0.html

ya revisaste lo expuesto en ese post??

o cambia <form method="post" action="http://192.168.1.1:8000/">

por: <form method="post" action="http://192.168.1.1:8000/index.php">

No te encierres en un problema de HTML.

Esto me suele suceder cuando alguna cuenta caduca, entonces www.google.com necesita apuntar a 192.168.1.1:8000, y hay que refrescar el caché. Apretando Ctrl+F5 cuando no carga arregla el problema.

Offline hmeperu

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #9 on: September 29, 2009, 01:37:30 pm »
Cuando una cuenta caduca?????????? yo no pongo nada de fecha de caducidad, no uso eso. El problema se presenta cuando apago el pfsense para hacerle un mantenimiento fisico a la pc o cuando se va la luz
y cuando reinicia entonces las pcs clientes siempre tienen que poner http://192.168.1.1:8000  para que puedan otra vez ingresar a sus cuentas y hacer uso del internet. pero se supone que eso debe ser automatico, solo estoy usando el pfsense para bloquear algunos puertos standares de p2p y optimizar el voip. Pero eso de apretar Ctrl+F5??? no he probado ni se me ocurrio, no creo que pase nada
pero bueno de todas formas lo probare y vere que pasa, tambien probare eso del DNS del puerto 53, algo asi..

Offline pzanitti

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #10 on: September 29, 2009, 02:32:51 pm »
Ctrl+F5 refresca la página sin tener en cuenta el caché (como F5 normalmente haría).

Tu problema es que necesitás que www.google primero apunte a 192.168.1.1, y si el usuario logra autenticarse, que apunte a 64.233.163.99. Una vez que el usuario se desloguee del portal cautivo (en caso de un reinicio en tu caso, o de que una cuenta caduque en el mio) necesitas que el navegador sepa que tiene que volver a apuntar a 192.168.1.1.

Offline hmeperu

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #11 on: October 01, 2009, 01:15:47 pm »
Hola a todos ya puse todo esto  y nada no funciona!!,agregue tambien el DNS y nada...tengo que poner siempre el bendido http://192.168.1.1:8000... y ahi recien sale el portal cautivo, probe con html que viene por defecto en el portal cautivo pensando que esta mal mi HTML pero igual nada..
no entiendo eso de como hacer que mi server apunte??..porfavor amigo explicamelo como se hace
es algun codigo HTML???..gracias de antemano.

no funciona ni asi  por: <form method="post" action="http://192.168.1.1:8000/index.php">
ni tampoco asi        por: <form method="post" action="http://192.168.1.1:8000">

ni tampoco lo del DNS (53)...no se que estaria pasando??..alguna idea amigos??

Offline bellera

  • Moderator
  • Hero Member
  • *****
  • Posts: 4458
  • Karma: +0/-0
    • LinkedIn
    • View Profile
    • Josep Pujadas i Jubany
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #12 on: October 01, 2009, 01:39:05 pm »
¡Hola!

La regla que añades en LAN no sirve para nada ya que la primera incluye todo.

Saludos,

Josep Pujadas

Offline hmeperu

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #13 on: October 01, 2009, 04:29:59 pm »
Hola...osea tengo que borrar el que dice source  LAN Net???y solo dejo el TCP/UDP???

Offline bellera

  • Moderator
  • Hero Member
  • *****
  • Posts: 4458
  • Karma: +0/-0
    • LinkedIn
    • View Profile
    • Josep Pujadas i Jubany
Re: automaticamente a portal cautivo http://192.168.1.1:8000
« Reply #14 on: October 02, 2009, 12:23:58 am »
¡Hola de nuevo!

No, al revés. Tienes que dejar la "default" a menos que quieras restringir cosas. Y con la de resolución DNS no tienes suficiente.

http://www.bellera.cat/josep/pfsense/regles_cs.html

Otra cuestión es qué está pasando con el portal cautivo ... que no se dispara ...

http://www.bellera.cat/josep/pfsense/portal_cs.html

Saludos,

Josep Pujadas