pfSense Gold Subscription

Author Topic: Wrong PHP binary in livecd_installer > pfSense-2.0-ALPHA-ALPHA-20091010-0541  (Read 1532 times)

0 Members and 1 Guest are viewing this topic.

zyco321

  • Guest
hi there,

the webinterface isn´t working because you´ve put in the wrong php binary. it should be php cgi-fcgi and not the cli binary. after copying the binary from pfSense-2.0-ALPHA-ALPHA-20090927-2209 lighttpd started.

Offline _igor_

  • Hero Member
  • *****
  • Posts: 602
  • Karma: +0/-0
    • View Profile
where can I find that file? On the old iso? Didn't see anything like this.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14998
  • Karma: +4/-0
    • View Profile
This should be fixed in builds from today, I believe.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline _igor_

  • Hero Member
  • *****
  • Posts: 602
  • Karma: +0/-0
    • View Profile
Which file and where is this file? I have at the moment a non-working firewall and want to know it. I have another install with the pfsense from 09.27. Thanks much for helping

I don't want to downgrade and upgrade completely again. On this way maybe other things may fail.
« Last Edit: October 14, 2009, 03:09:44 am by _igor_ »

zyco321

  • Guest
i don´t know if already fixed with a newer build. you can find the php binary under /usr/local/bin, just copy the file "php" from the 0927 installation to your broken one and start lighttpd or restart your pc/whatever.

/edit: even the latest build has the wrong binary included
« Last Edit: October 14, 2009, 02:15:40 pm by zyco321 »

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14998
  • Karma: +4/-0
    • View Profile
Today's snapshot works. You can do a console URL update to upgrade and it should be operational again.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!