Netgate m1n1wall

Author Topic: redirect  (Read 3313 times)

0 Members and 1 Guest are viewing this topic.

Offline mpurins

  • Newbie
  • *
  • Posts: 2
    • View Profile
redirect
« on: December 01, 2005, 06:05:50 am »
Hello
I have a problem with URL redirection to my Portal page (http://mycaptiveportal:8000) after session timeout (radius auth). There is no alert about session timeout, thats why users are in trouble, when all internet stops and they cant browse internet.

Is there some solutions or some workaround?
Thanks

Offline sullrich

  • Hero Member
  • *****
  • Posts: 5110
    • View Profile
    • pfSense
Re: redirect
« Reply #1 on: December 01, 2005, 12:14:02 pm »
Hello
I have a problem with URL redirection to my Portal page (http://mycaptiveportal:8000) after session timeout (radius auth). There is no alert about session timeout, thats why users are in trouble, when all internet stops and they cant browse internet.

Is there some solutions or some workaround?
Thanks

Do you have the popup enabled? 

Offline mpurins

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: redirect
« Reply #2 on: December 02, 2005, 02:53:24 am »
yes.

Offline jeroen234

  • Sr. Member
  • ****
  • Posts: 505
    • View Profile
Re: redirect
« Reply #3 on: January 06, 2006, 06:28:47 am »
most browsers block the popups

Offline sullrich

  • Hero Member
  • *****
  • Posts: 5110
    • View Profile
    • pfSense
Re: redirect
« Reply #4 on: January 06, 2006, 09:52:11 am »
m0n0wall 1.21's captive portal has been merged into beta2.

Offline Gertjan

  • Sr. Member
  • ****
  • Posts: 337
    • View Profile
Re: redirect
« Reply #5 on: February 19, 2006, 08:15:07 am »
most browsers block the popups

Why not explaining on your main Portal web page that users should/could use IE->Utils->Blocking popup windows->Parameters to block publicity-> [add the opt1 IP : i.e. 192.168.2.1] so they would receive a 'disconnect' windows, from pFsense only.

By the way, pFSense & FreeRadius (a windows server process) rocks..... But don't look for time limited features in it - it isn't any great use if prepaid functionality is needed.
« Last Edit: February 19, 2006, 08:18:31 am by Gertjan »

Offline jeroen234

  • Sr. Member
  • ****
  • Posts: 505
    • View Profile
Re: redirect
« Reply #6 on: February 19, 2006, 08:51:03 am »
most browsers block the popups

Why not explaining on your main Portal web page that users should/could use IE->Utils->Blocking popup windows->Parameters to block publicity-> [add the opt1 IP : i.e. 192.168.2.1] so they would receive a 'disconnect' windows, from pFsense only.


there are more browsers then just that crapy thing microsoft delivers
this way you have to explan it 15 or more times for all the browers

Offline hoba

  • Administrator
  • Hero Member
  • *****
  • Posts: 5837
  • What was the problem to this solution again?
    • View Profile
    • pfSense
Re: redirect
« Reply #7 on: February 19, 2006, 10:13:42 am »
most browsers block the popups

Why not explaining on your main Portal web page that users should/could use IE->Utils->Blocking popup windows->Parameters to block publicity-> [add the opt1 IP : i.e. 192.168.2.1] so they would receive a 'disconnect' windows, from pFsense only.


That wouldn't work, as depending on which page the user tried to access the captive portal popup page appears to be from that side and not the pfSense. Try going to google.com when not authenticated. you would have to allow popups from google. next time you hit it by going to myfavouritesite.org and you would have to enable popups from that site...doesn't work. I would rather like to see a single line small frame at the top of the next page after authentication to give the user the possibility to click "open logout popup" along with a note as most browsers allow the popup when the user clicked on it.