The pfSense Store

Author Topic: [Solved] unable to connect to OPT1 ftp server from LAN  (Read 1483 times)

0 Members and 1 Guest are viewing this topic.

Offline sdeplo

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
[Solved] unable to connect to OPT1 ftp server from LAN
« on: June 30, 2010, 03:45:17 am »
Hello,

I'm in this config: WAN/LAN/OPT1. A FTP server in passive mode is behind opt1.
NAT rules works great and everything works fine for external IP's but not from LAN computers.

I enable the TFTP proxy on LAN and trying to connect to the ftp internal ip.
I get  "227 Entering Passive Mode" with the exteran ip so he can't connect...
It was working on 1.2.3 because the ftp proxy helper return internal ip in passive mode.

And i can't connect from LAN using external ip I get "connection to 123.123.123.123....."
and nothing append.

Is it a bug or i have another NAT rule to create? Can you help me?

Kind regards,


« Last Edit: July 01, 2010, 08:29:03 am by sdeplo »

Offline sdeplo

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: unable to connect to OPT1 ftp server from LAN
« Reply #1 on: July 01, 2010, 08:14:01 am »
HI,

i just create a NAT rule:

If   Proto   Src. addr   Src. ports   Dest. addr                   Dest. ports               NAT IP          NAT Ports   Description
LAN   TCP          *          *   123.123.123.123(ext ip)       21 (FTP)           192.168.1.2    21 (FTP)      FTP


and it works fine now.

Is my NAT seems correct for my configuration?

Thanks,