Netgate m1n1wall

Author Topic: Problem with reboot on fit-pc2i  (Read 5972 times)

0 Members and 1 Guest are viewing this topic.

Offline vho

  • Newbie
  • *
  • Posts: 5
    • View Profile
Problem with reboot on fit-pc2i
« on: January 13, 2011, 05:14:03 am »
Updated my fit-pc2i 2.0-beta4 with the latest snapshot (pfSense-Full-Update-2.0-beta5-i386-1430.tgz 12-Jan-2011 18:42).

When I request an reboot via the GUI or from the shell (shutdown -r now or from the menu) the machine hangs and I need to remove the power. Have the same problem after a Firmware upgrade then pfSense doesn't reboot automatically.

« Last Edit: January 17, 2011, 12:30:36 pm by vho »

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14931
    • View Profile
Re: Problem with reboot
« Reply #1 on: January 17, 2011, 09:24:45 am »
Can you try to do this:

Code: [Select]
sysctl hw.acpi.handle_reboot=1
From Diagnostics > Command or from a shell prompt.

Then try to issue a reboot from the GUI and see if it happens.

Some odd BIOS implementations require a different way of handling a reboot. If that works you can add this to /boot/loader.conf.local

Code: [Select]
hw.acpi.handle_reboot="1"
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline vho

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Problem with reboot
« Reply #2 on: January 17, 2011, 11:02:10 am »
Hey! Thanks for the proposal but unfortunately it still does not reboot.

Tested on 2.0-BETA5 (i386) built on Sun Jan 16 22:00:36 EST 2011

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14931
    • View Profile
Re: Problem with reboot
« Reply #3 on: January 17, 2011, 12:10:18 pm »
It was worth a shot I guess. You may want to change the title of the thread to mention fit pc2, there are others on the forum who have those boxes and they may have some suggestions.

My only other advice may be to try updating the BIOS or look through the BIOS for any ACPI options you might be able to flip and test.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline vho

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #4 on: January 17, 2011, 12:40:27 pm »
Thanks, I will continue to test and see if any bios setting to solve the problem.

Offline jojje

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #5 on: January 23, 2011, 06:28:10 am »
Is there some trace setting which can be enabled to help capture the information you need in order to identify the cause of this problem?
I've got this hardware model too and also experience the described problem. Would be nice to have the issue not be part of the final release..

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14931
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #6 on: January 23, 2011, 09:36:35 am »
Is there some trace setting which can be enabled to help capture the information you need in order to identify the cause of this problem?
I've got this hardware model too and also experience the described problem. Would be nice to have the issue not be part of the final release..

Not really. The shutdown/reboot signals are typically handled via ACPI or other similar calls so it really depends a lot on the BIOS of the system involved. If it doesn't work, the only real tweak is the sysctl I mentioned earlier.

You could try a stock FreeBSD 8.1-RELEASE install and see if it can shutdown/reboot OK. I suspect it won't, but you might find more hits around the web with freebsd fit-pc reboot with more suggestions.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline mark80

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #7 on: January 29, 2011, 07:15:00 am »
Nice to hear that I'm not alone on this issue.
Before I installed pfsense on this machine, I used ubuntu and had exactly the same scenario as well.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/392673

This was rectified quite quickly and after it worked a regular "reboot" just fine with Ubuntu.

I was just like you tried to change the ACPI settings of the bios, also tried updating to a newer version of bios, but it does not work in Pfsense, nor in a stock install of FreeBSD 8.1.

The machine shuts down normally when I use "shutdown-p now", it is only
rebooting that does not work. The machine hang after the normal shutdown
sequence after the message "cpu_reset: stopping Other CPUs". I have to hold
the power button for 5-6 seconds to turn it off, and then turn it on again.

The details of the hardware here:
http://www.compulab.co.il/fitpc2i/html/fitpc2i-sb-datasheet.htm

I really hope this can be corrected before pfsense 2.0 release!
Would be unfortunate to not be able to restart the server from work, without having to be present to restart it manually every time.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14931
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #8 on: January 29, 2011, 09:18:33 am »
I was just like you tried to change the ACPI settings of the bios, also tried updating to a newer version of bios, but it does not work in Pfsense, nor in a stock install of FreeBSD 8.1.

If it doesn't work on FreeBSD, there may not be anything we can do about it. If you can replicate it on FreeBSD 8.1 (really you should try 8.2 also) you can open a PR with them and see if they can come up with a fix.

http://doc.pfsense.org/index.php/Policy_on_FreeBSD_issues
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline TooMeeK

  • Full Member
  • ***
  • Posts: 124
    • View Profile
Re: Problem with reboot
« Reply #9 on: May 05, 2011, 11:39:48 am »
Can you try to do this:
Code: [Select]
sysctl hw.acpi.handle_reboot=1

You just solved my issue with the latest snapshot! (2.0-RC1 (i386) built on Thu May 5 06:05:22 EDT 2011)
It hangs after message "Rebooting..." but executing this in commmand prompt solved this.
I use KVM for VM emulation.

UPDATE: uuups, seems still doesn't work :(

UPDATE2:
It doesn't work becouse adding this to (new created) file /boot/loader.conf.local doesn't work
same when I add this to /boot/loader.conf
just take a look - have to add manually (screenshot)

UPDATE3:
still hanging on "Rebooting...", even with Executed command and handle reboot enabled.

UPDATE4:
added to /etc/sysctl.conf

SOLVED: Guess what? The problem was I was using QEMU domain type instead of KVM! Checked this on different server (I'm using AMD Phenom while different server has Core i5 and has no problem). Simple change in XML of VM and problem solved.
« Last Edit: May 05, 2011, 01:14:55 pm by TooMeeK »

Offline mrzaz

  • Full Member
  • ***
  • Posts: 124
  • Beta Errors Eradicate Roguecode or BEER for short.
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #10 on: June 06, 2011, 05:49:30 pm »
Could jimp, mark80 and vho check with the LATEST build if it works on the fit-pc2i ?

I'm about to order the fit-pc2i but don't want to run into these issues and It would be nice to know if it works now or not.
Would be very thankful if you could test and report back.

//Dan

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14931
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #11 on: June 06, 2011, 06:15:59 pm »
I do not have a fit-pc2i to test, so I can't help there. Someone else from the thread may be able to answer you.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline kb0

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #12 on: June 10, 2011, 12:53:05 pm »
I just received a fit-pc2i yesterday and loaded the latest nightly (june 9th). I cannot successfully reboot and setting hw.acpi.handle_reboot=1 does not resolve the problem. Would really like to get this fixed and am willing to tinker. Any suggestions?

Offline fatsailor

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #13 on: June 24, 2011, 10:09:49 pm »
Ditto here....the machines arrived today and hangs on the reboot with RC3.

The bios on my boxes (Sep 10) is not the most recent (Apr 10) which is annoying. I'll upgrade the BIOS tomorrow and retry, but I suspect no joy. At which point, I'll install 8.2 and see what I can do....but I suspect a custom kernel patch will be needed.

An interesting side note is that Linux had this same problem with the boards. Sadly, the fix was adding a command line (reboot=b) to grub.

Offline fatsailor

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Problem with reboot on fit-pc2i
« Reply #14 on: June 25, 2011, 04:57:27 pm »
I loaded up FreeBSD 8.2 Stable 201105 and it fixes the reboot problem. I'll see about putting together a custom RC3 based on 8.2 Stable.