pfSense Gold Subscription

Author Topic: DNS forwarder doesn't work after upgraded to Jan 20 snapshot  (Read 705 times)

0 Members and 1 Guest are viewing this topic.

Offline rlai000

  • Jr. Member
  • **
  • Posts: 66
  • Karma: +0/-0
    • View Profile
DNS forwarder doesn't work after upgraded to Jan 20 snapshot
« on: January 20, 2011, 02:07:38 pm »
I've set a domain on DNS forwarder to a VPN linked DNS server.  After the upgrade (Jan 20), I cannot resolve the domain anymore.  The VPN link is working though.  It seems other functions are working too.

I need to manually revered back to earlier snapshot (Jan 1).  But it said the config file is for newer version.  I restored my backup and it's working as expected.  I assume Jan 20 has a newer config file structure that make my DNS forwarder not working.

-Raylund

Offline rlai000

  • Jr. Member
  • **
  • Posts: 66
  • Karma: +0/-0
    • View Profile
Re: DNS forwarder doesn't work after upgraded to Jan 20 snapshot
« Reply #1 on: January 20, 2011, 11:37:47 pm »
I found the problem.  It's the route/gateway of VPN didn't work.

As pfsense cannot accessing the server in the other side of the VPN, I need to create a gateway with the same IP as the LAN interface on LAN interface.  And than set a route to the subnet of other side of the VPN via this gateway.

In the new snapshots, the gateway/routing is missing.  That's why I cannot resolve the domain which is queried by the server in the other side of the VPN.

-Raylund

Offline ermal

  • Administrator
  • Hero Member
  • *****
  • Posts: 3364
  • Karma: +2/-0
    • View Profile
Re: DNS forwarder doesn't work after upgraded to Jan 20 snapshot
« Reply #2 on: January 21, 2011, 02:25:29 am »