Netgate SG-1000 microFirewall

Author Topic: Unable to attach hardware  (Read 1617 times)

0 Members and 1 Guest are viewing this topic.

Offline eduard879

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Unable to attach hardware
« on: March 09, 2011, 05:06:49 am »
I am getting ath0: Unable to attach hardware after installing a Netgear WPN311 into my pfSense box.  I realize that is is not on the approved/tested Hardware list, but I also read that m0n0wall supports the Wireless G Cards on the new FreeBSD 6.x.  Isn't the current pfSense version on FreeBSD 6.x?  Also, is there a way for me to force ath0 drivers onto the WPN311?  If not, does anyone know when this Wireless PCI Card might be supported in the future?



  • Guest
Re: Unable to attach hardware
« Reply #1 on: March 09, 2011, 05:37:07 am »
FreeBSD 6 is ancient.  The current release of FreeBSD is 8.2.  pfSense 2.0 is built on top of FreeBSD 8.1. 
All that said, use hardware which is currently supported.

Offline stephenw10

  • Administrator
  • Hero Member
  • *****
  • Posts: 12147
  • Karma: +485/-15
    • View Profile
Re: Unable to attach hardware
« Reply #2 on: March 09, 2011, 06:18:49 am »
That card is based on the Atheros AR5004G yes?
I'm surprised it isn't supported already but a quick search doesn't show many people using it with FreeBSD. It's quite an old chipset and to be honest if it's not supported already it isn't going to be a priority.


Edit: A search on this forum shows quite a few people successfully using this card, or at least cards based on the same chipset. (if it is ar5004g)
« Last Edit: March 09, 2011, 06:25:49 am by stephenw10 »