The pfSense Store

Author Topic: NanoBSD w/ DB44/4*DB9 adapter ?  (Read 1555 times)

0 Members and 1 Guest are viewing this topic.

Offline XZed

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
NanoBSD w/ DB44/4*DB9 adapter ?
« on: March 25, 2011, 04:16:50 am »
Hello,

Until now, i installed a lot of pfSense boxes w/ pleasure :)...

All w/ full install way.

I want to setup, for the first time, an embedded one.

I wrote nanobsd image to CF and, as documented, at a certain step, output is redirected to serial port.

Unfortunately, i don't manage to access this serial output.

But, i think/suggest that it's due to the specific part of my setup.

Let me present it :

It's a Nexcom NISE-3100 box : http://www.jmsindustrial.nl/bestanden/OVERIG/NISE3100.pdf

As you can see, it features 4 serial ports via a DB44 connector/adapter.

I tried all 4 ports w/ different settings (Putty and others clients) : i never managed to access it.

In the BIOS, i haven't any serial redirection option or something similar (meanwhile, i can setup the various ways serial ports can use : RS232, etc...).

By the way, i installed pfHacom release in order to have VGA output and to see how pfSense considers these serial ports via DB44 connector.

I'm not currently connected to it but i remember have seen 4 "sio" (Serial I/O i suppose) ports detected.

Well, i already used serial outputs on switches and other embedded materials. But i never tried to use such a feature on a "standard computer" and i'm even asking to myself if it's possible without "special bios features"...

So i don't know if my problem resides on specific DB44 connector or on the fact i'm trying to use serial redirection on standard computer.

Finally, just to know : are Hacom releases "validated" by pfSense ? I mean : i'd like to have peace-of-mind on security concerns :) ...

http://www.hacom.net/kb/pfsense-2-rc1

Thank you very much,

Sincerely,

XZed

Online stephenw10

  • Hero Member
  • *****
  • Posts: 8127
    • View Profile
Re: NanoBSD w/ DB44/4*DB9 adapter ?
« Reply #1 on: March 25, 2011, 06:34:51 am »
I think you need to confirm that pfSense is correctly detecting and setting up the serial ports from the Hacom boot log. Post your results here.

Also you need to confirm that you have correctly connected to the serial port. Have you seen anything on the serial connection under any OS? What sort of cable are you using?

Steve

Edit: It's hard to say for sure whether the connectors on the DB44 to 4X DB9 cable are straight or crossed. It looks from the what documentation I can find on the Nexcom site as though they are standard com port pinout and would therefore require a null modem (cross over) cable of the type you would use with a switch. However I have used a number of multi-com port cards that have crossed output and require a straight through cable.
« Last Edit: March 25, 2011, 11:31:01 am by stephenw10 »

Offline XZed

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
Re: NanoBSD w/ DB44/4*DB9 adapter ?
« Reply #2 on: March 25, 2011, 11:26:24 am »
Hello,

Thank you for your detailed answer !

While reading your post, i thought about an important detail that i forgot to mention :

While i wanted to use a null modem cable, some things prevented me to do it :

- no serial port integrated on my mobo
- no serial port pci card
- consequently, i used a USB/DB9 cable
- a DB9 F/F cable but can't prove it's crosslinked


Well,after writing it, i admit that a lot of problems can appear with such tricks... all of this added to the fact that the other side has a DB44/DB9 adapter...

Obvisouly i was conscious that the first thing to do is : start from scratch the setup with the simpliest setup : serial card / (verified) null modem cable.

But, not having these items for the moment, i gave it a try :) ...

For the logs : once i got it, i post it.

Indeed, i thought about setting up any "normal" OS to see how serial ports look like, but hadn't yet the time.

I'll try to make all the tests this week-end.

Thank you very much for your help.





Offline XZed

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
Re: NanoBSD w/ DB44/4*DB9 adapter ?
« Reply #3 on: March 26, 2011, 08:24:29 pm »
For the logs, 2 versions :

one w/ the original configuration, another w/ only the first serial port enabled

Now, w/ pfSense v2, "sio" ports were renamed "uart"

pfHacom boot logs

Still haven't bought serial port pci cards + null modem cable but, one friend gave me still his "usual packge used to configure various branded routers" : still a USB/DB9 cable + a DB9 cable (which i suppose null modem).

Still the same problem : Putty (or any other terminal client) keeps blinking on the upper left corner but w/o any interaction possible...

Thank you
« Last Edit: March 26, 2011, 08:32:37 pm by XZed »