Netgate SG-1000 microFirewall

Author Topic: LIS driver for LCDPROC in Pfsense 1.2.3 OR 2.0  (Read 1443 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
LIS driver for LCDPROC in Pfsense 1.2.3 OR 2.0
« on: June 30, 2011, 09:19:13 am »
Hey everyone,

I just recently bought a 2x20 USB LCD display and would like to use it on my PFSense box with LCDProc. PFSense 1.2.3 doesn't include the driver I need (the LIS driver), and I just installed 2.0 RC3 in a VM and it also appears to lack the driver I need. This driver should be included in the latest release of LCDProc.

I have very little experience with Linux / BSD. Can anyone help me get this working? I probably should've just ordered an LCD that was known to work with PFSense, but this is what Newegg had in stock.

Thanks in advance!


  • Guest
Re: LIS driver for LCDPROC in Pfsense 1.2.3 OR 2.0
« Reply #1 on: July 03, 2011, 04:09:21 pm »
Alright so I did a bit more testing.

the pfsense lcdproc package doesn't include the driver i need,

So I uninstalled it, and manually installed the latest freebsd pkg from

to my dismay, this also didn't include the driver (even though it should according to lcdproc's documentation)

I did some more reading and it looks like the LIS driver needs libftdi to function properly, so I installed that from

I uninstalled and reinstalled the lcdproc freebsd pkg, and still no joy.

it seems like just about nobody has tried to use this driver on freebsd/pfsense/monowall/freenas

I did find an article on using this in MYTHTV:

it *looks* like I might be able to get this running if i install from source (that way I can tell it which drivers to install, and force the LIS driver)
but this is where im completely out of my element.

Can someone please get me moving in that direction? I'd really appreciate it.

My eyes are bleeding at this point. too much reading.

The other thing that comes to mind - this is a driver that should be included in the pfsense package, but isn't. So perhaps there's some technical reason that this simply won't work on freeBSD/Pfsense?