pfSense Gold Subscription

Author Topic: Router Advertisement Option doesn't take  (Read 1161 times)

0 Members and 1 Guest are viewing this topic.

Offline tfull99

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Router Advertisement Option doesn't take
« on: November 29, 2011, 10:41:10 am »
I'm running

2.1-DEVELOPMENT (i386)
built on Tue Sep 13 17:28:43 EDT 2011
FreeBSD 8.1-RELEASE-p4

and did a gitsync this morning.  No matter what I set the Router Advertisement to on the DHCPv6 Server page for my LAN, the raflags for my lan interface appears to get set as 'MO'.  I'm using the ISC DHCPv6 server and want to disable this.  I've set the option to 'disable', but still see the advertisements being sent.  Sure enough, in the /var/etc/rtadvd.conf I still see the raflags for the lan interface set to 'MO'.  I'm manually modified the file and that seems to stop the advertisements, but if I do a gitsync, or modify the service, or just reboot the firewall, it always gets set back to 'MO' again.  Am I doing something wrong?

Thanks,

Tim
« Last Edit: November 29, 2011, 10:46:45 am by tfull99 »

Offline tfull99

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Router Advertisement Option doesn't take
« Reply #1 on: November 29, 2011, 02:48:35 pm »
I found something related I think.  If I have the 'Enable DHCPv6 server on LAN interface' box unchecked, the 'MO'  keeps getting applied, regardless of the Router Advertisement setting.  Once I checked the Enable box, then set the RA to disabled, the RAFLAG was set to zero.  Unfortunately, I don't want the box checked, so when I unchecked it, the 'MO' came back, even though it had the RA still set to disabled.

Tim

Offline databeestje

  • Administrator
  • Hero Member
  • *****
  • Posts: 1048
  • Karma: +0/-0
  • It just might be your luck day, if you only knew.
    • View Profile
Re: Router Advertisement Option doesn't take
« Reply #2 on: November 29, 2011, 04:08:06 pm »
must have the bits set wrong, I'll look into it.