The pfSense Store

Author Topic: NAT will nicht wirklich ?  (Read 2385 times)

0 Members and 1 Guest are viewing this topic.

Offline tobsen

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
NAT will nicht wirklich ?
« on: January 05, 2006, 04:06:56 am »
Hallo Leute :-)

ich habe ein seltsames NAT Problem und komme einfach nicht weiter.
Ich benutze die  Version BETA 1.0  auf meinem WRAP und möchte meinen internen Server per FTP und SSH erreichen können.
Also hab ich beispielsweise SSH im NAT per Portforwarding auf meinen Internen Server gelegt

WAN Interface -> Proto TCP -> Port 22 -> NAT IP 192.168.192.4 -> Port 22

In der Firewall gibt es auf dem WAN Interface eine PASS Regel

WAN Interface -> Proto TCP -> Source  * -> Port    22 (SSH) -> Destination 192.168.192.4 -> Port    22 (SSH)

es geht aber nicht. Wenn ich Daheim bin ( im LAN ) komme ich drauf und wenn ich per PPTP eingewählt bin auch.
Es muss aber auch mit dem redirect funzen. Ich hab keinen Plan mehr habt Ihr ne Idee ???

Offline hoba

  • Administrator
  • Hero Member
  • *****
  • Posts: 5837
  • Karma: +3/-0
  • What was the problem to this solution again?
    • View Profile
    • pfSense
Re: NAT will nicht wirklich ?
« Reply #1 on: January 05, 2006, 07:35:25 am »

WAN Interface -> Proto TCP -> Source  * -> Port    22 (SSH) -> Destination 192.168.192.4 -> Port    22 (SSH)

Der Sourceport von dem Dein Client kommt is zufällig. Ändere bei der Firewallregel Sourceport auf any und es geht. Warum hast Du die Regel nicht automatisch generieren lassen als Du den NAT Eintrag angelegt hast (die unterste Checkbox)?

Sourceports sind so gut wie IMMER zufällig. Das Feld sollte immer any sein (schau Dir mal Deine Firewallstates z.B. an unter Diagnostics>States). Es gibt nur wenige Programme oder Geräte (z.B.b VoiP-Phones), die mit statischen Sourceports arbeiten.

Offline tobsen

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: NAT will nicht wirklich ?
« Reply #2 on: January 05, 2006, 08:52:19 am »
danke für den Tip Hoba, das wars :-)

ich hatte auch Probleme mit der selberstellten Regel, aber das lag wohl eher an meinem zu viel geklicke ( Hab immer ftp und ssh gleichzeitig bearbeitet und war wohl einfach zu ungeduldig).

also ssh geht nun auf meinen Server, aber mit dem ftp muss ich wohl noch abwarten.

Gruß

hat sich erledigt
http://forum.pfsense.org/index.php?topic=409.0