pfSense English Support > Virtualization installations and techniques

pfsense 2.0 and Xenserver HowTo

(1/1)

tommyboy180:
Confirmed working on XenServer 5.6Sp2 and 6.0

At the boot menu choose option 7 "Escape to loader prompt"

--- Code: ---set hw.clflush_disable=1
boot
--- End code ---

Install pfSense.

After the installation, add the following line to /boot/loader.conf by running the following command from the shell prompt.

--- Code: ---echo "hw.clflush_disable=1" >> /boot/loader.conf
--- End code ---

All credit goes to wmlaros

marcelloc:
Great news. Thanks to wmlaros and you tommyboy180.
 :)

dscline:
Are these options required for all pfsense on Xenserver installations, or is this specific to AMD systems?  This page on installing pfsense on Hyper-v says to use these same options, claiming:

--- Quote ---Apparently FreeBSD 8 has a problem with AMD 64 processors which prevents them from booting in virtual environments. A workaround is to choose option 7 "Escape to loader prompt" ...
--- End quote ---

And it appears from this page that everyone that was having issues had an AMD system.

I'm completely new to pfsense and VMs, but I'm trying to dive in and figure it out.  I'm on an Intel system, so I'm just wondering if this is something I need to (or even should) do.

Thanks!

Navigation

[0] Message Index

Go to full version