The pfSense Store

Author Topic: Traffic graph causing logout of webGUI...  (Read 3644 times)

0 Members and 1 Guest are viewing this topic.

Offline Sup3rior

  • Jr. Member
  • **
  • Posts: 64
  • Karma: +0/-0
    • View Profile
Traffic graph causing logout of webGUI...
« on: October 18, 2011, 11:39:29 am »
Hi,

Having just introduced our first pfSense devices in production, I have stumbled upon a rather strange issue.

When I want to access the traffic graphs I am logged out of the webGUI (returned to login screen). Trying again to see the graphs I get logged out again.
I've instead added the graphs as a widget on the dashboard, where I have no problem seeing the WAN and LAN graphs but as soon as I expand the graph for the PFSYNC network I am once again logged out.
I therefore speculate that the PFSYNC network is the cause of this, but am at somewhat of a loss of what causes it.

We are running version 2.0-RELEASE for AMD64.

Hope someone has a suggestion.

Regards,
Anders

Offline stilez

  • Jr. Member
  • **
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #1 on: October 23, 2011, 10:38:27 pm »
Confirming - had same issue here. Fresh install of pfsense 2.0 on i386 (p4/Intel chipset) platform. But it seems browser-dependant, logs out pfsense when accessed via IE9 but not when accessed via Firefox 7 (Win7 client computer)
« Last Edit: October 23, 2011, 10:42:17 pm by stilez »

Offline Sup3rior

  • Jr. Member
  • **
  • Posts: 64
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #2 on: October 24, 2011, 03:23:13 am »
I'll give it a try with my Opera browser and see what happens :)

Offline stilez

  • Jr. Member
  • **
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #3 on: October 24, 2011, 06:41:32 am »
FWIW clean reinstall, new config, same result, browser dependent

Offline pf2.0nyc

  • Full Member
  • ***
  • Posts: 169
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #4 on: October 25, 2011, 10:49:20 am »
FWIW clean reinstall, new config, same result, browser dependent

+1, same issue on IE9, have not tried any other browser however.

Offline greybeard

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #5 on: October 30, 2011, 08:20:39 pm »
FWIW clean reinstall, new config, same result, browser dependent

+1, same issue on IE9, have not tried any other browser however.

+1 IE9, haven't tried other browsers
« Last Edit: October 30, 2011, 08:52:23 pm by greybeard »

Offline AwesomePilot

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #6 on: November 01, 2011, 10:03:17 pm »
Same here, on IE8, IE9 and Firefox.

PFS 2.0 AMD64

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14976
  • Karma: +4/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #7 on: November 02, 2011, 09:03:53 am »
Moral of the story, as always, don't use IE*. :-)

* If you want to use IE, patches fixing HTML/CSS/other issues are always accepted.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline greybeard

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #8 on: November 02, 2011, 05:43:47 pm »
In case anyone finds this thread when searching for SVG and IE9 problems, several people have now confirmed that they have an issue with the SVG support in IE9.
The current workaround is to apply one's morals to the choice of a browser and or to work on a patch.  ;D

Offline stilez

  • Jr. Member
  • **
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #9 on: November 02, 2011, 06:30:06 pm »
In case anyone finds this thread when searching for SVG and IE9 problems
It's more that it appears to cause an unexpected logout on the router.

Offline Sup3rior

  • Jr. Member
  • **
  • Posts: 64
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #10 on: November 21, 2011, 09:38:42 am »
Moral of the story, as always, don't use IE*. :-)

* If you want to use IE, patches fixing HTML/CSS/other issues are always accepted.

Why do I get the feeling you don't like IE? ;) :P

But if it's a general issue with IE, why does it only happen on the PFSYNC network and none of the others?

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14976
  • Karma: +4/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #11 on: November 21, 2011, 10:11:17 am »
Hard to say why, but if it doesn't happen in any other browser, it's still IE's interpretation of the code to blame.

If someone who knows IE and wants to debug it in more detail, we'd be happy to take in patches for that.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline stratagem

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Traffic graph causing logout of webGUI...
« Reply #12 on: December 03, 2011, 08:47:02 am »
On a clean install of pfSense 2.0-RELEASE amd64, the Traffic Graph page destroys the session as the SVG is loaded by IE9. The graph.php page/template renders, then the SVG (or javascript?) kills it. There is no issue with the dashboard traffic graph widget.

IE8 with no SVG plugin displays the page and an informative table - no logout.
« Last Edit: December 03, 2011, 08:48:39 am by stratagem »