pfSense Support Subscription

Author Topic: pfBlocker  (Read 183519 times)

0 Members and 1 Guest are viewing this topic.

Offline Quinn1981

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #60 on: November 03, 2011, 08:57:34 am »
Reinstalled after the max tables resize and it works a treat. Thanks! :)

Offline RonpfS

  • Full Member
  • ***
  • Posts: 129
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #61 on: November 03, 2011, 09:20:55 pm »
I am getting this from time to time: 404 - Not Found

Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9995
  • Karma: +3/-0
    • View Profile
Re: pfBlocker
« Reply #62 on: November 04, 2011, 05:56:28 am »
Can you paste the url that gets 404 error?

Offline RonpfS

  • Full Member
  • ***
  • Posts: 129
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #63 on: November 04, 2011, 10:52:35 am »
https://12.34.56.78/pkg_edit.php?xml=pfblocker.xml

this happened at the same time as snort was misbehaving ... I removed snort now

Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9995
  • Karma: +3/-0
    • View Profile
Re: pfBlocker
« Reply #64 on: November 04, 2011, 11:47:44 am »
the url is fine.

while using some packages, the menu url is prefixed with /packages/something/.
when you choose other url in menu, this prefix persists, and then a 404 error occur.

This is not a problem related to pfBlocker.



« Last Edit: November 04, 2011, 11:53:11 am by marcelloc »

Offline hubsd

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #65 on: November 04, 2011, 03:17:33 pm »
I discovered a new problem today, pfsense takes more than 1 minute to finish boot (9 minutes to be accurate !)
I noticed that it's blocked most on the time on "Configuring firewall" step.

Without plugin, no problem so...

There is also that usual "Warning message" in webgui after reboot in webgui (then need to "acknowledge all")

Setup is Alix 2c3 + pfsense nanobsd + compact flash 2 GB

Widget and lists :


RAM/CPU/TABLE usage


Packages used


log side, I have this messages (x10)

Quote
php: : New alert found: There were error(s) loading the rules: no IP address found for grep: /tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data no IP address found for grep: /tmp/rules.debug:20: file "/var/db/aliastables/pfBlockerInternetTrash.txt" contains bad data no IP address found for grep: /tmp/rules.debug:22: file "/var/db/aliastables/pfBlockerBlizzard.txt" contains bad data no IP address found for grep: /tmp/rules.debug:24: file "/var/db/aliastables/pfBlockeripfilterX.txt" contains bad data pfctl: Syntax error in config file: pf rules not loaded The line in question reads [ /tmp/rules.debug]:


php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'no IP address found for grep: /tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data no IP address found for grep: /tmp/rules.debug:20: file "/var/db/aliastables/pfBlockerInternetTrash.txt" contains bad data no IP address found for grep: /tmp/rules.debug:22: file "/var/db/aliastables/pfBlockerBlizzard.txt" contains bad data no IP address found for grep: /tmp/rules.debug:24: file "/var/db/aliastables/pfBlockeripfilterX.txt" contains bad data pfctl: Syntax error in config file: pf rules not loaded'



« Last Edit: November 04, 2011, 03:27:38 pm by hubsd »

Offline ghm

  • Jr. Member
  • **
  • Posts: 48
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #66 on: November 05, 2011, 08:20:15 am »
I discovered a new problem today, pfsense takes more than 1 minute to finish boot (9 minutes to be accurate !)

Setup is Alix 2c3 + pfsense nanobsd + compact flash 2 GB


Same here - massive issues on 2.0 embedded (Countryblock works apart from logging though). I see loads of:
Code: [Select]
Nov 4 14:14:29 php: : There were error(s) loading the rules: no IP address found for grep: /tmp/rules.debug:24: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data no IP address found for grep: /tmp/rules.debug:26: file "/var/db/aliastables/pfBlockerNorthAmerica.txt" contains bad data no IP address found for grep: /tmp/rules.debug:28: file "/var/db/aliastables/pfBlockerOceania.txt" contains bad data no IP address found for grep: /tmp/rules.debug:30: file "/var/db/aliastables/pfBlockerSouthAmerica.txt" contains bad data no IP address found for grep: /tmp/rules.debug:32: file "/var/db/aliastables/pfBlockerTopSpammers.txt" contains bad data pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [ /tmp/rules.debug]:
Nov 4 14:14:29 php: : New alert found: There were error(s) loading the rules: no IP address found for grep: /tmp/rules.debug:24: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data no IP address found for grep: /tmp/rules.debug:26: file "/var/db/aliastables/pfBlockerNorthAmerica.txt" contains bad data no IP address found for grep: /tmp/rules.debug:28: file "/var/db/aliastables/pfBlockerOceania.txt" contains bad data no IP address found for grep: /tmp/rules.debug:30: file "/var/db/aliastables/pfBlockerSouthAmerica.txt" contains bad data no IP address found for grep: /tmp/rules.debug:32: file "/var/db/aliastables/pfBlockerTopSpammers.txt" contains bad data pfctl: Syntax error in config file: pf rules not loaded The line in question reads [ /tmp/rules.debug]:
Nov 4 14:14:28 php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'no IP address found for grep: /tmp/rules.debug:24: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data no IP address found for grep: /tmp/rules.debug:26: file "/var/db/aliastables/pfBlockerNorthAmerica.txt" contains bad data no IP address found for grep: /tmp/rules.debug:28: file "/var/db/aliastables/pfBlockerOceania.txt" contains bad data no IP address found for grep: /tmp/rules.debug:30: file "/var/db/aliastables/pfBlockerSouthAmerica.txt" contains bad data no IP address found for grep: /tmp/rules.debug:32: file "/var/db/aliastables/pfBlockerTopSpammers.txt" contains bad data pfctl: Syntax error in config file: pf rules not loaded'

The firewall seems to be blocked then altogether. I guess there's an issue with rw mounting nanobsd...
Went back to Countryblock for the time being.
Featurewise pfBlocker seems great though!


Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9995
  • Karma: +3/-0
    • View Profile
Re: pfBlocker
« Reply #67 on: November 05, 2011, 09:16:18 am »
I found a fetch issue While booting and on url table pfblocker get file function. I'm fixing it today.

EDIT

version 0.1.4.1 released with fixes in:
  • boot process
  • embedded platform
  • url table get file package function

Many thanks for all of you that are helping us with this package.
« Last Edit: November 05, 2011, 10:46:53 am by marcelloc »

Offline Hugovsky

  • Full Member
  • ***
  • Posts: 128
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #68 on: November 05, 2011, 10:44:23 am »
Very nice package, indeed. No errors to report so far. pfsense 2.0 release amd64.

Offline hubsd

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #69 on: November 05, 2011, 02:40:57 pm »
ok, now it takes 3/4 minutes to finish boot (better than 9 minutes)

I still have those warning messages

Quote
There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

There were error(s) loading the rules: no IP address found for grep:
/tmp/rules.debug:18: file "/var/db/aliastables/pfBlockerEurope.txt" contains bad data
pfctl: Syntax error in config file: pf rules not loaded The line in question reads [
/tmp/rules.debug]:

Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9995
  • Karma: +3/-0
    • View Profile
Re: pfBlocker
« Reply #70 on: November 06, 2011, 06:46:56 am »
what version are you using?

I have no embedded hardware to test it, I'm looking a way to do this using virtualbox.


Offline hubsd

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #71 on: November 06, 2011, 07:24:21 am »
pfSense 2.0-RELEASE (i386) / nanobsd on Compact Flash 2 Gb
pfBlocker-dev 0.1.4.1


I have a 4 Gb microdrive somewhere, should I give it a try ?

Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9995
  • Karma: +3/-0
    • View Profile
Re: pfBlocker
« Reply #72 on: November 06, 2011, 08:55:13 am »
I' ve tested virtualbox + pfsense 2.0 amd64 embedded kernel with no issues.

I'm not sure if embedded kernel will work the same way nanobsd on Compact Flash 2 Gb will do.

I found some posts on forum saying that is not easy to run nanobsd img on virtualbox, but I'm still trying..


Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9995
  • Karma: +3/-0
    • View Profile
Re: pfBlocker
« Reply #73 on: November 06, 2011, 04:44:53 pm »
hubsd,

Second test, first problem:

I've changed /etc/platform to nanobsd.
after a reboot mount -a returns:
Code: [Select]
/dev/ad0s1a on / (ufs, local, noatime, read-only, synchronous)
devfs on /dev (devfs, local)
/dev/md0 on /tmp (ufs, local)
/dev/md1 on /var (ufs, local)

So, read-only file system.

installed and configured pfblocker with no issues.

after a reboot,
I got the same error:
Code: [Select]
php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'no IP address found for grep: /tmp/rules.debug:15: file "/var/db/aliastables/pfBlockerTopSpammers.txt" contains bad data pfctl: Syntax error in config file: pf rules not loaded'
php: : New alert found: There were error(s) loading the rules: no IP address found for grep: /tmp/rules.debug:15: file "/var/db/aliastables/pfBlockerTopSpammers.txt" contains bad data pfctl: Syntax error in config file: pf rules not loaded The line in question reads [ /tmp/rules.debug]:
php: : There were error(s) loading the rules: no IP address found for grep: /tmp/rules.debug:15: file "/var/db/aliastables/pfBlockerTopSpammers.txt" contains bad data pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [ /tmp/rules.debug]:


But, without saving any new config, I've looked at diagnostics-> table and pfBlockerTopSpammers was filled up normally, alias was there and firewall rules too.

So, Isn't it just a 'until boot finishes issue'?

Can you check if it happens the same way on your installation?

I know system alerts are annoying and have to be fixed but if package is still working, isn't it a minor issue?

Second problem:
boot takes 3 to 4 minutes.
it's a problem in fetch call that has no time out(or 01:15 timeout), I'll include a timeout patch to pfsense-tools.inc file on next release.
« Last Edit: November 06, 2011, 04:47:51 pm by marcelloc »

Offline hubsd

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +0/-0
    • View Profile
Re: pfBlocker
« Reply #74 on: November 06, 2011, 04:54:35 pm »
Quick update, i exported my nanobsd config and imported it in a microdrive + classic embedded installation (so no nanobsd)

I can confirm that I have zero issue now and boot time takes 2 minutes.

So the problems I noticed are only while using nanobsd.