The pfSense Store

Author Topic: Errors on Dell PowerEdge r510  (Read 3089 times)

0 Members and 1 Guest are viewing this topic.

Offline fredmatrack

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Errors on Dell PowerEdge r510
« on: November 19, 2011, 02:28:24 am »
Hi,

After upgrading Pfsense 1.2.3 to 2.0, we often get error messages:
Code: [Select]
Warning: exec(): Unable to fork [/sbin/pfctl -vvsI -i bce3] in /etc/inc/pfsense-utils.inc on line 1137
Code: [Select]
Warning: exec(): Unable to fork [/sbin/sysctl -n vm.stats.vm.v_page_count vm.stats.vm.v_inactive_count vm.stats.vm.v_cache_count vm.stats.vm.v_free_count] in /usr/local/www/includes/functions.inc.php on line 180 Warning: Division by zero in /usr/local/www/includes/functions.inc.php on

When I log in using SSH, I get this one:
Code: [Select]
*** Welcome to pfSense 2.0-RELEASE-pfSense (i386) on apollo ***

  LAN (lan)                 -> bce3       -> 192.168.1.254
  WAN (wan)                 -> bce0       -> xx.xx.xx.13 (DHCP)
Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65

  WANBACKUP (opt1)          -> bce1       -> NONE (DHCP)
Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65

  PEDAGOGISCH (opt2)        -> bce2       -> NONE
Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65

Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65

  ADMINISTRATIE (opt3)      -> bce4       -> NONE
Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65

  ABDIJSTRAAT (opt4)        -> bce5       -> 192.168.96.254
  TELEFOON (opt5)           -> bce6       -> 192.168.32.254 /etc/rc.initial: Cannot fork: Cannot allocate memory
Connection to 172.16.1.254 closed.

or this:

Code: [Select]
Cannot fork: Cannot allocate memory
[: -gt: unexpected operator
Cannot fork: Cannot allocate memory

I already modified the file /boot/loader.conf.local:
Code: [Select]
kern.ipc.nmbclusters="131072"
hw.bce.tso_enable=0
hw.pci.enable_msix=0

Any ideas what is happening and how to solve?
« Last Edit: November 20, 2011, 06:50:53 am by fredmatrack »

Offline fredmatrack

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #1 on: November 21, 2011, 02:10:16 am »
After a day (and a reboot):

Code: [Select]
Warning: exec(): Unable to fork [/usr/local/bin/beep.sh stop 2>&1] in /etc/inc/util.inc on line 853 Warning: exec(): Unable to fork [/etc/rc.stop_packages 2>&1] in /etc/inc/util.inc on line 853 Warning: exec(): Unable to fork [nohup /etc/rc.reboot > /dev/null 2>&1 & 2>&1] in /etc/inc/util.inc on line 853
Code: [Select]
Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65 Warning: shell_exec(): Unable to execute '/sbin/ifconfig -l' in /etc/inc/interfaces.inc on line 65

Offline fredmatrack

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #2 on: November 25, 2011, 09:01:34 am »
On the display of the server, I see this error:
vm_thread_new: kstack allocation failed

I hope somebody can find an answer for this problem. Now I have to reboot the server every day!

Offline heper

  • Hero Member
  • *****
  • Posts: 676
  • Karma: +0/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #3 on: December 03, 2011, 06:30:22 pm »
if it were me, i'd try to get a backup of the current config using the gui, clean install pfsense, import the config and see if that resolves it.

but, you could allways wait around till someone comes along with a more elegant solution ;)

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14994
  • Karma: +4/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #4 on: December 08, 2011, 10:11:09 am »
How much RAM is actually being detected (watch the boot logs or check dmesg)?

It looks like it's exhausing all your RAM and swap space which I would only expect to see if in situations where you only had maybe ~64MB of RAM or less actually getting used.

Could be a bad stick of RAM but that would usually fail in even more spectacular ways.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline fredmatrack

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #5 on: December 12, 2011, 06:07:08 am »
This is the output for dmesg:
Code: [Select]
$ dmesg
Copyright (c) 1992-2010 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.1-RELEASE-p4 #1: Tue Sep 13 17:28:11 EDT 2011
    root@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8 i386
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(R) CPU           E5504  @ 2.00GHz (2000.08-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x106a5  Family = 6  Model = 1a  Stepping = 5
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x9ce3bd<SSE3,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,DCA,SSE4.1,SSE4.2,POPCNT>
  AMD Features=0x28100000<NX,RDTSCP,LM>
  AMD Features2=0x1<LAHF>
  TSC: P-state invariant
real memory  = 4294967296 (4096 MB)
avail memory = 3127521280 (2982 MB)
ACPI APIC Table: <DELL   PE_SC3  >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)
 cpu0 (BSP): APIC ID: 16
 cpu1 (AP): APIC ID: 18
ioapic1: Changing APIC ID to 1
ioapic0 <Version 2.0> irqs 0-23 on motherboard
ioapic1 <Version 2.0> irqs 32-55 on motherboard
netisr_init: forcing maxthreads to 1 and bindthreads to 0 for device polling
wpi: You need to read the LICENSE file in /usr/share/doc/legal/intel_wpi/.
wpi: If you agree with the license, set legal.intel_wpi.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (wpi_fw, 0xc0988330, 0) error 1
ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (ipw_bss_fw, 0xc0789370, 0) error 1
ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (ipw_ibss_fw, 0xc0789410, 0) error 1
ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
module_register_init: MOD_LOAD (ipw_monitor_fw, 0xc07894b0, 0) error 1
wlan: mac acl policy registered
kbd1 at kbdmux0
cryptosoft0: <software crypto> on motherboard
padlock0: No ACE support.
acpi0: <DELL PE_SC3> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
bce0: <Broadcom NetXtreme II BCM5716 1000Base-T (C0)> mem 0xce000000-0xcfffffff irq 36 at device 0.0 on pci1
miibus0: <MII bus> on bce0
brgphy0: <BCM5709C 10/100/1000baseTX PHY> PHY 1 on miibus0
brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bce0: [ITHREAD]
bce0: ASIC (0x57092008); Rev (C0); Bus (PCIe x4, 2.5Gbps); B/C (5.0.6); Flags (MSI|MFW); MFW (NCSI 2.0.3)
bce1: <Broadcom NetXtreme II BCM5716 1000Base-T (C0)> mem 0xd0000000-0xd1ffffff irq 48 at device 0.1 on pci1
miibus1: <MII bus> on bce1
brgphy1: <BCM5709C 10/100/1000baseTX PHY> PHY 1 on miibus1
brgphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bce1: [ITHREAD]
bce1: ASIC (0x57092008); Rev (C0); Bus (PCIe x4, 2.5Gbps); B/C (5.0.6); Flags (MSI|MFW); MFW (NCSI 2.0.3)
pcib2: <ACPI PCI-PCI bridge> at device 3.0 on pci0
pci2: <ACPI PCI bus> on pcib2
mfi0: <Dell PERC 6> port 0xfc00-0xfcff mem 0xdf180000-0xdf1bffff,0xdf1c0000-0xdf1fffff irq 32 at device 0.0 on pci2
mfi0: Megaraid SAS driver Ver 3.00
mfi0: 4255 (376514919s/0x0020/info) - Shutdown command received from host
mfi0: 4256 (boot + 3s/0x0020/info) - Firmware initialization started (PCI ID 0060/1000/1f0c/1028)
mfi0: 4257 (boot + 3s/0x0020/info) - Firmware version 1.22.02-0612
mfi0: 4258 (boot + 3s/0x0020/info) - Firmware initialization started (PCI ID 0060/1000/1f0c/1028)
mfi0: 4259 (boot + 3s/0x0020/info) - Firmware version 1.22.02-0612
mfi0: 4260 (boot + 23s/0x0008/info) - Battery Present
mfi0: 4261 (boot + 23s/0x0020/info) - Controller hardware revision ID (0x0)
mfi0: 4262 (boot + 23s/0x0020/info) - Package version 6.2.0-0013
mfi0: 4263 (boot + 23s/0x0020/info) - Board Revision
mfi0: 4264 (boot + 37s/0x0002/info) - Inserted: PD 00(e0xff/s0)
mfi0: 4265 (boot + 37s/0x0002/info) - Inserted: PD 00(e0xff/s0) Info: enclPd=ffff, scsiType=0, portMap=00, sasAddr=1221000000000000,0000000000000000
mfi0: 4266 (boot + 37s/0x0002/info) - Inserted: PD 01(e0xff/s1)
mfi0: 4267 (boot + 37s/0x0002/info) - Inserted: PD 01(e0xff/s1) Info: enclPd=ffff, scsiType=0, portMap=01, sasAddr=1221000001000000,0000000000000000
mfi0: [ITHREAD]
pcib3: <ACPI PCI-PCI bridge> at device 7.0 on pci0
pci3: <ACPI PCI bus> on pcib3
bce2: <Broadcom NetXtreme II BCM5709 1000Base-T (C0)> mem 0xd2000000-0xd3ffffff irq 38 at device 0.0 on pci3
miibus2: <MII bus> on bce2
brgphy2: <BCM5709C 10/100/1000baseTX PHY> PHY 1 on miibus2
brgphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bce2: [ITHREAD]
bce2: ASIC (0x57092003); Rev (C0); Bus (PCIe x4, 2.5Gbps); B/C (5.0.6); Flags (MSI)
bce3: <Broadcom NetXtreme II BCM5709 1000Base-T (C0)> mem 0xd4000000-0xd5ffffff irq 45 at device 0.1 on pci3
miibus3: <MII bus> on bce3
brgphy3: <BCM5709C 10/100/1000baseTX PHY> PHY 1 on miibus3
brgphy3:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bce3: [ITHREAD]
bce3: ASIC (0x57092003); Rev (C0); Bus (PCIe x4, 2.5Gbps); B/C (5.0.6); Flags (MSI)
pcib4: <ACPI PCI-PCI bridge> at device 9.0 on pci0
pci4: <ACPI PCI bus> on pcib4
bce4: <Broadcom NetXtreme II BCM5709 1000Base-T (C0)> mem 0xd6000000-0xd7ffffff irq 40 at device 0.0 on pci4
miibus4: <MII bus> on bce4
brgphy4: <BCM5709C 10/100/1000baseTX PHY> PHY 1 on miibus4
brgphy4:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bce4: [ITHREAD]
bce4: ASIC (0x57092003); Rev (C0); Bus (PCIe x4, 2.5Gbps); B/C (5.0.6); Flags (MSI)
bce5: <Broadcom NetXtreme II BCM5709 1000Base-T (C0)> mem 0xd8000000-0xd9ffffff irq 50 at device 0.1 on pci4
miibus5: <MII bus> on bce5
brgphy5: <BCM5709C 10/100/1000baseTX PHY> PHY 1 on miibus5
brgphy5:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bce5: [ITHREAD]
bce5: ASIC (0x57092003); Rev (C0); Bus (PCIe x4, 2.5Gbps); B/C (5.0.6); Flags (MSI)
pcib5: <ACPI PCI-PCI bridge> at device 10.0 on pci0
pci5: <ACPI PCI bus> on pcib5
bce6: <Broadcom NetXtreme II BCM5709 1000Base-T (C0)> mem 0xda000000-0xdbffffff irq 41 at device 0.0 on pci5
miibus6: <MII bus> on bce6
brgphy6: <BCM5709C 10/100/1000baseTX PHY> PHY 1 on miibus6
brgphy6:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bce6: [ITHREAD]
bce6: ASIC (0x57092003); Rev (C0); Bus (PCIe x4, 2.5Gbps); B/C (5.0.6); Flags (MSI)
bce7: <Broadcom NetXtreme II BCM5709 1000Base-T (C0)> mem 0xdc000000-0xddffffff irq 39 at device 0.1 on pci5
miibus7: <MII bus> on bce7
brgphy7: <BCM5709C 10/100/1000baseTX PHY> PHY 1 on miibus7
brgphy7:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bce7: [ITHREAD]
bce7: ASIC (0x57092003); Rev (C0); Bus (PCIe x4, 2.5Gbps); B/C (5.0.6); Flags (MSI)
pci0: <base peripheral, interrupt controller> at device 20.0 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 20.1 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 20.2 (no driver attached)
uhci0: <Intel 82801JI (ICH10) USB controller USB-D> port 0xec40-0xec5f irq 17 at device 26.0 on pci0
uhci0: [ITHREAD]
usbus0: <Intel 82801JI (ICH10) USB controller USB-D> on uhci0
uhci1: <Intel 82801JI (ICH10) USB controller USB-E> port 0xec60-0xec7f irq 18 at device 26.1 on pci0
uhci1: [ITHREAD]
usbus1: <Intel 82801JI (ICH10) USB controller USB-E> on uhci1
ehci0: <Intel 82801JI (ICH10) USB 2.0 controller USB-B> mem 0xdf0ff800-0xdf0ffbff irq 19 at device 26.7 on pci0
ehci0: [ITHREAD]
usbus2: EHCI version 1.0
usbus2: <Intel 82801JI (ICH10) USB 2.0 controller USB-B> on ehci0
uhci2: <Intel 82801JI (ICH10) USB controller USB-A> port 0xec80-0xec9f irq 21 at device 29.0 on pci0
uhci2: [ITHREAD]
usbus3: <Intel 82801JI (ICH10) USB controller USB-A> on uhci2
uhci3: <Intel 82801JI (ICH10) USB controller USB-B> port 0xeca0-0xecbf irq 20 at device 29.1 on pci0
uhci3: [ITHREAD]
usbus4: <Intel 82801JI (ICH10) USB controller USB-B> on uhci3
uhci4: <Intel 82801JI (ICH10) USB controller USB-C> port 0xecc0-0xecdf irq 21 at device 29.2 on pci0
uhci4: [ITHREAD]
usbus5: <Intel 82801JI (ICH10) USB controller USB-C> on uhci4
uhci5: <Intel 82801JI (ICH10) USB controller USB-F> port 0xece0-0xecff irq 20 at device 29.3 on pci0
uhci5: [ITHREAD]
usbus6: <Intel 82801JI (ICH10) USB controller USB-F> on uhci5
ehci1: <Intel 82801JI (ICH10) USB 2.0 controller USB-A> mem 0xdf0ffc00-0xdf0fffff irq 21 at device 29.7 on pci0
ehci1: [ITHREAD]
usbus7: EHCI version 1.0
usbus7: <Intel 82801JI (ICH10) USB 2.0 controller USB-A> on ehci1
pcib6: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci6: <ACPI PCI bus> on pcib6
vgapci0: <VGA-compatible display> mem 0xcd800000-0xcdffffff,0xde7fc000-0xde7fffff,0xde800000-0xdeffffff irq 19 at device 3.0 on pci6
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH10 SATA300 controller> port 0xe8e0-0xe8e7,0xe8d0-0xe8d3,0xe8e8-0xe8ef,0xe8d4-0xe8d7,0xec00-0xec0f,0xec10-0xec1f irq 23 at device 31.2 on pci0
atapci0: [ITHREAD]
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
atapci1: <Intel ICH10 SATA300 controller> port 0xe8f0-0xe8f7,0xe8d8-0xe8db,0xe8f8-0xe8ff,0xe8dc-0xe8df,0xec20-0xec2f,0xec30-0xec3f irq 22 at device 31.5 on pci0
atapci1: [ITHREAD]
ata4: <ATA channel 0> on atapci1
ata4: [ITHREAD]
ata5: <ATA channel 1> on atapci1
ata5: [ITHREAD]
atrtc0: <AT realtime clock> port 0x70-0x7f irq 8 on acpi0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
uart0: [FILTER]
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
uart1: [FILTER]
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc7fff,0xc8000-0xc8fff,0xec000-0xeffff pnpid ORM0000 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
ata0: [ITHREAD]
ata1 at port 0x170-0x177,0x376 irq 15 on isa0
ata1: [ITHREAD]
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
ppc0: parallel port not found.
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr f
device_attach: est0 attach returned 6
p4tcc0: <CPU Frequency Thermal Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr f
device_attach: est1 attach returned 6
p4tcc1: <CPU Frequency Thermal Control> on cpu1
Timecounters tick every 1.000 msec
IPsec: Initialized Security Association Processing.
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 480Mbps High Speed USB v2.0
usbus3: 12Mbps Full Speed USB v1.0
usbus4: 12Mbps Full Speed USB v1.0
usbus5: 12Mbps Full Speed USB v1.0
usbus6: 12Mbps Full Speed USB v1.0
usbus7: 480Mbps High Speed USB v2.0
ugen0.1: <Intel> at usbus0
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <Intel> at usbus1
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen2.1: <Intel> at usbus2
uhub2: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus2
ugen3.1: <Intel> at usbus3
uhub3: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
ugen4.1: <Intel> at usbus4
uhub4: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus4
ugen5.1: <Intel> at usbus5
uhub5: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus5
ugen6.1: <Intel> at usbus6
uhub6: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus6
ugen7.1: <Intel> at usbus7
uhub7: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus7
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub3: 2 ports with 2 removable, self powered
uhub4: 2 ports with 2 removable, self powered
uhub5: 2 ports with 2 removable, self powered
uhub6: 2 ports with 2 removable, self powered
bce0: bce_pulse(): Bootcode lost the driver pulse! (bc_state = 0x0003600E)
bce1: bce_pulse(): Bootcode lost the driver pulse! (bc_state = 0x0003600E)
bce2: bce_pulse(): Bootcode lost the driver pulse! (bc_state = 0x0003E00E)
bce3: bce_pulse(): Bootcode lost the driver pulse! (bc_state = 0x0003E00E)
bce4: bce_pulse(): Bootcode lost the driver pulse! (bc_state = 0x0003E00E)
bce5: bce_pulse(): Bootcode lost the driver pulse! (bc_state = 0x0003E00E)
bce6: bce_pulse(): Bootcode lost the driver pulse! (bc_state = 0x0003E00E)
bce7: bce_pulse(): Bootcode lost the driver pulse! (bc_state = 0x0003E00E)
uhub2: 4 ports with 4 removable, self powered
uhub7: 4 ports with 4 removable, self powered
acd0: DVDR <TSSTcorp DVD+/-RW TS-L633C/D250> at ata4-master UDMA100 SATA 1.5Gb/s
mfi0: 4268 (376514988s/0x0020/info) - Time established as 12/06/11 19:29:48; (38 seconds since power on)
mfi0: 4269 (376515038s/0x0008/info) - Battery temperature is normal
mfi0: 4270 (376515038s/0x0008/info) - Current capacity of the battery is above threshold
mfi0: 4271 (376515038s/0x0008/info) - Battery relearn will start in 4 days
mfid0: <MFI Logical Disk> on mfi0
mfid0: 152064MB (311427072 sectors) RAID volume '' is optimal
SMP: AP CPU #1 Launched!
Root mount waiting for: usbus7 usbus2
ugen2.2: <vendor 0x0424> at usbus2
uhub8: <vendor 0x0424 product 0x2514, class 9/0, rev 2.00/0.00, addr 2> on usbus2
uhub8: 4 ports with 4 removable, self powered
Root mount waiting for: usbus2
ugen2.3: <Alps Electric> at usbus2
uhub9: <Alps Electric Hub in Apple USB Keyboard, class 9/0, rev 1.10/2.10, addr 3> on usbus2
ugen3.2: <Avocent> at usbus3
ukbd0: <Keyboard> on usbus3
kbd2 at ukbd0
ums0: <Mouse> on usbus3
ums0: 3 buttons and [Z] coordinates ID=0
Root mount waiting for: usbus2
uhub9: 3 ports with 2 removable, bus powered
ugen2.4: <Alps Electric> at usbus2
ukbd1: <Alps Electric Apple USB Keyboard, class 0/0, rev 1.10/1.03, addr 4> on usbus2
kbd3 at ukbd1
ugen2.5: <Mitsumi> at usbus2
ums1: <Mitsumi Apple USB Mouse, class 0/0, rev 1.00/5.05, addr 5> on usbus2
ums1: 1 buttons and [XY] coordinates ID=0
Trying to mount root from ufs:/dev/mfid0s1a
pflog0: promiscuous mode enabled
bce5: link state changed to UP
bce6: link state changed to UP
bce4: link state changed to UP
bce2: link state changed to UP
mfi0: 4272 (376515103s/0x0008/info) - Battery started charging
bce7: link state changed to DOWN
arp: 172.16.1.101 moved from 00:17:f2:c6:f0:56 to 00:1f:f3:43:36:6b on bce2
arp: 172.16.1.175 moved from f8:1e:df:f7:a5:43 to 00:24:36:9f:4a:d0 on bce2
mfi0: 4273 (376518613s/0x0008/info) - Battery charge complete

There is 4GB of ram. After re-installing the Lightsquid package, the server runs about 4 days without a need for reboot.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14994
  • Karma: +4/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #6 on: December 12, 2011, 08:13:56 am »
You could have something in your squid config set to consume large amounts of RAM. You didn't mention packages before, there could be tons of things in packages that would chew through all your RAM and swap if they aren't set correctly.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline fredmatrack

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #7 on: December 12, 2011, 09:21:24 am »
These are my settings for Squid proxy:



Offline fredmatrack

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #8 on: December 12, 2011, 09:22:52 am »
At this moment, Memory usage is 45%.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14994
  • Karma: +4/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #9 on: December 12, 2011, 09:40:50 am »
The output from the following commands at the shell would also help:

Code: [Select]
top -SHLet it run for a 30+ seconds, then copy and paste the full screen of output including the memory usage breakdown

And:
Code: [Select]
ps uxawww
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline fredmatrack

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #10 on: December 12, 2011, 09:50:16 am »
At this moment, SSH to the server gets a timeout. This is the output using the command prompt in the web interface.


Code: [Select]
$ ps uxawww
USER    PID %CPU %MEM   VSZ   RSS  TT  STAT STARTED      TIME COMMAND
root     11 200.0  0.0     0    16  ??  RL   Tue08PM 16605:07.14 [idle]
root  61477  0.1  0.5 53596 16216  ??  S    Tue08PM   0:01.22 /usr/local/bin/php
root      0  0.0  0.0     0    48  ??  DLs  Tue08PM   0:00.35 [kernel]
root      1  0.0  0.0  1888   304  ??  ILs  Tue08PM   0:00.05 /sbin/init --
root      2  0.0  0.0     0     8  ??  DL   Tue08PM   0:08.56 [g_event]
root      3  0.0  0.0     0     8  ??  DL   Tue08PM   0:19.88 [g_up]
root      4  0.0  0.0     0     8  ??  DL   Tue08PM   0:22.35 [g_down]
root      5  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.00 [crypto]
root      6  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.00 [crypto returns]
root      7  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.00 [sctp_iterator]
root      8  0.0  0.0     0     8  ??  DL   Tue08PM   0:13.08 [pfpurge]
root      9  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.00 [xpt_thrd]
root     10  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.00 [audit]
root     12  0.0  0.0     0   232  ??  WL   Tue08PM  59:36.44 [intr]
root     13  0.0  0.0     0    16  ??  DL   Tue08PM   0:00.26 [ng_queue]
root     14  0.0  0.0     0     8  ??  DL   Tue08PM   2:37.17 [yarrow]
root     15  0.0  0.0     0   256  ??  DL   Tue08PM   0:16.12 [usb]
root     16  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.64 [pagedaemon]
root     17  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.00 [vmdaemon]
root     18  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.00 [pagezero]
root     19  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.29 [idlepoll]
root     20  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.91 [bufdaemon]
root     21  0.0  0.0     0     8  ??  DL   Tue08PM   0:01.23 [vnlru]
root     22  0.0  0.0     0     8  ??  DL   Tue08PM   6:27.69 [syncer]
root     23  0.0  0.0     0     8  ??  DL   Tue08PM   0:01.12 [softdepflush]
root     39  0.0  0.0     0     8  ??  DL   Tue08PM   0:00.25 [md0]
root    253  0.0  0.0  3408  1072  ??  INs  Tue08PM   0:00.01 /usr/local/sbin/check_reload_status
root    255  0.0  0.0  3408   936  ??  IN   Tue08PM   0:00.00 check_reload_status: Monitoring daemon of check_reload_status
root    270  0.0  0.0  1888   388  ??  Is   Tue08PM   0:00.01 /sbin/devd
root   2158  0.0  0.0  3316   952  ??  Is   Tue08PM   0:00.22 /usr/local/bin/minicron 240 /var/run/ping_hosts.pid /usr/local/bin/ping_hosts.sh
root   2639  0.0  0.0  3316   952  ??  Is   Tue08PM   0:00.02 /usr/local/bin/minicron 3600 /var/run/expire_accounts.pid /etc/rc.expireaccounts
root   3102  0.0  0.0  3316   952  ??  Is   Tue08PM   0:00.00 /usr/local/bin/minicron 86400 /var/run/update_alias_url_data.pid /etc/rc.update_alias_url_data
root  10235  0.0  0.1  5272  2544  ??  Is   Tue08PM   0:00.00 /usr/sbin/sshd
root  10480  0.0  0.0  3316  1232  ??  Is   Tue08PM   0:00.08 dhclient: bce0 [priv] (dhclient)
root  12217  0.0  0.0  4556  1144  ??  Is   Tue08PM   0:00.01 /usr/local/sbin/sshlockout_pf 15
_dhcp 20334  0.0  0.0  3316  1356  ??  Ss   Tue08PM   0:00.18 dhclient: bce0 (dhclient)
root  21632  0.0  0.0  1564   508  ??  IN    4:49PM   0:00.00 sleep 60
root  23177  0.0  0.1  7296  3440  ??  Is   Tue08PM   0:00.00 /usr/local/sbin/squid -D
root  23348  0.0  0.0  1564   508  ??  S     4:49PM   0:00.00 sleep 55
proxy 23868  0.0 31.7 1000576 988376  ??  S    Tue08PM  32:11.57 (squid) -D (squid)
root  24023  0.0  0.0  3456  1096  ??  R     4:49PM   0:00.00 ps uxawww
proxy 24208  0.0  0.0  1564   632  ??  I    Tue08PM   0:00.00 (unlinkd) (unlinkd)
root  28396  0.0  0.1  4944  1900  ??  Ss   Tue08PM   0:06.31 /usr/sbin/syslogd -c -c -l /var/dhcpd/var/run/log -f /var/etc/syslog.conf
root  34317  0.0  0.0  3316  1252  ??  SNs  Tue08PM   2:30.65 /usr/local/sbin/apinger -c /var/etc/apinger.conf
root  35411  0.0  0.0  3316  1280  ??  Ss   Tue08PM   0:00.21 ntpd: [priv] (ntpd)
dhcpd 36906  0.0  0.2  8436  5644  ??  Ss    4:48PM   0:00.00 /usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /etc/dhcpd.conf bce3 bce4 bce2
root  37122  0.0  0.1  9528  3464  ??  Is   Tue08PM   0:00.02 /usr/local/sbin/mpd4 -b -d /var/etc/pptp-vpn -p /var/run/pptp-vpn.pid -s pptps pptps
root  41359  0.0  0.0  3436  1308  ??  Is   Tue08PM   0:00.00 /usr/sbin/inetd -wW -R 0 -a 127.0.0.1 /var/etc/inetd.conf
root  44202  0.0  0.0  4496  1292  ??  IN    4:48PM   0:00.00 /usr/local/bin/rrdtool -
root  54604  0.0  0.2 52572  7588  ??  Is   Tue08PM   0:00.04 /usr/local/bin/php
root  56990  0.0  0.5 54620 15456  ??  I    Tue08PM   0:00.19 /usr/local/bin/php
root  57033  0.0  0.2 52572  7672  ??  I    Tue08PM   0:00.00 /usr/local/bin/php
root  59166  0.0  0.1  6588  3492  ??  SN    4:48PM   0:00.06 /usr/local/sbin/lighttpd -f /var/etc/lighty-webConfigurator.conf
root  60911  0.0  0.2 52572  7628  ??  Is   Tue08PM   0:00.04 /usr/local/bin/php
root  61244  0.0  0.0  3656  1244  ??  IN    4:48PM   0:00.02 /bin/sh /var/db/rrd/updaterrd.sh
root  61275  0.0  0.6 54620 19748  ??  I    Tue08PM   0:01.92 /usr/local/bin/php
root  61690  0.0  0.0  3404  1264  ??  Is   Tue08PM   0:00.56 /usr/sbin/cron -s
root   1604  0.0  0.0  3656  1196  v0- S    Tue08PM   0:04.06 /bin/sh /usr/local/etc/rc.d/proxy_monitor.sh start
root  11998  0.0  0.0  3684  1428  v0  Is   Tue08PM   0:00.01 login [pam] (login)
root  12479  0.0  0.0  3656  1208  v0  I    Tue08PM   0:00.00 -sh (sh)
root  13627  0.0  0.0  3656  1208  v0  I+   Tue08PM   0:00.00 /bin/sh /etc/rc.initial
root  29015  0.0  0.1  5912  2924  v0- S    Tue08PM   0:04.21 /usr/sbin/tcpdump -s 256 -v -l -n -e -ttt -i pflog0
root  29055  0.0  0.0  3316   836  v0- S    Tue08PM   0:02.23 logger -t pf -p local0.info
_ntp  33003  0.0  0.0  3316  1260  v0- S    Tue08PM   0:00.44 ntpd: ntp engine (ntpd)

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14994
  • Karma: +4/-0
    • View Profile
Re: Errors on Dell PowerEdge r510
« Reply #11 on: December 12, 2011, 09:57:18 am »
Just run that periodically and keep an eye on it. Looks like squid is using 1GB so far, it may keep going up, or something else may spring up using lots of RAM.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!