pfSense Support Subscription

Author Topic: pfSense 2.0.1 install squid failed!  (Read 9322 times)

0 Members and 1 Guest are viewing this topic.

Offline Sopon Tumchota

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #15 on: January 12, 2012, 10:24:50 am »
i;m try to install with AMD64, it same error!!!!!

Beginning package installation for squid...
Downloading package configuration file... done.
Saving updated package information... done.
Downloading squid and its dependencies...
Checking for package installation...
 Downloading http://files.pfsense.org/packages/amd64/8/All/squid-2.7.9_1.tbz ...  (extracting)

   Downloading http://files.pfsense.org/packages/amd64/8/All/cyrus-sasl-2.1.25_1.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/amd64/packages-8.1-release/All/cyrus-sasl-2.1.25_1.tbz.
of squid-2.7.9_1 failed!

Installation aborted.Backing up libraries...
Removing package...
Starting package deletion for squid-2.7.9_1...done.
Starting package deletion for squid_radius_auth-1.10...done.
Starting package deletion for libwww-5.4.0_4...done.
Removing squid components...
Tabs items... done.
Menu items... done.
Services... done.
Loading package instructions...
Include file squid.inc could not be found for inclusion.
Deinstall commands...
Not executing custom deinstall hook because an include is missing.
Removing package instructions...done.
Auxiliary files... done.
Package XML... done.
Configuration... done.
Cleaning up... Failed to install package.

Installation halted.

Offline Sopon Tumchota

  • Newbie
  • *
  • Posts: 19
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #16 on: January 13, 2012, 05:13:14 am »
Today i,m try to install squid on pfsense 2.0.1 AMD64 look like good  ;D in step Additional files...  proxy_monitor.sh failed ...

Beginning package installation for squid...
Downloading package configuration file... done.
Saving updated package information... done.
Downloading squid and its dependencies...
Checking for package installation...
 Downloading http://files.pfsense.org/packages/amd64/8/All/libwww-5.4.0_4.tbz ...  (extracting)
Loading package configuration... done.
Configuring package components...
Additional files... proxy_monitor.sh failed.
Backing up libraries...
Removing package...
Starting package deletion for squid-2.7.9_1...done.
Starting package deletion for cyrus-sasl-2.1...done.
Starting package deletion for openldap-client-2.4...done.
Starting package deletion for perl-5.12...done.
Starting package deletion for squid_radius_auth-1.10...done.
Starting package deletion for libwww-5.4.0_4...done.
Removing squid components...
Tabs items... done.
Menu items... done.
Services... done.
Loading package instructions...
Deinstall commands... done.
Removing package instructions...done.
Auxiliary files... done.
Package XML... done.
Configuration... done.
Cleaning up... Failed to install package.

Installation halted.

Offline schlocker

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #17 on: February 18, 2012, 02:35:02 am »
I had the exact same issue with multiple packages and PFS 2.0.1. Disabled all load balancing rules and it still would not work. Could download package from browser but not within the package installer.

Not a routing issue.

In Thailand with three internet connections, 10/10MB leased line, 12/1 MB ADSL and 4/.5MB ADSL.

In my case the problem turned out to be the 10MB leased line. I used it as the default gateway as it has the lowest latency. When this connection is the default gateway the packages would not install.

Used the 12MB ADSL and all packages downloaded and installed correctly.

Using Squid, Squid Guard, Lightsquid, and Load-balancing multiple WAN connections successfully.
I hope this helps someone.

Not sure why this leased line has issues when downloading packages, but now I use the ADSL as the default gateway.
« Last Edit: February 18, 2012, 02:39:12 am by schlocker »

Offline ary_iLLuM

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #18 on: February 24, 2012, 12:27:14 am »
I've install squid successfully but "Proxy Server" not show up under Services

howto fix this ?

best regards

Online marcelloc

  • Hero Member
  • *****
  • Posts: 9954
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #19 on: February 24, 2012, 09:05:17 am »
I've install squid successfully but "Proxy Server" not show up under Services

howto fix this ?

best regards

Try to reinstall the package.

Offline smith999

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #20 on: February 25, 2012, 10:23:43 pm »
I can't  to access http://files.pfsense.org/packages/8/All/. My network is 203.172.175.xxx. Help me pls.

Online cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6314
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: pfSense 2.0.1 install squid failed!
« Reply #21 on: February 25, 2012, 10:50:29 pm »
I can't  to access http://files.pfsense.org/packages/8/All/. My network is 203.172.175.xxx. Help me pls.

Your provider has been null routed by the ISP that hosts that server because of a DDoS attack. I contacted them to see if that's subsided and they can remove that. You should complain to your provider to be more responsive with detecting and taking down DDoS bots so ISPs don't have to block you.

Offline smith999

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #22 on: February 26, 2012, 02:51:27 am »
I can't  to access http://files.pfsense.org/packages/8/All/. My network is 203.172.175.xxx. Help me pls.

Your provider has been null routed by the ISP that hosts that server because of a DDoS attack. I contacted them to see if that's subsided and they can remove that. You should complain to your provider to be more responsive with detecting and taking down DDoS bots so ISPs don't have to block you.
Thank You Very Much.Please allow my subnet is 203.172.175.160/27.I will try complain with my provider about responsive and taking down DDoS.

Online cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6314
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: pfSense 2.0.1 install squid failed!
« Reply #23 on: February 26, 2012, 03:27:20 am »
I can't do anything about it, I don't control their network. I did notify the provider though.

Offline jampola

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #24 on: February 28, 2012, 09:27:19 pm »
Seems to be an issue with TOT (Thailand ISP) - I can ssh through my godaddy account and download the packages but no dice directly from my pfSense boxes. I have 4 sites all with TOT and they're all having the same issue. I've tried explaining this to TOT but my spoken Thai is not great and their spoken English is even worse, so if any of you Thai guys want to call them and tell them to sort out their routing issues, that'd be great!

Offline novacoresystems

  • Jr. Member
  • **
  • Posts: 30
    • View Profile
    • Novacore Systems
Re: pfSense 2.0.1 install squid failed!
« Reply #25 on: February 29, 2012, 12:31:50 pm »
Yeah definitely... I've installed this package on a few different VMs and physical machines and it installed fine. Both i386 and X64.

Offline smith999

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #26 on: March 01, 2012, 02:23:48 am »
I understand that because uninet(thailand) training on pfsense. May lead to the misconception that an attack by ddos.

Online cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6314
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: pfSense 2.0.1 install squid failed!
« Reply #27 on: March 01, 2012, 06:51:29 pm »
I understand that because uninet(thailand) training on pfsense. May lead to the misconception that an attack by ddos.

No, we push at times over 150 Mbps off that server, doesn't matter if you had thousands of people in training, it wouldn't impact anything or even raise any kind of concern. It wasn't targeted to us either, someone else on the provider's network. It was legitimately a DDoS attack. I'm not sure if that null routing has been removed yet, but I have requested that it is.

Offline smith999

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #28 on: March 13, 2012, 08:33:12 pm »
...

Offline iTronz

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: pfSense 2.0.1 install squid failed!
« Reply #29 on: March 13, 2012, 11:27:59 pm »
I have this same issue with a new install of pfsense but I'm based in the United Kingdom.....

"Failed to install package"

This must be a server side issue.