pfSense Support Subscription

Author Topic: NAT Port Forwarding to Internal host UDP port 5060 not working as expected  (Read 22047 times)

0 Members and 1 Guest are viewing this topic.

Offline N8LBV

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
It only happens with some specific packages.
If I have a dynamic SIP registration going out -->10.73.73.8:(src)5060:(dst)5060-->PFSMyPublicIP:43112:5060-->RemotePublic IP:43112:5060
Packets coming back as RemotePublicIP:5060:43112--->PFSMyPublicIP:43112:5060--->10.73.73.8:5060:5060 work good as expected.

However if RemotePublicIP suddenly sends us another packet like this:  RemotePublicIP:5060:5060 (instead or aside from) RemotePublicIP:5060:43112
The packet destined to port 5060 does not get nated and send on to 10.73.73.8 like it should be due to the port forwarding rule.
It's as if the dynamically created reachback rule is somehow overwriting the port forward rule which should NEVER happen :-)


My test scenario is this:

From PFSense Fresh install Defaults

1. assign single static IP to WAN Interface.
2. assign single static IP to lan interface. (10.73.73.1)
3. assign default gateway and DNS address for WAN
4. DHCP disabled on lan & wan
5. Start with auto outbound rule make sure Internet access & nat Lan to outside is working
6. Enable NOT blocking bogon networks (not needed to recreate problem) I just do it for testing.
7. Internal asterisk box placed at 10.73.73.8 and using PFS as it's gateway.
8. Asterisk nat settings are set properly for internal network range and external public IP address in sip.conf
9  In PFS Set Port forward from anywhere UDP DST port=5060 gets rdirect target set to 10.73.73.8 redirect port UDP 5060
10. In PFS Set Port forward from anywhere UDP DST Ports =11200-11300 redirect to target 10.73.73.8 UDP DST 11200-11300 (this is for RTP and NOT needed to demonstrate port 5060 failure to nat).
In my case port forward 5060 fail issue can still be tested without without RTP flowing to the internal box You just simply won't have working audio has nothing to do with the issue reported.

11. Have asterisk register to an external SIP provider will by default create a dynamic inbound port back to asterisk (THIS IS OK).
12. You are now registered with provider outbound port is UDP 5060 inbound port will be random 32119 for example.. Inbound SIP from registered provider will be on UDP port 32119.
     (my provder doesn't care if we randomize or dynamically change the outbound port it still works)
13. Same provider now sends you usual expected packets on port 32119 for SIP messaging as expected and they reach the internal box just fine.
14. TEST: Now same provder sends us another SIP packet but instead they send it to UDP PORT 5060 instead of 32119.
15.  PFSense gets the packet but does not nat it and does not pass it on to 10.73.73.8 regardless of our port forward rule that it should.

I can provide more details and packet captures and screenshots of my PFSense setup if this will save you any time as well as allow you remote access to my test config via Private message email or a phone call.

Also just confirming the focus here is now that I'm siting a bug in port forwarding.
 I did get my system to 'work' by Forcing static outbound on UDP 5060 just to get PFSense get me the packets coming back on PORT 5060 via a separate mechanism other than a port forward rule.
aside from port forwarding rules.. This made my system work but also setup other ugly limitations that will cause me grief later on for sure when I need other (random ports) to work in combination with
5060 to/from the same remote host.

Online cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6333
  • Karma: +0/-0
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
You need to rewrite the source port on your outbound SIP as is done by default. I suspect the outbound NAT state is picking up the traffic rather than the rdr (port forward), because you aren't rewriting the source port.

Offline N8LBV

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
>You need to rewrite the source port on your outbound SIP as is done by default.
Sorry I'm not understanding exactly what you are saying here.
If I use it in a default fashion while outbound sip is being rewritten I am seeing the problem with inbound packets to port 5060 which is wrong.
A remote host can send inbound packets to multiple ports there is nothing wrong with this.


>  I suspect the outbound NAT state is picking up the traffic rather than the rdr (port forward), because you aren't rewriting the source port.
 Still not understanding at all (sorry). And we are dealing with an inbound static rule so outbound nat state should not matter.

I still have an expectation as it works on all other firewalls and that is if you define a port forward rule it will work regardless of what is going on
dynamically.

I still see no reason at all why this is not portwarding under all conditions. That is the sole purpose of port forwarding. Seriously.. there's no reason for it NOT to work unless
there is a bug in the packet inspection and/or decision making here.. It's a brain dead simple port forwarding task and it's failing.

« Last Edit: January 23, 2012, 05:28:07 pm by N8LBV »

Offline N8LBV

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
CMB, it sounds like you are telling me what I need to do to make it work (which I have done) and have made it work awhile back.. maybe you already read this.. I'm not sure.  I have done exactly that and it does work. But portworwarding itself in this case still does not behave the way I expect it should.
It breaks other things that I won't dig into right now unless you ask, as it will take this off topic.
I'll continue to listen & learn for awhile before I open a bug report in case I'm missing something.  Thank you
so very much for helping out!


Offline phazethree

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
I am having a similar problem but I can at least get it to work using Manual NAT. The problem with this is once I turn on manual NAT with Static, it breaks my other subnets web browsing capabilities.

Here is my scenario:

192.168.0.0 - Local lan
192.168.1.0 - VPN lan
192.168.12.0 - MPLS lan
192.168.13.0 - MPLS lan
192.168.14.0 - VPN lan
192.168.23.0 - VPN Lan
192.168.24.0 - VPN lan
192.168.25.0 - VPN lan
192.168.26.0 - VPN lan

The phone system sits on 192.168.0.6 and there are IP phones on 192.168.23.0 and 192.168.25.0 working fine. We had to add a SIP provider for routing "out of area" numbers to the phone system from the phones sitting on the  192.168.14.0 network. The intercom traffic works fine between 192.168.0.0 and 192.168.14.0 through the VPN. All HTTP traffic works fine through squid3 as a proxy from all networks. With this currently set as Auto Outbound NAT everything works fine except the SIP traffic. I can call the number, the packets get routed through the phone system and the phones at 192.168.14.0 ring. I can hear them answer but they cannot hear me. To resolve this I turned on Manual Outbound NAT. Fixed the phone issue, but now no one can access web pages through squid3 on any network other than 192.168.0.0 which is local to the firewall and the phone system.

I have come to the conclusion that the Static Port option breaks squid3 but fixes the phones, and in turn static mapping turned off fixes squid3 but breaks the phones (one way audio). We are using an outside provider so there are no SIP equipment onsite.

Any one have any suggestions or need further info please feel free. I'm at the point I'll try anything now.

Offline friesen

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
i am having the exact same problem as N8LBV.  i have been using voip through pfsense for years with no problems until setting up a new box with version 2.0.1 of pfsense.  something isnt right.  i have tried all the suggestions for outbound static ports and anything else that people suggest in various forums and still no love.  why can't this version of pfsense just not forward udp traffic that originated from behind the firewall back to it on port 5060 to my voip server?  i can connect to my server through port 5060 on a sip client that originates on the wan connection, but not a connection that originated from behind pfsense, i hope that makes sense.

Offline friesen

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
I finally got mine working today. i reset everything to factory defaults.  created a nat port forward
WAN    TCP/UDP    *    *    WAN address    5060 (SIP)    10.0.0.8    5060 (SIP) and allowed it to create a new associated filter rule for that.  under NAT.outbound i changed it to manual and set it to use static-port, reloaded my trunk and inbound calls worked. 

Offline chinny.ha

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
hi all,

i also have the exact same issue -- 9 packets arriving on wan, 2 arriving at interior host.

i'm running a pfsense 2.01 host on amd64 inside a vmware virtual machine.

seriously grave -- i cannot seem to get the packets forwarded following the advice in this thread :-(

c

Offline giulianoz

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Same issue here. Unfortunately the tips above didn't worked for me :( Any suggestion ?

Offline giulianoz

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
it seems to work on 2.1 snapshot of july 18th

Offline inflamer

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +0/-0
    • View Profile
N8LBV,

does the SIP UA on the inside of your pfSense implement rport? If not, I would expect that SIP responses coming back from the SIP server on the outside will be sent to the port specified in the via header inserted by the SIP UA on the inside of your network, which for SIP over UDP normally would be 5060.

Can you post a packet capture showing an outbound SIP request and the corresponding response which is coming back on the wrong port?

Offline inflamer

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +0/-0
    • View Profile
N8LBV,

also keep in mind that while SIP responses use via headers for making it back to the originator, new requests within the same transaction (Such as the ACK request you mentioned in your initial post) use record-route headers for making it to their destination, which could explain why some SIP responses/requests are not arriving at the same port as the outbound traffic used.

Offline gofast

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
I am also having the exact same problem. A brain dead port forward on UDP port 5060 is not working. I have been pulling my hair out trying everything. Packet captures on the pfsense show that the retuning packets never get forwarded from with WAN to LAN, i.e. are on WAN but never on LAN. I reset to defaults and added just the simple rule and still no joy.

Offline inflamer

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +0/-0
    • View Profile
Gofast,

have you verified that the response is coming back to the same port as the original request was sent out from?

If the involved SIP UA's do not support the 'rport' SIP extension then the responses would be sent back to the port specified in the topmost via header, which would normally not be the same port as the NAT'ed port the original request was sent out with.

- Andreas

Offline gofast

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
The source and dest port were 5060 from the asterisk box for the packet on the LAN being sent to the internet(WAN).
The source port got changed via the outgoing NAT to the WAN. The return packet from the internet had source and dest ports of 5060. The port forward should forward this regardless because it met the rule - destination port 5060 on wan forward to an ip on the LAN. I firewall added rules to allow all on all interfaces and it doesn't help. It appears to just get dropped for an unknown reason (unknown to me). Why does the port forward get ignored? What came before shouldn't matter as UDP is stateless. Am I missing something?