The pfSense Store

Author Topic: Mutiple Public IP NAT to multiple webservers  (Read 2297 times)

0 Members and 1 Guest are viewing this topic.

Offline bellera

  • Hero Member
  • *****
  • Posts: 5575
  • Karma: +120/-51
    • View Profile
Mutiple Public IP NAT to multiple webservers
« on: March 05, 2012, 04:07:57 pm »
WAN (First Public IP)
Virtual IP ARP for WAN (Second Public IP)

NAT Port Forward publishing two webservers at LAN.
Second NAT doesn't work after upgrading from 1.2.3 to 2.0.1.

http://forum.pfsense.org/index.php?topic=30109.0

Same problem at Spanish section

http://forum.pfsense.org/index.php/topic,46586.msg246284.html#msg246284

Offline cmb

  • Hero Member
  • *****
  • Posts: 11230
  • Karma: +893/-7
    • View Profile
    • Chris Buechler
Re: Mutiple Public IP NAT to multiple webservers
« Reply #1 on: March 05, 2012, 11:05:31 pm »
what's the output of "ps ax|grep choparp" show?


Offline cmb

  • Hero Member
  • *****
  • Posts: 11230
  • Karma: +893/-7
    • View Profile
    • Chris Buechler
Re: Mutiple Public IP NAT to multiple webservers
« Reply #3 on: March 06, 2012, 08:53:42 pm »
One of them looks to be on the wrong NIC based on that, it appears they're on the same subnet, but two different NICs.

Offline bellera

  • Hero Member
  • *****
  • Posts: 5575
  • Karma: +120/-51
    • View Profile
Re: Mutiple Public IP NAT to multiple webservers
« Reply #4 on: March 07, 2012, 02:53:30 am »
Ok, thanks!

I told the spanish user to reedit its Virtual IPs.

http://forum.pfsense.org/index.php/topic,46586.msg246820.html#msg246820

Regards,

Josep Pujadas-Jubany