The pfSense Store

Author Topic: Problems with OpenVPN Export Utility  (Read 853 times)

0 Members and 1 Guest are viewing this topic.

Offline KrisDouglas

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Problems with OpenVPN Export Utility
« on: March 12, 2012, 03:32:55 pm »
Hello, I noticed after installing the OpenVPN export utility that it was not displaying on the UI properly.

I tried to uninstall it and I got the following error:

Code: [Select]
Parse error: syntax error, unexpected $end in /usr/local/pkg/openvpn-client-export.inc on line 443
at the bottom of the page. This happens just after it says the following:

Code: [Select]
Removing package...
Starting package deletion for p7zip-9.13...done.
Starting package deletion for zip-3.0...done.
Removing OpenVPN Client Export Utility components...
Tabs items... done.
Loading package instructions...

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14998
  • Karma: +4/-0
    • View Profile
Re: Problems with OpenVPN Export Utility
« Reply #1 on: March 15, 2012, 10:53:52 am »
Sounds like somehow that file may have been corrupted.

If you can get to the shell, try:

Code: [Select]
fetch -o /usr/local/pkg/ http://www.pfsense.com/packages/config/openvpn-client-export/openvpn-client-export.inc
Then see if it works.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline KrisDouglas

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Problems with OpenVPN Export Utility
« Reply #2 on: March 15, 2012, 10:59:42 am »
I should have replied back to let everyone know, I fixed this with the above solution a couple of days ago.

The one thing I will tell you, is that if you rely on a firewall to access the machine you will be in deep trouble if you reboot it.

If you ever come across this problem you need to fix it before you restart the machine.