Netgate m1n1wall

Author Topic: UDPXY v. 1.0 (Build 21) standard  (Read 1529 times)

0 Members and 1 Guest are viewing this topic.

Offline abahaba

  • Newbie
  • *
  • Posts: 9
    • View Profile
UDPXY v. 1.0 (Build 21) standard
« on: March 18, 2012, 06:55:57 am »
Hi,

If you have time and desire to help, I need your help.

I have installed udpxy v. 1.0 (Build 21) standard on pfSense 2.0.1-RELEASE-pfSense (i386), together with the IGMP Proxy.
WAN (re0) 10.218.104.92
LAN (rl0) 172.22.22.0/24
I do not know why, but the provider broadcasts multicast stream from 150.158.231.1

Over IGMP Proxy client, using udp :/ / @ 239.2.3.xxx: 1234 is taking multicast well, but as you know over wi-fi, even with enabled multicast.
UDPXY created a log file udpxy.log udpxy, but it always remains empty. I can see the logs only through pfSense/status/system logs.
On startup UDPXY runs through udpxy.sh with a such parameters udpxy_flags = $ {udpxy_flags-"-a rl0-m re0-c 20-M 120"}
Can you recommend a maximum performance parameters (-H,-B,-R, etc.) for better viewing?

The client connects uses http://172.22.22.3:4022/udp/239.2.3.75:1234

______________________________________________________________________
tcpdump-ni re0 igmp

14:32:18.688774 IP 10.218.104.92> 224.0.0.22: igmp v3 report, 1 group record (s)
14:32:20.298748 IP 10.218.104.92> 224.0.0.22: igmp v3 report, 1 group record (s)
14:32:23.713717 IP 10.218.104.92> 224.0.0.22: igmp v3 report, 1 group record (s)
14:32:25.323684 IP 10.218.104.92> 224.0.0.22: igmp v3 report, 1 group record (s)
_______________________________________________________________________


Over the status (web: http://172.22.22.3:4022/status) I have:

Active clients:
Process ID          Source                    Destination         Throughput
15643         172.22.22.99:49889       239.2.3.75:1234        N / A


The client does not see the picture. After restarting of pfsense router - the video stream goes. After switching to the next different channel - the video stream goes well. But if I return to previous channel - no video stream. But video stream on the WAN still remaining:

14:48:08.180322 IP 150.158.231.1.49152> 239.2.3.38.1234: UDP, length 1316
14:48:08.182658 IP 150.158.231.1.49152> 239.2.3.38.1234: UDP, length 1316
14:48:08.184980 IP 150.158.231.1.49152> 239.2.3.38.1234: UDP, length 1316
14:48:08.187311 IP 150.158.231.1.49152> 239.2.3.75.1234: UDP, length 1316
14:48:08.189647 IP 150.158.231.1.49152> 239.2.3.38.1234: UDP, length 1316
14:48:08.191966 IP 150.158.231.1.49152> 239.2.3.38.1234: UDP, length 1316
14:48:08.194315 IP 150.158.231.1.49152> 239.2.3.75.1234: UDP, length 1316

But udpxy does not supply to client a unicast. After a while, the stream appears, but not for all channels, as over IGMP Proxy.

For example over IGMP Proxy using udp://@239.2.3.16:1234 client's stream appears.
But over udpxy using http://172.22.22.3:4022/udp/239.2.3.14:1234 - nothing and result on log is such:
udpxy [42873]: read_buf: read: Resource temporarily unavailable

Observed pattern: in some cases UDPXY starts to work, when I used IGMP Proxy before for that specific chanel.


Thanks in advance for your help.