Netgate m1n1wall

Author Topic: HTTP 403 (Forbidden) Webgui  (Read 2121 times)

0 Members and 1 Guest are viewing this topic.

Offline zonda7

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
HTTP 403 (Forbidden) Webgui
« on: April 21, 2012, 12:07:34 pm »
Hi

I setup up pfsense 2.1 on a VM running FreeBSD, enabled ssh, checked I can ping out the WAN and LAN and checked I could ping back into the address I gave the LAN but I cannot connect to the Webgui. In Firefox I get a blank page and in IE and Chrome I get a HTTP 403 (Forbidden) message.  HELP!!!! :-\


Offline M.I.Bovrd

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
  • M.I.Bovrd
    • View Profile
    • CQRITEŽ
Re: HTTP 403 (Forbidden) Webgui
« Reply #1 on: April 21, 2012, 01:29:48 pm »
A little confused?  ???

Not sure what you enabled. Enabling ssh allows access on port 22 or other defined port for a terminal program.

Selecting HTTPS allows secure browser access to the Web-configurater. If you havn't disabled the re-direct HTTP access will redirect you to HTTPS.

Try HTTP again.
Tweet: MIBovrd@cqrite http://www.cqrite.com

Offline zonda7

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: HTTP 403 (Forbidden) Webgui
« Reply #2 on: April 21, 2012, 01:52:54 pm »
As you can see I am confused too :S

Well so far apart from the standard setup I have not made any changes.  I ran the install as per the guides (enabled ssh for some unknown reason) and tried to connect to Webgui (in my case) 10.10.10.1 from the pc which the VM is setup on.  You can ping from either side yet cannot connect from either https or http.  Do I need to make any changes from the standard install?

Offline M.I.Bovrd

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
  • M.I.Bovrd
    • View Profile
    • CQRITEŽ
Re: HTTP 403 (Forbidden) Webgui
« Reply #3 on: April 21, 2012, 02:18:55 pm »
Not done a VM install, so not sure. Depends on what type of VM, how many ports, IP ranges you are using, and routing. A little piccy might help with the ip's. VM's do have nasty issue sending the response back via the interfaces real IP rather than the VIP, this would mean ping would work, but http or any TCP connection would fail.
Some things to try.
Try a traceroute to both sides to see which way it goes.

Try ssh admin@x.x.x.x pfsense using LAN ip, if that works then routing not a problem to LAN

Try 'telnet x.x.x.x 80' LAN IP again. See if it connects, if it does then your browser is probably proxied. take proxy of and connect direct.
Tweet: MIBovrd@cqrite http://www.cqrite.com

Offline zonda7

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: HTTP 403 (Forbidden) Webgui
« Reply #4 on: April 21, 2012, 04:01:51 pm »
I disabled the proxy but that did not work.

I tried to ssh and telnet both failed.

The host and VM config is what you can find in how to install on a VM.  I have onboard nic (LAN int) and an expansion nic (WAN int).

Host machine has ip 10.10.10.2/24
VM LAN int 10.10.10.1/24
WAN int 192.168.1.91

Here are some screen shots.

Offline zonda7

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: HTTP 403 (Forbidden) Webgui
« Reply #5 on: April 21, 2012, 04:07:31 pm »
....

Offline zonda7

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: HTTP 403 (Forbidden) Webgui
« Reply #6 on: April 21, 2012, 04:08:29 pm »
....

Offline zonda7

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: HTTP 403 (Forbidden) Webgui
« Reply #7 on: April 21, 2012, 04:09:23 pm »
...

Offline cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6333
  • Karma: +0/-0
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: HTTP 403 (Forbidden) Webgui
« Reply #8 on: April 21, 2012, 04:13:09 pm »
You're not getting a 403 from the firewall, it's from your own machine. You're creating an IP conflict on 10.10.10.1.

Offline cmb

  • Administrator
  • Hero Member
  • *****
  • Posts: 6333
  • Karma: +0/-0
    • LinkedIn
    • Twitter
    • View Profile
    • Chris Buechler
Re: HTTP 403 (Forbidden) Webgui
« Reply #9 on: April 21, 2012, 04:14:04 pm »
and you also can't have 10.10.10.0/24 on both your physical and virtual NICs, aside from the IP conflict breaking things. You have to bridge if you want a 10.10.10.x IP on the VM.

Offline zonda7

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: HTTP 403 (Forbidden) Webgui
« Reply #10 on: April 24, 2012, 11:46:18 am »
Thanks for the assistance.  I RTFM'd on the VM front so now have a better understanding :O) and it works.