pfSense Gold Subscription

Author Topic: Squid3 and SSL  (Read 1155 times)

0 Members and 1 Guest are viewing this topic.

Offline onkeldave83

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Squid3 and SSL
« on: April 26, 2012, 04:18:48 am »
hello at all,

i want to test to filter ssl traffic with squid3.

i read that i cant use a transparence mode with this.

ok i disable squid transparent.

i have created /usr/local/www/wpad.dat

i put it in dns forwarder.

but no success.

have anyone a tutorial ?

thaaaanks

Offline onkeldave83

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: Squid3 and SSL
« Reply #1 on: April 26, 2012, 04:23:58 am »
i have set:
autodetect proxy settings in browser


but squid + filter are not filtering any more :(((


Offline onkeldave83

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: Squid3 and SSL
« Reply #2 on: April 26, 2012, 04:38:49 am »
what have i to do in normal words, that i can filter traffic on https?????

reverse proxy enable ?

wpad ?

config ???

rule???


thanks for helping

Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9930
    • View Profile
Re: Squid3 and SSL
« Reply #3 on: April 26, 2012, 10:39:06 am »
Before using wpad, configure your browser to use squid ip and port.

When you have all rules set to filter https and http urls(squidguard will improve your filter options) working, then try wpad again.

Enable squid logs to be able to check what is passing through squid

att,
Marcello Coutinho

Offline mohandshamada

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Squid3 and SSL
« Reply #4 on: April 27, 2012, 08:13:58 am »
i confgured wpad and try to make it work and it doesnt i followed the tutorial in the documentation but nothing happen