The pfSense Store

Author Topic: squid removed when restoring a backup  (Read 858 times)

0 Members and 1 Guest are viewing this topic.

Offline fluca1978

  • Full Member
  • ***
  • Posts: 137
  • Karma: +0/-0
    • View Profile
squid removed when restoring a backup
« on: May 03, 2012, 02:39:28 am »
Hi all,
this happened with a 1.2.3 machine: I restored a backup and the squid package disappeared at all. The strange thing is that other packages, like bandwidthd and squidguard remained in place, while for squid I needed to reinstall it from scratch. Is this normal?

Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9985
  • Karma: +3/-0
    • View Profile
Re: squid removed when restoring a backup
« Reply #1 on: May 03, 2012, 06:24:50 am »
If your backup file has squid config on it, a package reinstall will get squid back with your config.

Offline fluca1978

  • Full Member
  • ***
  • Posts: 137
  • Karma: +0/-0
    • View Profile
Re: squid removed when restoring a backup
« Reply #2 on: May 03, 2012, 06:45:54 am »
If your backup file has squid config on it, a package reinstall will get squid back with your config.

Yes, of course. But I don't understand why the package has been removed while restoring a copy. And why only such package while other packages remains where they are.

Offline marcelloc

  • Hero Member
  • *****
  • Posts: 9985
  • Karma: +3/-0
    • View Profile
Re: squid removed when restoring a backup
« Reply #3 on: May 03, 2012, 09:08:32 am »
Not sure what happened but why are you still on 1.2.3?

Offline fluca1978

  • Full Member
  • ***
  • Posts: 137
  • Karma: +0/-0
    • View Profile
Re: squid removed when restoring a backup
« Reply #4 on: May 03, 2012, 09:39:02 am »
Not sure what happened but why are you still on 1.2.3?


I'm going to upgrade, could it be a bug in such version?