The pfSense Store

Author Topic: Avahi-Daemon Process run away?  (Read 1496 times)

0 Members and 1 Guest are viewing this topic.

Offline mostlyharmless

  • Newbie
  • *
  • Posts: 24
    • View Profile
Avahi-Daemon Process run away?
« on: June 25, 2012, 01:34:17 am »
I'm running PfSense Embedded 2.0.1 on an Alix 1dc
I have the avahi 0.6.25_2 package installed
It seems that it's taking up 100% computer after a day or two or after a reset.
I can't seem to figure out why it's doing this. It doesn't strike me as a very cpu intensive program.
Only way I seem to relieve the problem is to kill -9 avahi-daemon, and restart it from the web configurator. This drops it back down to sane processor levels.
Is this a known issue?

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14934
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #1 on: June 25, 2012, 06:07:44 am »
Some others have reported this also but so far I haven't been able to reproduce it.

I did make some changes to Avahi in the last week, you might try:

1. Remove Avahi from the GUI
2. From the shell:
 pkg_delete -f avahi\*
3. Reinstall Avahi from the GUI

Then see if it behaves any better.

Also any log messages referring to Avahi at or near the time it started using a bunch of CPU might help.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline mostlyharmless

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #2 on: June 25, 2012, 04:07:50 pm »
I'll try to keep a sharp eye on it, but it seems to be the worst kind of misbehavior, the kind that doesn't have any rhyme or reason.

New problems, it's not uninstalling cleanly, and re-install is hanging at
Downloading http://files.pfsense.org/packages/8/All/python27-2.7.2_3.tbz ...  (extracting)

It freezes here, just sitting there.
I'm at a loss as to how to figure out what's going on.

Offline d_ethier

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #3 on: June 25, 2012, 05:29:38 pm »
I'll try to keep a sharp eye on it, but it seems to be the worst kind of misbehavior, the kind that doesn't have any rhyme or reason.

New problems, it's not uninstalling cleanly, and re-install is hanging at
Downloading http://files.pfsense.org/packages/8/All/python27-2.7.2_3.tbz ...  (extracting)

It freezes here, just sitting there.
I'm at a loss as to how to figure out what's going on.
I'm having the same issue right now. It will not move past the python install. I have to restart the box just to get the webConfigurator running again.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14934
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #4 on: June 25, 2012, 05:41:27 pm »
Guessing that's probably because /var is filling up on an embedded unit, not sure how it worked before, the package didn't get any bigger/smaller recently.
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline d_ethier

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #5 on: June 26, 2012, 08:31:02 am »
Guessing that's probably because /var is filling up on an embedded unit, not sure how it worked before, the package didn't get any bigger/smaller recently.

Python 2.7 is a few mb's larger, but that doesn't seem to be enough. The new package has two fewer dependencies too. Both bison and m4 are gone in the latest version.

Trying to revert back to the older version of avahi now. While it caused the CPU to spike, it did work. We need that functionality.
« Last Edit: June 26, 2012, 08:36:03 am by d_ethier »

Offline d_ethier

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #6 on: June 26, 2012, 10:41:17 am »
Guessing that's probably because /var is filling up on an embedded unit, not sure how it worked before, the package didn't get any bigger/smaller recently.

Python 2.7 is a few mb's larger, but that doesn't seem to be enough. The new package has two fewer dependencies too. Both bison and m4 are gone in the latest version.

Trying to revert back to the older version of avahi now. While it caused the CPU to spike, it did work. We need that functionality.

Also, /var seems to be fine. /dev/ufs/pfsense0 is steadily filling up though. I've been leaving the python install for about an hour and this partition has jumped from 25% to 50% utilization in that time.

Offline d_ethier

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #7 on: June 26, 2012, 02:27:52 pm »
Guessing that's probably because /var is filling up on an embedded unit, not sure how it worked before, the package didn't get any bigger/smaller recently.

Python 2.7 is a few mb's larger, but that doesn't seem to be enough. The new package has two fewer dependencies too. Both bison and m4 are gone in the latest version.

Trying to revert back to the older version of avahi now. While it caused the CPU to spike, it did work. We need that functionality.

Also, /var seems to be fine. /dev/ufs/pfsense0 is steadily filling up though. I've been leaving the python install for about an hour and this partition has jumped from 25% to 50% utilization in that time.

Alright, I left it for a few hours and the situation did not change. The interface is usable now, so I started another install. It is stalling on the perl extraction now:

  Downloading http://files.pfsense.org/packages/8/All/perl-5.12.4_3.tbz ...  (extracting)

I'll leave this part for a while and see what happens.

Offline mostlyharmless

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #8 on: June 26, 2012, 09:46:47 pm »
After I don't know what happened, it seems to have installed. Maybe a bit of "leave it alone" was all it needed, I don't know.  ??? Anyways, for the time it seems to be working at a proper level. I'll try to catch it misbehaving now.

Offline d_ethier

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #9 on: June 28, 2012, 10:21:49 am »
After I don't know what happened, it seems to have installed. Maybe a bit of "leave it alone" was all it needed, I don't know.  ??? Anyways, for the time it seems to be working at a proper level. I'll try to catch it misbehaving now.

Same here. I left the install process, came back, tried a re-install and it moved on to the perl install. Stalled again, left it, came back and tried a re-install which completed successfully. The daemon seems to be behaving now, which is good.

Nearly out of space on the /dev/ufs/pfsense0 partition, but it should be fine for awhile.

Offline jimp

  • Administrator
  • Hero Member
  • *****
  • Posts: 14934
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #10 on: July 02, 2012, 03:32:17 pm »
Nearly out of space? On what size? 512MB cf?
Need help fast? Commercial Support!

Co-Author of pfSense: The Definitive Guide. - Check the Doc Wiki for FAQs.

Do not PM for help!

Offline d_ethier

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Avahi-Daemon Process run away?
« Reply #11 on: July 09, 2012, 06:04:59 pm »
Nearly out of space? On what size? 512MB cf?

1gb. pfHacom box.

It is problematic now because on reboot I'm getting a lot of BTX halted error messages. It's hit-and-miss whether the router restarts or not.